Bug 422041

Summary: Add scroll animation on arrow keys
Product: [Applications] okular Reporter: Orestis <orestis.kapar>
Component: generalAssignee: Okular developers <okular-devel>
Status: RESOLVED FIXED    
Severity: wishlist CC: bugseforuns, hoffmann_lorenz, nate
Priority: NOR    
Version: 1.10.1   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In: 1.11.2

Description Orestis 2020-05-25 09:55:57 UTC
SUMMARY
The benefits of scroll animation are clear; it is easier for the eye to track the movement so that it does not get lost after an instant scroll.

Okular supports scroll animation with Page Up and Page Down keys. However, when using the Up and Down Arrow keys (or j/k for that matter) the animation is still instant forcing on the reader the mini-task of tracking the position.


STEPS TO REPRODUCE
1. Open a (pdf) document.
2. Press Page Down.
3. Press Page Up.
4. Press Arrow Down (or j).
5. Press Arrow Up (or k).

OBSERVED RESULT
There is a scroll animation when using Page Up/Down buttons. There is no scroll animation when using Up/Down Arrow buttons (or j/k).

EXPECTED RESULT
There is a scroll animation for any vertical or horizontal movement on the document.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.6.13-arch1-1
(available in About System)
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.70.0
Qt Version: 5.14.2

ADDITIONAL INFORMATION
Comment 1 Laura David Hurka 2020-06-08 19:38:57 UTC
I am a bit puzzled about this report. I understand it that Page Up/Down show smooth scroll animations, but Arrow Up/Down do an instant jump.

Are you a new Okular user, or can you describe the changes you observed? AFAIK smooth scrolling was added in 1.10.0 and received a fix in 1.10.1; but applies to both Page and Arrow keys.
Comment 2 Orestis 2020-06-08 19:54:35 UTC
I see that I had not stated the okular version in the initial comment; my bad. Right now `okular --version` on my system yields 1.10.1 and the issue is still present.

You stated that there should be scroll animations with both the Page and Arrow keys. Nevertheless, I am only seeing scroll animations for the Page keys. Using the Arrow keys results in instant jumps. 

Is this the intended configuration? Is it controllable in the settings? I don't think I have made any setting alterations regarding this.
Comment 3 Laura David Hurka 2020-06-08 20:22:59 UTC
I don’t think this is intended. It should be same, or reverse. I remember that I saw scroll animations for both arrow keys and page keys when I installed Okular 20.04. (Damaged my laptop then, so I can’t test it right now.)

Currently, this is not configurable.
Comment 4 Laura David Hurka 2020-06-11 21:57:18 UTC
Laptop fixed, Okular not; but I can confirm it now. No smooth scroll animation only on arrow keys.
Comment 5 Nate Graham 2020-09-11 13:59:36 UTC
Git commit c54c38f761fb79efd0d552bdb88c7977f22b3a88 by Nate Graham.
Committed on 11/09/2020 at 13:59.
Pushed by ngraham into branch 'release/20.08'.

Re-add smooth scrolling for arrow key and mouse wheel scrolling

This is safe now that the animated transitions no longer block repeated
scroll actions during the animation.

This partially reverts 08d368c13b0fa7368be9720b8de1b7a67188b8e9
Related: bug 425850
FIXED-IN: 1.11.2

M  +2    -2    ui/pageview.cpp

https://invent.kde.org/graphics/okular/commit/c54c38f761fb79efd0d552bdb88c7977f22b3a88
Comment 6 Lorenz Hoffmann 2021-08-16 09:42:04 UTC
It seems to me that this is not working anymore. I am on version 21.04.3, and there is no animation using the arrow keys (left and right), while there is an animation using the page up and down keys.
Comment 7 Laura David Hurka 2021-08-16 11:33:26 UTC
(In reply to Lorenz Hoffmann from comment #6)
> It seems to me that this is not working anymore. I am on version 21.04.3,
> and there is no animation using the arrow keys (left and right), while there
> is an animation using the page up and down keys.

IIRC this may be intentional, because it allows you to quickly compare two following pages. (Like https://en.wikipedia.org/wiki/Blink_comparator.)

If there was an animation for Left/Right Arrow in version 20.12, or the animation is missing even if the page can scroll horizontally, this is a bug. You should make a new bug report then.