Bug 421402

Summary: Plasma crashes when I change icon arrangement
Product: [Plasma] plasmashell Reporter: Patrick Silva <bugseforuns>
Component: generalAssignee: David Edmundson <kde>
Status: RESOLVED DUPLICATE    
Severity: crash CC: plasma-bugs
Priority: NOR Keywords: drkonqi
Version: master   
Target Milestone: 1.0   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Patrick Silva 2020-05-12 09:38:26 UTC
Application: plasmashell (5.18.80)

Qt Version: 5.14.2
Frameworks Version: 5.71.0
Operating System: Linux 5.3.0-45-generic x86_64
Windowing system: Wayland
Distribution: KDE neon Unstable Edition

-- Information about the crash:
- What I was doing when the application crashed:
right-click on wallpaper, hover over "Icons" > 'Arrange in", change to "Rows" or "Columns",
Plasma crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fb0d7b25800 (LWP 7814))]
[KCrash Handler]
#6  0x00007fb0d11ae564 in __memmove_sse2_unaligned_erms () at ../sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S:249
#7  0x00007fb0d5a70c8a in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/string_fortified.h:34
#8  0x00007fb0d5a70c8a in QVector<QQuickItemPrivate::ChangeListener>::realloc(int, QFlags<QArrayData::AllocationOption>) (this=this@entry=0x560dd9b9f618, aalloc=<optimized out>, options=..., options@entry=...) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qvector.h:738
#9  0x00007fb0d5a68501 in QVector<QQuickItemPrivate::ChangeListener>::detach() (this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qvector.h:411
#10 0x00007fb0d5a68501 in QVector<QQuickItemPrivate::ChangeListener>::erase(QQuickItemPrivate::ChangeListener*, QQuickItemPrivate::ChangeListener*) (aend=<optimized out>, abegin=<optimized out>, this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qvector.h:923
#11 0x00007fb0d5a68501 in QVector<QQuickItemPrivate::ChangeListener>::remove(int) (i=<optimized out>, this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qvector.h:484
#12 0x00007fb0d5a68501 in QVector<QQuickItemPrivate::ChangeListener>::removeOne(QQuickItemPrivate::ChangeListener const&) (t=..., this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qvector.h:185
#13 0x00007fb0d5a68501 in QQuickItemPrivate::removeItemChangeListener(QQuickItemChangeListener*, QFlags<QQuickItemPrivate::ChangeType>) (this=this@entry=0x560dd9b9f5a0, listener=listener@entry=0x560dda08ea10, types=..., types@entry=...) at items/qquickitem.cpp:3955
#14 0x00007fb0d5b9dada in QQuickShaderEffectSource::~QQuickShaderEffectSource() (this=0x560dda08e9f0, __in_chrg=<optimized out>) at items/qquickshadereffectsource.cpp:213
#15 0x00007fb0d5b9db39 in QQuickShaderEffectSource::~QQuickShaderEffectSource() (this=0x560dda08e9f0, __in_chrg=<optimized out>) at items/qquickshadereffectsource.cpp:218
#16 0x00007fb0a4d2567b in  () at /usr/lib/x86_64-linux-gnu/qt5/qml/QtGraphicalEffects/private/libqtgraphicaleffectsprivate.so
#17 0x00007fb0a4d20575 in  () at /usr/lib/x86_64-linux-gnu/qt5/qml/QtGraphicalEffects/private/libqtgraphicaleffectsprivate.so
#18 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd9bd1480) at kernel/qobject.cpp:2123
#19 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#20 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9bd13c0, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#21 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9bd13c0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#22 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9bd13c0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#23 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd9bd1030) at kernel/qobject.cpp:2123
#24 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#25 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9bd0f70, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#26 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9bd0f70, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#27 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9bd0f70, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#28 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd9bd0cd0) at kernel/qobject.cpp:2123
#29 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#30 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9bd0c10, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#31 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9bd0c10, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#32 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9bd0c10, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#33 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd6ff2050) at kernel/qobject.cpp:2123
#34 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#35 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9b9e250, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#36 0x00007fb0d5a8ddd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x560dd9b9e250, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#37 0x00007fb0d5a8ddd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x560dd9b9e250, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#38 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd9b9cad0) at kernel/qobject.cpp:2123
#39 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#40 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9b9ca10, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#41 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9b9ca10, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#42 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9b9ca10, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#43 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd6ff2640) at kernel/qobject.cpp:2123
#44 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#45 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9b6c6a0, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#46 0x00007fb0d5a8ddd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x560dd9b6c6a0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#47 0x00007fb0d5a8ddd5 in QQmlPrivate::QQmlElement<QQuickLoader>::~QQmlElement() (this=0x560dd9b6c6a0, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#48 0x00007fb0d1b3eceb in QObjectPrivate::deleteChildren() (this=0x560dd9b6bfc0) at kernel/qobject.cpp:2123
#49 0x00007fb0d1b482ce in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1107
#50 0x00007fb0d5a6d22d in QQuickItem::~QQuickItem() (this=0x560dd9b6bf00, __in_chrg=<optimized out>) at items/qquickitem.cpp:2383
#51 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9b6bf00, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#52 0x00007fb0d5a8dbb5 in QQmlPrivate::QQmlElement<QQuickItem>::~QQmlElement() (this=0x560dd9b6bf00, __in_chrg=<optimized out>) at ../../include/QtQml/../../src/qml/qml/qqmlprivate.h:111
#53 0x00007fb0d1b425a5 in QObject::event(QEvent*) (this=this@entry=0x560dd9b6bf00, e=e@entry=0x560dd9a473a0) at kernel/qobject.cpp:1326
#54 0x00007fb0d5a6a4db in QQuickItem::event(QEvent*) (this=0x560dd9b6bf00, ev=0x560dd9a473a0) at items/qquickitem.cpp:8162
#55 0x00007fb0d2e539ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x560dd61f5b40, receiver=receiver@entry=0x560dd9b6bf00, e=e@entry=0x560dd9a473a0) at kernel/qapplication.cpp:3685
#56 0x00007fb0d2e5abb0 in QApplication::notify(QObject*, QEvent*) (this=0x7ffd54bf0e30, receiver=0x560dd9b6bf00, e=0x560dd9a473a0) at kernel/qapplication.cpp:3431
#57 0x00007fb0d1b0f4a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x560dd9b6bf00, event=0x560dd9a473a0) at kernel/qcoreapplication.cpp:1075
#58 0x00007fb0d1b0f67e in QCoreApplication::sendEvent(QObject*, QEvent*) (receiver=receiver@entry=0x560dd9b6bf00, event=event@entry=0x560dd9a473a0) at kernel/qcoreapplication.cpp:1470
#59 0x00007fb0d1b12121 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x560dd61eab00) at kernel/qcoreapplication.cpp:1815
#60 0x00007fb0d1b126b8 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1674
#61 0x00007fb0d1b6f103 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x560dd6214130) at kernel/qeventdispatcher_glib.cpp:277
#62 0x00007fb0cad54417 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007fb0cad54650 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#64 0x00007fb0cad546dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#65 0x00007fb0d1b6e7ac in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x560dd6266840, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#66 0x00007fb0d1b0dd2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffd54bf0cc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#67 0x00007fb0d1b174a0 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1383
#68 0x0000560dd5bbb0ca in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:222

Possible duplicates by query: bug 421390, bug 421359, bug 421299, bug 420897, bug 415108.

Reported using DrKonqi
Comment 1 Patrick Silva 2020-05-13 12:36:36 UTC
Now plasma is crashing immediately after login to Wayland session.
Drkonqi says that the bug was already reported (it's this one).
Comment 2 David Edmundson 2020-05-14 09:25:26 UTC

*** This bug has been marked as a duplicate of bug 421170 ***