Bug 419853

Summary: Panel and panel widgets are too easy to accidentally delete
Product: [Plasma] plasmashell Reporter: gustavo
Component: PanelAssignee: Nate Graham <nate>
Status: RESOLVED FIXED    
Severity: normal CC: nate, rikmills
Priority: NOR Keywords: usability
Version: 5.18.4   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 5.18.5
Sentry Crash Report:
Attachments: The plasma panel is too easy to misconfigure by accident.
The plasma panel is too easy to misconfigure by accident II
The plasma panel is too easy to misconfigure by accident III

Description gustavo 2020-04-08 17:31:53 UTC
Created attachment 127392 [details]
The plasma panel is too easy to misconfigure by accident.

SUMMARY

The plasma panel is too easy to misconfigure by accident.

STEPS TO REPRODUCE
1. Right click on the panel
2. Verify that removing the panel altogether is one click away without confirmation
3. Verify that remove parts of the panel (ex: system tray, task bar) is available as the nearest option to the mouse cursor upon right click

OBSERVED RESULT

It is rather easy for users to accidentally break the initial configuration setup by system integrators.

EXPECTED RESULT

Would be great to have the same options available but in a way that protects from accidental changes. For example:

* the option to remove the panel could be hidden in the "more settings" menu (like it was in the past) or could require a user confirmation

* the option to remove panel components could perhaps be on top of the context menu rather than on the bottom


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.5

ADDITIONAL INFORMATION
Comment 1 gustavo 2020-04-08 17:32:19 UTC
Created attachment 127393 [details]
The plasma panel is too easy to misconfigure by accident II
Comment 2 gustavo 2020-04-08 17:32:48 UTC
Created attachment 127394 [details]
The plasma panel is too easy to misconfigure by accident III
Comment 3 Nate Graham 2020-04-09 17:34:45 UTC
Those are very reasonable concerns and suggestions IMO.
Comment 4 Nate Graham 2020-04-09 18:45:07 UTC
Working on this.
Comment 5 Nate Graham 2020-04-09 19:31:35 UTC
Patch submitted: https://phabricator.kde.org/D28710
Comment 6 gustavo 2020-04-10 16:37:26 UTC
@Nate,

Great work on the submitted patch. I just want to note that inside the "More options" menu the "Remove panel" option is still the nearest one to the mouse cursor. Maybe it could be not the first? (just a suggestion).

However it turns out, it is fore sure a great improvement over the current situation.

Thanks again.
Comment 7 Nate Graham 2020-04-10 16:51:51 UTC
Oh duh, good point.
Comment 8 Nate Graham 2020-04-12 18:22:31 UTC
Changed in the patch.
Comment 9 gustavo 2020-04-13 14:41:38 UTC
Thanks again Nate. Any idea if this this be on time for Kubuntu 20.04?
Comment 10 Nate Graham 2020-04-13 14:50:25 UTC
Currently that'll be up to whether the Kubuntu people decide to cherry-pick the change, as Kubuntu will ship with Plasma 5.18 and the patch is targeted for Plasma 5.19 because it changes the UI.

It's possible that this could be considered a bugfix as it doesn't add any new strings, in which case it can land for a 5.18 bugfix release, which would get it into Kubuntu with no extra packaging necessary. I can see about that.
Comment 11 gustavo 2020-04-13 15:00:52 UTC
I think Kubuntu 20.04 will be a reference release for KDE, and therefore preventing accidental misconfigurations is important. Furthermore the UI changes that removed Lock/Unlock widgets are not minor and were done so near the release date that I think the changes now introduced by your patch are quite justifiable.
Comment 12 Nate Graham 2020-04-13 17:11:18 UTC
Git commit ba66d2eabe38bc357d799bff391cf5edbce139c0 by Nate Graham.
Committed on 13/04/2020 at 17:05.
Pushed by ngraham into branch 'Plasma/5.18'.

Make accidental panel and panel widget deletion more difficult

Summary:
We make it very easy to delete panels and panel widgets--perhaps a bit too easy. User
feedback has indicated that we may need to re-work this a bit, and that perhaps D20144 was a
mistake.

This patch moves the {nav Remove Panel} button back into the {nav More} menu where it used to
be, to make it harder to accidentally click on. It also moves the {nav Remove} button for
panel widgets higher up in the menu so it's not so close to the cursor.

To adjust to these changes, the layout of buttons on the panel toolbar is changed to
preserve visual balance, and the {nav More} menu's name is adjusted to reflect the fact that
removing a panel is not a setting.
FIXED-IN: 5.18.5

Test Plan: {F8227561}

Reviewers: #vdg, #plasma, ndavis

Reviewed By: #vdg, ndavis

Subscribers: rikmills, broulik, plasma-devel

Tags: #plasma

Maniphest Tasks: T12942

Differential Revision: https://phabricator.kde.org/D28710

M  +20   -2    containments/panel/contents/ui/ConfigOverlay.qml
M  +19   -0    desktoppackage/contents/configuration/panelconfiguration/MoreSettingsMenu.qml
M  +15   -26   desktoppackage/contents/configuration/panelconfiguration/ToolBar.qml

https://commits.kde.org/plasma-desktop/ba66d2eabe38bc357d799bff391cf5edbce139c0
Comment 13 Rik Mills 2020-04-16 11:14:00 UTC
(In reply to Nate Graham from comment #10)
> Currently that'll be up to whether the Kubuntu people decide to cherry-pick
> the change, as Kubuntu will ship with Plasma 5.18 and the patch is targeted
> for Plasma 5.19 because it changes the UI.
> 
> It's possible that this could be considered a bugfix as it doesn't add any
> new strings, in which case it can land for a 5.18 bugfix release, which
> would get it into Kubuntu with no extra packaging necessary. I can see about
> that.

I certainly can't cherry pick what is arguably a UI feature change this late for 20.04.

It is also somewhat doubtful that this would be acceptable as a 'bugfix' for the 5.18.5 SRU update in a few weeks.