Bug 419329

Summary: Kirigami 5.68.0 causes virtualdesktop and regional setting KCM to crash in systemsettings
Product: frameworks-kirigami Reporter: Rik Mills <rikmills>
Component: generalAssignee: Marco Martin <notmart>
Status: RESOLVED DUPLICATE    
Severity: crash CC: fabian, hpfeil, nate, thesourcehim, vkrause
Priority: NOR    
Version: 5.68.0   
Target Milestone: Not decided   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Rik Mills 2020-03-28 10:12:46 UTC
SUMMARY

Kirigami 5.68.0 causes virtualdesktop and regional settings KCMs to crash when opened in systemnsettings

The cause has been git bisected to the following commit:

https://cgit.kde.org/kirigami.git/commit/?id=9b7cae898ed7d9b58e65035b8216ec6ff78bfa17

Launchpad bugs:

https://bugs.launchpad.net/bugs/1869280

https://bugs.launchpad.net/bugs/1869438

Backtraces:

Virtual desktop KCM:

Thread 1 "systemsettings5" received signal SIGSEGV, Segmentation fault.
0x00007ffff58661d2 in QQmlData::wasDeleted (object=0x555557858200) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:338
338     ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h: No such file or directory.
(gdb) bt
#0  0x00007ffff58661d2 in QQmlData::wasDeleted (object=0x555557858200) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:338
#1  QV4::QObjectWrapper::wrap (engine=0x555557aaff20, object=0x555557858200)
    at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4qobjectwrapper_p.h:215
#2  0x00007ffff590fbf8 in QV4::ExecutionEngine::fromVariant (this=this@entry=0x555557aaff20, variant=...) at jsruntime/qv4engine.cpp:1514
#3  0x00007ffff58638cd in searchContextProperties (v4=v4@entry=0x555557aaff20, context=context@entry=0x555557546430, name=<optimised out>, 
    hasProperty=hasProperty@entry=0x7fffffffd197, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimised out>, ep=<optimised out>)
    at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:115
#4  0x00007ffff5864770 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimised out>, id=..., receiver=<optimised out>, hasProperty=0x7fffffffd197, base=0x0, 
    lookup=0x0) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:301
#5  0x00007ffff58650b4 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x555557647490, engine=0x555557aaff20, base=0x0)
    at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:398
#6  0x00007fffbf37c365 in ?? ()
#7  0x0000000000000000 in ?? ()

Regional Settings KCMs:

Thread 1 "systemsettings5" received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x00007ffff5886418 in QQmlPropertyCache::callJSFactoryMethod (args=0x7fffffffc470, object=0x555558010e60, this=<optimised out>)
    at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/qml/qqmlpropertycache_p.h:875
#2  QV4::QObjectWrapper::create (engine=<optimised out>, object=0x555558010e60) at jsruntime/qv4qobjectwrapper.cpp:691
#3  0x00007ffff5888373 in QV4::QObjectWrapper::wrap_slowPath (engine=0x555557455e60, object=0x555558010e60) at jsruntime/qv4qobjectwrapper.cpp:616
#4  0x00007ffff590fbf8 in QV4::ExecutionEngine::fromVariant (this=this@entry=0x555557455e60, variant=...) at jsruntime/qv4engine.cpp:1514
#5  0x00007ffff58638cd in searchContextProperties (v4=v4@entry=0x555557455e60, context=context@entry=0x555557fffb70, name=<optimised out>, 
    hasProperty=hasProperty@entry=0x7fffffffc727, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimised out>, ep=<optimised out>)
    at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:115
#6  0x00007ffff5864770 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimised out>, id=..., receiver=<optimised out>, hasProperty=0x7fffffffc727, base=0x0, 
    lookup=0x0) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:301
#7  0x00007ffff58650b4 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x5555573e9a00, engine=0x555557455e60, base=0x0)
    at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:398
#8  0x00007fffc40a09b5 in ?? ()
#9  0x0000000000000000 in ?? ()


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.5
Comment 1 Fabian Vogt 2020-03-28 12:27:29 UTC
Also reported on openSUSE Leap 15.2 with Qt 5.12.7: https://bugzilla.opensuse.org/show_bug.cgi?id=1167690

It might be related a bit to https://bugs.kde.org/show_bug.cgi?id=404518
Comment 2 Nate Graham 2020-04-15 02:50:37 UTC
*** Bug 419406 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2020-04-15 02:56:39 UTC

*** This bug has been marked as a duplicate of bug 419008 ***
Comment 4 Wolfgang Bauer 2020-06-09 15:34:46 UTC
*** Bug 421107 has been marked as a duplicate of this bug. ***