Bug 419261

Summary: Language settings crash upon startup
Product: systemsettings Reporter: jz23 <home>
Component: kcm_languageAssignee: Eike Hein <hein>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kde, plasma-bugs
Priority: NOR    
Version: 5.18.3   
Target Milestone: ---   
Platform: Kubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description jz23 2020-03-26 11:29:57 UTC
ADDITIONAL INFORMATION
Application: kcmshell5 (5.18.3)

Qt Version: 5.12.5
Frameworks Version: 5.68.0
Operating System: Linux 5.4.0-20-generic x86_64
Windowing system: X11
Distribution: Ubuntu Focal Fossa (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
Opening the language settings (standalone or in the system settings)

- Unusual behavior I noticed:
Application crashes

- Custom settings of the application:
Switched the default language from German (de_DE) to English (en_US) and back again

The crash can be reproduced every time.

-- Backtrace:
Application: Modul für Systemeinstellungen (kcmshell5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f13b3482800 (LWP 24785))]

Thread 8 (Thread 0x7f139a46d700 (LWP 24792)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55f24a974fd8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55f24a974f88, cond=0x55f24a974fb0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55f24a974fb0, mutex=0x55f24a974f88) at pthread_cond_wait.c:638
#3  0x00007f13a873734b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f13a8736f5b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f139ac6e700 (LWP 24791)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55f24a974fd8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55f24a974f88, cond=0x55f24a974fb0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55f24a974fb0, mutex=0x55f24a974f88) at pthread_cond_wait.c:638
#3  0x00007f13a873734b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f13a8736f5b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f139b46f700 (LWP 24790)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55f24a974fd8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55f24a974f88, cond=0x55f24a974fb0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55f24a974fb0, mutex=0x55f24a974f88) at pthread_cond_wait.c:638
#3  0x00007f13a873734b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f13a8736f5b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f139bc70700 (LWP 24789)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55f24a974fd8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55f24a974f88, cond=0x55f24a974fb0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55f24a974fb0, mutex=0x55f24a974f88) at pthread_cond_wait.c:638
#3  0x00007f13a873734b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f13a8736f5b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f13abfff700 (LWP 24788)):
#0  0x00007f13b5c9e33d in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f13b5c5073a in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f13b5c510db in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f13b5c512e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f13b79178c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f13b78be82b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f13b76f7775 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f13b6be43a9 in QQmlThreadPrivate::run (this=0x55f24a8d4ab0) at qml/ftw/qqmlthread.cpp:148
#8  0x00007f13b76f89c2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f13b1387700 (LWP 24787)):
#0  0x00007f13b8e7f9bf in __GI___poll (fds=0x7f13a40029e0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f13b5c511ae in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f13b5c512e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f13b79178c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f13b78be82b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f13b76f7775 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f13b88c7efa in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f13b76f89c2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f13b2577700 (LWP 24786)):
#0  0x00007f13b8e7f9bf in __GI___poll (fds=0x7f13b2576ca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f13b64a1c1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f13b64a387a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f13b2d7a1a8 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f13b76f89c2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f13b67c1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f13b8e8c153 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f13b3482800 (LWP 24785)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f13b6b2c49b in QJSEnginePrivate::cache (minorVersion=-1, obj=0x55f24b2fc760, this=<optimized out>) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsapi/qjsengine_p.h:169
#8  QJSEnginePrivate::cache (minorVersion=-1, obj=0x55f24b2fc760, this=<optimized out>) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsapi/qjsengine_p.h:163
#9  QQmlData::createPropertyCache (engine=<optimized out>, object=0x55f24b2fc760) at qml/qqmlengine.cpp:2052
#10 0x00007f13b6a7044b in QV4::QObjectWrapper::create(QV4::ExecutionEngine*, QObject*) () at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/qml/qqmldata_p.h:284
#11 0x00007f13b6a72373 in QV4::QObjectWrapper::wrap_slowPath (engine=0x55f24a8f8b50, object=0x55f24b2fc760) at jsruntime/qv4qobjectwrapper.cpp:616
#12 0x00007f13b6af9bf8 in QV4::ExecutionEngine::fromVariant(QVariant const&) () at jsruntime/qv4engine.cpp:1514
#13 0x00007f13b6a4d8cd in searchContextProperties (v4=v4@entry=0x55f24a8f8b50, context=context@entry=0x55f24b332330, name=<optimized out>, hasProperty=hasProperty@entry=0x7ffe453b7aa7, base=base@entry=0x0, lookup=lookup@entry=0x0, originalLookup=<optimized out>, ep=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:115
#14 0x00007f13b6a4e770 in QV4::QQmlContextWrapper::getPropertyAndBase (resource=<optimized out>, id=..., receiver=<optimized out>, hasProperty=0x7ffe453b7aa7, base=0x0, lookup=0x0) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:301
#15 0x00007f13b6a4f0b4 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter (l=0x55f24a7d3230, engine=0x55f24a8f8b50, base=0x0) at ../../include/QtQml/5.12.5/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:398
#16 0x00007f1398523945 in ?? ()
#17 0x0000000000000000 in ?? ()
[Inferior 1 (process 24785) detached]
Comment 1 David Edmundson 2020-04-06 11:42:18 UTC

*** This bug has been marked as a duplicate of bug 419008 ***