Bug 418967

Summary: rarely, randomly mail dispatcher agent switch to "not ready" mode thus mail are not sent
Product: [Frameworks and Libraries] Akonadi Reporter: Philippe ROUBACH <philippe.roubach>
Component: Mail Dispatcher AgentAssignee: kdepim bugs <kdepim-bugs>
Status: REPORTED ---    
Severity: normal    
Priority: NOR    
Version: 5.13.2   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Philippe ROUBACH 2020-03-17 17:09:11 UTC
SUMMARY

rarely, randomly mailfilter agent switch to "not ready" mode thus mail are not sent


OBSERVED RESULT

 you can no more send any mail. 

They all stay in the outbox.

with akonadiconsole you can check that mailfilter agent is not ready. "ready" is not displayed, no state is displayed.

restart mailfilter agent then you can again send mail.

EXPECTED RESULT

 you can send any mail.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.68.0
Qt Version: 5.14.1

ADDITIONAL INFORMATION

openSuse Argon LEAP 15.1
kde app 19.12.3
Comment 1 Philippe ROUBACH 2021-01-24 10:53:03 UTC
Hello i made an error this is the mail dispatcher which gets a problem.

openSuse 15.2
kde apps 20.12.1
kde plasma 5.20.5
kde frameworks 5.78.0
qt 5.15.2

problem still there.
Comment 2 Philippe ROUBACH 2021-09-08 08:04:03 UTC
Again and again, a mail is not sent. It stays in the ouput box.

this time the mail dispatcher is "ready".

i must restart it according the mail is sent.

kde gear 21.08.1
plasma 5.22.5
framework 5.85.0
qt 5.15.2