Bug 416400

Summary: App launched while system tray settings is open has no icon in "Entries" section of system tray settings
Product: [Plasma] plasmashell Reporter: Patrick Silva <bugseforuns>
Component: System TrayAssignee: Konrad Materka <materka>
Status: RESOLVED FIXED    
Severity: normal CC: materka, nate
Priority: NOR    
Version: 5.17.90   
Target Milestone: 1.0   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In: 5.18.0

Description Patrick Silva 2020-01-18 00:26:47 UTC
STEPS TO REPRODUCE
1. open system tray settings
2. open an app with systray icon (I tested VLC, Juk player and Deluge torrent client)
3. 

OBSERVED RESULT
app launched in the step 2 has no icon in "Entries" section of systray settings.
Close and reopen systray settings: now the app launched in the step 2 has an icon in "Entries" section. 

EXPECTED RESULT
apps with systray icon always have an icon in "Entries" section of systray settings.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.17.90
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.0
Comment 1 Konrad Materka 2020-01-21 08:57:37 UTC
The situation is a little bit better, but still the issue exists. You can scroll list down and up again, icon is rendered correctly.
I've done very limited investigation, but the problem is with rendering (ListView), model is updated correctly and changes are correctly notified.
I will investigate further.
Comment 2 Konrad Materka 2020-01-22 19:36:26 UTC
Fix: https://phabricator.kde.org/D26850
Comment 3 Konrad Materka 2020-01-26 22:18:36 UTC
Git commit 3ba955f4f5c50355976424984b49b3457f11d8f1 by Konrad Materka.
Committed on 26/01/2020 at 22:18.
Pushed by kmaterka into branch 'Plasma/5.18'.

[SystemTray] Fix model update in settings (missing icon)

Summary:
Fixes a bug, when system tray settings is opened and new application is opened, view is not correctly refreshed and icon is missing. Caused by duplicated role names. Related to: D26586
FIXED-IN: 5.18.0

Test Plan:
1. Open system tray settings
2. Open an app with systray icon
Expected:
Icon, title etc are correctly rendered.

Reviewers: #plasma_workspaces, #plasma, davidedmundson, ngraham, broulik

Reviewed By: #plasma_workspaces, #plasma, davidedmundson

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D26850

M  +9    -1    applets/systemtray/systemtraymodel.cpp

https://commits.kde.org/plasma-workspace/3ba955f4f5c50355976424984b49b3457f11d8f1