Bug 415911

Summary: cannot add addressbook vCard directory
Product: [Applications] kaddressbook Reporter: Peer Frank <peer.frank>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: REPORTED ---    
Severity: major CC: KDE, rigo, tcl-kde, tokoe
Priority: NOR    
Version: 5.13.0   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: akonadi.error

Description Peer Frank 2020-01-05 23:45:54 UTC
cannot add a usable addressbook vCard directory

1. right click in pane Addressbooks / add addressbook 
2. select vCard directory (which worked before and also on an other installation)

contacts folder is displayed
but has 0 objects & size 0 and no content displayed (in the Name pane)

list of addresses

I guess some akonadi files are messed up. tried to delete but probably i have not catched the right ones or all of them.

does not work as a new user either

simply deleting the list item and adding a dir again is not the solution

opensuse TW20200103  plasma 5.17.4  FW 5.65 Qt 5.13.1 Kernel 5.3.12-2-default
Comment 1 Peer Frank 2020-01-17 09:05:38 UTC
Created attachment 125192 [details]
Comment 2 Peer Frank 2020-01-17 09:12:44 UTC
I'd like to add more info, also I could play with a new, pristine notebook for testing.
Of course I tried the published procedures of deleting the akonadi directories and akonadi* files in .local/share/,  ./config and ./cache

Also akonadictl fsck && akonadictl vacuum.
Nothing enables kaddressbook to work with imported vCard directory.

One detail was surprising (on a new TW installation): the WARNING_README.txt file was written into the home directory instead of the vCard directory

These are my findings with respect to installations: (does not work means can't import vCard dir):
TW20200111 (rolling updates, on my production box): does not work (anymore)
TW20191128 (not updated since): works
TW20200111  (fresh install): does not work
LEAP 15.1 (fresh install): works
TW20200111 updated from LEAP15.1: works
Comment 3 Peer Frank 2020-01-29 08:32:42 UTC
a message from akonadictl fsck:
Collection "akonadi_vcarddir_resource_22" (id: 58) has no RID.
Comment 4 Rigo Wenning 2020-03-02 14:13:55 UTC
I can confirm this with TW20200201. I will try to import with the import wizard
Comment 5 Rigo Wenning 2020-03-02 14:24:48 UTC
I used the import function of the kaddressbook. This imported the data without problems and it is now available in akonadi. Fun fact: There is no duplication of data on the disk.
Comment 6 Peer Frank 2020-03-02 15:12:55 UTC
thank you for the feedback.
Interesting, I have no import options for vcard directories, nor an import wizard.
Hence, I still cannot import a vcard directory (anymore).
KAddressbook 5.13.2 meanwhile. I'm puzzled since it works flawless on a laptop with a different installation history (as described).
Comment 7 Rigo Wenning 2020-03-02 16:00:49 UTC
You DO have import functions: File > import > Import vCard ... 
Go to the folder specified in the vCard directory resource that does not work. 
(the directory specified in your akonadi_vcarddir_resource_22)
Select the filter for "all files" as the names in that directory have no extension. 
Mark all files except Warning_Readme.txt
Click "Open"
Chose the addressbook that did not work automatically
(in your case the resource name of "akonadi_vcarddir_resource_22")
click Ok
see contacts being imported. 
see your addressbook being populated correctly and usable immediately. 
As I said: Fun fact is that the number of files in that directory does not change at all, so this is a pure database operation it seems. Importing into the calender of that same vcarddir that you import from does not duplicate the entries :)

This is a hack, so it does not solve the bug, but is a first rescue mechanism.
Comment 8 Peer Frank 2020-03-02 16:27:41 UTC
Thank you Rigo, THAT did the trick. So easy :-)
Comment 9 Rigo Wenning 2020-04-29 21:25:10 UTC
I have the same issue now with an iCal-Dir and I can't import as it only takes one file at a time. Stopping akonadi and starting again including stopping and starting korganizer/kontact yielded no result. 0 items in the calendar that was added, but the folder contains many ical files.
Comment 10 Michal Kec (MiK) 2020-11-15 16:03:52 UTC
I can confirm this bug with KDE Neon 5.20. It is long-standing and very annoying issue.

SW details
KAddressBook: 5.15.3 beta (20.07.80)
Operating System: KDE neon 5.20
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1

Can I help with any more details?