Bug 414171

Summary: Set values in KMail2-options are not written back
Product: [Applications] kmail2 Reporter: Harold Becker <habero>
Component: miscAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED NOT A BUG    
Severity: normal CC: montel
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: crypto-keys are not preserved in preferences
Sent-folder is not preserved in preferences
access to emailidentities
access to emaildefaults
Empty identities in file emailidentities

Description Harold Becker 2019-11-15 11:46:25 UTC
SUMMARY


STEPS TO REPRODUCE
1. Restart system
2. open KMail-Options
3. choose appropriate eMail-address at 'identities' and choose 'change'
4. first: choose 'enhanced': Folder for sent messages is not set
5. second: choose 'crypto...': in wallet present keys are not set

OBSERVED RESULT
It is no problem so set the missing values.
But at every! restart, these set values are lost.
The impression is, that online set values (finished with) 'take over' are not written back.

EXPECTED RESULT
Set values are written back and are present after a restart or cold start.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: openSUSE Leap 15.1 64-bit / 5.12.8
Kernel-Version: 4.12.15-lp151.28.32-default
KDE Plasma Version: 5.12.8
KDE Frameworks Version: 5.55.0
Qt Version: 5.9.7

ADDITIONAL INFORMATION
This problem persists since several versions of openSUSE (at least since openSUSE 13.x).
For further information or attachments (screenshots), please contact me.
A workaround was, to edit options-file (that is no solution for less expierienced users!).
Comment 1 Laurent Montel 2019-11-15 12:15:00 UTC
Hi
I don't understand your problem.
Could you provide screenshot where are the pb please ?
thanks
Comment 2 Harold Becker 2019-11-15 14:26:08 UTC
Created attachment 123941 [details]
crypto-keys are not preserved in preferences
Comment 3 Harold Becker 2019-11-15 14:28:11 UTC
Created attachment 123942 [details]
Sent-folder is not preserved in preferences
Comment 4 Harold Becker 2019-11-15 14:31:03 UTC
Hello,

Thank you for your rapid answer.

See added attached screenshots.


Best wishes
Harold Becker

------------------------------
Am Freitag, 15. November 2019, 13:15:00 CET schrieb Laurent Montel:
> https://bugs.kde.org/show_bug.cgi?id=414171
>
> Laurent Montel <montel@kde.org> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> CC|                            |montel@kde.org
>
> --- Comment #1 from Laurent Montel <montel@kde.org> ---
> Hi
> I don't understand your problem.
> Could you provide screenshot where are the pb please ?
> thanks
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 5 Laurent Montel 2019-11-15 15:00:14 UTC
I don't understand why it's not stored for you
Could you look at in "~/.config/emailidentities" when you close your kmail if it's store.
open kmail -> change settings -> quit kmail -> verify if this file is changed.
Comment 6 Laurent Montel 2019-11-17 12:13:09 UTC
(In reply to Laurent Montel from comment #5)
> I don't understand why it's not stored for you
> Could you look at in "~/.config/emailidentities" when you close your kmail
> if it's store.
> open kmail -> change settings -> quit kmail -> verify if this file is
> changed.

did you verify it ?
Comment 7 Harold Becker 2019-11-17 13:18:53 UTC
Hello,

I verified it in the past.
No actual change of this file when kmail is closed.
No change, when clicking on 'OK' or 'Anwenden' (=apply) (please excuse the
German word, but I am running my Linux with the locale Germany - same excuse
for all these screencopies, I attached).
That took place in every situation I changed the preferences (when I had to
change the insufficient preferences*). Changes are used by kmail as long as it
is running. Changes are forgotten, when kmail ist closed.
*) I already know, which preferences are to be changed when kmail is started
again (see P.S., why I am hesitating to edit this file, even though I know
what is missing).


Best Wishes
Harold Becker

P.S.:
The only thing, that brought changes, was an active editing of this file.
But I think, such an action is error-prone.
And I do not really know, which form of entry is correct.

------------------------------
Am Sonntag, 17. November 2019, 13:13:09 CET schrieb Laurent Montel:
> https://bugs.kde.org/show_bug.cgi?id=414171
>
> --- Comment #6 from Laurent Montel <montel@kde.org> ---
> (In reply to Laurent Montel from comment #5)
>
> > I don't understand why it's not stored for you
> > Could you look at in "~/.config/emailidentities" when you close your kmail
> > if it's store.
> > open kmail -> change settings -> quit kmail -> verify if this file is
> > changed.
>
> did you verify it ?
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 8 Christophe Marin 2019-11-17 19:30:44 UTC
Are the ~/.config/emailidentities permissions correct? (ie: are you owner and allowed to write in this file)
Comment 9 Harold Becker 2019-11-17 21:17:51 UTC
Created attachment 123976 [details]
access to emailidentities
Comment 10 Harold Becker 2019-11-17 21:24:30 UTC
Hallo.

Owner is root, but others have read/write-access (see attachment).


Best wishes
Harold

P.S.:
Why the application Kmail2 is not writing an own file emailidentities when
installed (with appropriate access rights)?
Why does Kmail2 is not announcing the impossibility accessing emailidentities
(when owner and access rights are not sufficient)?
The preferences are so essential for Kmail2. But failing is not told to user!

------------------------------
Am Sonntag, 17. November 2019, 20:30:44 CET schrieb Christophe Giboudeaux:
> https://bugs.kde.org/show_bug.cgi?id=414171
>
> --- Comment #8 from Christophe Giboudeaux <christophe@krop.fr> ---
> Are the ~/.config/emailidentities permissions correct? (ie: are you owner
> and allowed to write in this file)
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 11 Laurent Montel 2019-11-18 06:20:14 UTC
Git commit 52ef93b5ee064f52a93b05038b078b14f39be066 by Laurent Montel.
Committed on 18/11/2019 at 06:19.
Pushed by mlaurent into branch 'release/19.12'.

Warn if emailsidentity we can't write in this config file

M  +3    -0    src/identitymanager.cpp

https://commits.kde.org/kidentitymanagement/52ef93b5ee064f52a93b05038b078b14f39be066
Comment 12 Harold Becker 2019-11-18 07:29:52 UTC
Good morning.

Thank you for your answer.
What shall this answer tell me?
Is this the full path? What does M and +3 and 0 mean?

I am an end user. As I am a little bit familiar with IT, most of this sparse
answers can be interpreted by me. But the now presented sparingness is to
much.

Is bugs.kde.org only for IT specialists?


Best wishes
Harold Becker

------------------------------
Am Montag, 18. November 2019, 07:20:14 CET schrieb Laurent Montel:
> https://bugs.kde.org/show_bug.cgi?id=414171
>
> --- Comment #11 from Laurent Montel <montel@kde.org> ---
> Git commit 52ef93b5ee064f52a93b05038b078b14f39be066 by Laurent Montel.
> Committed on 18/11/2019 at 06:19.
> Pushed by mlaurent into branch 'release/19.12'.
>
> Warn if emailsidentity we can't write in this config file
>
> M  +3    -0    src/identitymanager.cpp
>
> https://commits.kde.org/kidentitymanagement/52ef93b5ee064f52a93b05038b078b14
> f39be066
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 13 Christophe Marin 2019-11-18 09:09:33 UTC
(In reply to Harold Becker from comment #10)
> Hallo.
> 
> Owner is root, but others have read/write-access (see attachment).
> 
> 
> Best wishes
> Harold
> 
> P.S.:
> Why the application Kmail2 is not writing an own file emailidentities when
> installed (with appropriate access rights)?

My guess is that you tried to start akonadi (or KMail) using sudo.

You can run `sudo chown $USER ~/.config/emaildefaults` to get back write access to this file.

> Why does Kmail2 is not announcing the impossibility accessing emailidentities
> (when owner and access rights are not sufficient)?
> The preferences are so essential for Kmail2. But failing is not told to user!

That's what https://bugs.kde.org/show_bug.cgi?id=414171#c11 is about. A warning will be logged if the permissions are wrong.
Comment 14 Harold Becker 2019-11-18 09:54:41 UTC
Created attachment 123983 [details]
access to emaildefaults
Comment 15 Harold Becker 2019-12-05 10:31:16 UTC
Created attachment 124327 [details]
Empty identities in file emailidentities

Hello,
what's about the identities in emaildentities shown by attachment?
Shown empty identities are only a little view of hundreds of empty identities.
That are no emailidentities I entered. They inflate the file for what?
Best wishes
Harold Becker
Comment 16 Harold Becker 2020-01-13 08:24:38 UTC
Changing access rights solved problem.
Comment 17 Christoph Feck 2020-02-06 18:10:16 UTC
Harold, could you please clarify if this ticket should get closed after comment 16?
Comment 18 Harold Becker 2020-02-06 18:58:38 UTC
ticket may be closed.
Comment 19 Christoph Feck 2020-02-06 19:39:33 UTC
Thanks for the update; changing status.