Bug 413442

Summary: kscreenlocker crashes after several hours of idle time
Product: [Plasma] kscreenlocker Reporter: Steve <stevmc>
Component: greeterAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED WORKSFORME    
Severity: crash CC: bhush94, nate, ndrzj1gbo, rpedrica
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Slackware   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Console output from manually starting kscreenlocker_greet with --testing option

Description Steve 2019-10-25 13:44:06 UTC
Created attachment 123479 [details]
Console output from manually starting kscreenlocker_greet with --testing option

SUMMARY
kscreenlocker crashes after several hours of idle time

STEPS TO REPRODUCE
1. Screen Locking configured to start automatically after 20 minutes
2. Unlocking without password setting: 300 seconds
3. After waking from sleep: not set
4. Appearance settings follows in steps 5-10 below
5. Media controls: set Show
6. Wallpaper type: Slideshow
7. Positioning: Scaled and Cropped
8. Order: Random
9. Change every: 0 hours 2 minutes 0 seconds
10. All 22 stock wallpapers are selected

OBSERVED RESULT
After several hours of idle (~ 6 to 8 hours) the screen locker crashes with below message.
“The screen locker is broken and unlocking is not possible anymore. In order to unlock switch to a virtual terminal (e.g. Ctrl+Alt+F2), log in as root and execute the command:
# ck-unlock-session <session-name>”

EXPECTED RESULT
No crash. Continued operation.


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Slackware/14.2 -current
(available in About System)
KDE Plasma Version: 5.17.0
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1

ADDITIONAL INFORMATION
package: kscreenlocker-5.17.0-x86_64-1alien
(behavior not observed in previous package kscreenlocker-5.16.5-x86_64-1alien and can be remedied by installing it)
This behavior appears related to bugs 405219 and 371175.
When disabling the automatic start and manually starting kscreenlocker with:
"/usr/lib64/kscreenlocker_greet --testing" a segmentation fault will occur. The console output which precedes the seg fault is added as an attachment.
Some relevant system log output in /var/log/messages:
Oct 24 06:40:50 kiai dbus-daemon[1777]: [session uid=1000 pid=1775] Successfully activated service 'org.kde.runners.baloo'
Oct 24 07:00:01 kiai -- MARK --
Oct 24 07:20:01 kiai -- MARK --
Oct 24 07:40:01 kiai -- MARK --
Oct 24 08:00:01 kiai -- MARK --
Oct 24 08:20:01 kiai -- MARK --
Oct 24 08:40:01 kiai -- MARK --
Oct 24 09:00:01 kiai -- MARK --
Oct 24 09:20:01 kiai -- MARK --
Oct 24 09:40:01 kiai -- MARK --
Oct 24 10:00:01 kiai -- MARK --
Oct 24 10:20:01 kiai -- MARK --
Oct 24 10:40:01 kiai -- MARK --
Oct 24 11:00:01 kiai -- MARK --
Oct 24 11:20:01 kiai -- MARK --
Oct 24 11:40:01 kiai -- MARK --
Oct 24 12:00:01 kiai -- MARK --
Oct 24 12:20:01 kiai -- MARK --
Oct 24 12:40:01 kiai -- MARK --
Oct 24 13:00:01 kiai -- MARK --
Oct 24 13:09:02 kiai kernel: [191359.983592] kscreenlocker_g[25671]: segfault at 7f7e20008eb8 ip 00007f7b52abce00 sp 00007fffa506cfb0 error 4 in libQt5Core.so.5.13.1[7f7b528ed000+2d3000]
Comment 1 Robby Pedrica 2019-10-26 06:37:30 UTC
Confirming this issue - segfaults from my system:

Oct 25 07:27:30 xxx kernel: [168827.862669] kscreenlocker_g[25294]: segfault at 7fadd0416ee8 ip 00007fad06a3de00 sp 00007fff72e80100 error 4 in libQt5Core.so.5.13.1[7fad0686e000+2d3000]
Oct 25 07:27:31 xxx kernel: [168828.470788] kscreenlocker_g[22986]: segfault at 18027ced82 ip 00007f29e9656e00 sp 00007ffef2430100 error 4 in libQt5Core.so.5.13.1[7f29e9487000+2d3000]
Oct 25 08:02:31 xxx kernel: [170928.836649] kscreenlocker_g[23008]: segfault at 1801b3abe0 ip 00007f56fdca9e00 sp 00007fff2f98dd10 error 4 in libQt5Core.so.5.13.1[7f56fdada000+2d3000]
Oct 25 08:43:10 xxx kernel: [173367.358983] kscreenlocker_g[31088]: segfault at 101da22a8 ip 00007fe1c16f5e00 sp 00007fffe7ac7750 error 4 in libQt5Core.so.5.13.1[7fe1c1526000+2d3000]
Oct 25 08:43:10 xxx kernel: [173367.976010] kscreenlocker_g[31106]: segfault at 1801d69ca2 ip 00007f464f837e00 sp 00007ffc90ef3500 error 4 in libQt5Core.so.5.13.1[7f464f668000+2d3000]

Same config as OP.
Comment 2 Steve 2019-10-28 11:58:33 UTC
Over the weekend this same issue resurfaced with the previous screen locker package kscreenlocker-5.16.5-x86_64-1alien. I had incorrectly assumed that this was associated with the kscreenlocker package code. The frequency of the crash is a lot higher and regular with the newer (5.17.0) package. I will leave the 5.16.5 installed for now but if I experience another crash I will try reverting the plasma-workspace package.
Comment 3 Nate Graham 2021-06-21 23:08:24 UTC
Please attach a backtrace of the crash. See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports

Thanks!
Comment 4 Bug Janitor Service 2021-07-06 04:33:54 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2021-07-21 04:33:38 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!