Bug 413204

Summary: [Possibly kio component][mtp] Dolphin doesn't re-read the state of the same mtp device, after reconnecting the device.
Product: kio-extras Reporter: Jakub Strzelecki <kubast2>
Component: MTPAssignee: Elvis Angelaccio <elvis.angelaccio>
Status: RESOLVED DUPLICATE    
Severity: normal CC: elvis.angelaccio, kfm-devel, ossi, sitter
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jakub Strzelecki 2019-10-19 18:21:24 UTC
SUMMARY
I have observed as an end-user that the mtp doesn't work when reconnecting the device, restarting the application is the user-side workaround I use for now.

STEPS TO REPRODUCE
1. Open dolphin. 
2. Connect mtp device. (mtp mode selected)
3. Do any action.
4. Reconnect mtp device. (mtp mode selected)

OBSERVED RESULT
The device is there, but contents of the mtp device are empty(no sdcard, no internal storage).
I have to restart dolphin to make it work.

EXPECTED RESULT
The device and it is contents are available without having to restart dolphin.

SOFTWARE/OS VERSIONS
Windows: ----
macOS: ----
Linux/KDE Plasma: 5.3.5
(available in About System)
KDE Plasma Version: 5.17.0
KDE Frameworks Version:  5.63.0
Qt Version: 5.13.1

ADDITIONAL INFORMATION
Comment 1 Jakub Strzelecki 2019-10-19 18:24:38 UTC
I have done couple of tests, it just happens randomly on reconnection, there doesn't seem to be any form of a strong pattern.
Comment 2 Oswald Buddenhagen 2021-10-03 16:38:37 UTC
possibly duplicated by Bug 440794 (which has a possibly useful log).
Comment 3 Harald Sitter 2022-01-06 12:51:07 UTC

*** This bug has been marked as a duplicate of bug 440794 ***