Bug 411421

Summary: latte-dock freezes on virtual desktop change
Product: lattedock Reporter: Ruben Bakker <ruben>
Component: applicationAssignee: Michail Vourlakos <mvourlakos>
Status: RESOLVED UPSTREAM    
Severity: critical CC: whatever2346
Priority: NOR    
Version: git (master)   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Ruben Bakker 2019-08-29 14:08:59 UTC
SUMMARY

As of this morning, latte-dock freezes immediately when I switch virtual desktops by using a keyboard shortcut, and more intermittently when switching through mouse scroll on desktop. When running latte in debug mode with -d, it displays some information about Plasma::Types related to edges, then "Expected JSON property "X-Plasma-Provides" to be a single string. but it is a stringlist." After that, the entire latte-dock becomes unresponsive and freezes (as seen by seconds counter in clock). Latte-dock behaves normally when staying in one virtual desktop. 

What I tried to fix it:

- The only difference since yesterday (when it was working fine) and this morning is an updated arch linux kernel, but I've already tried downgrading, but it had no effect.

- I tried to purge and completely reinstall (even removing config files) latte-dock. I also cleared the latte QML cache multiple times.

- I tried to reset the compositor settings for kwin (Desktop Behavior/Desktop Effects

- I tried to disable Kwin Grid-Tiling script

- I tried to disable compositor

Only thing left to try is a full reinstall, which I would like to prevent. 

STEPS TO REPRODUCE
1. switch virtual desktop down
2. see frozen latte-dock
3. wait 3-5 minutes, latte-dock becomes responsive (and responds to commands issued earlier, so mashing a few buttons then executes)

OBSERVED RESULT

latte-dock freezes and is unresponsive for about 3-5 minutes.

EXPECTED RESULT

latte-dock resumes normal operation even when switching virtual desktops.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.16
Qt: 5.13.0
KDE Frameworks: 5.61.0

ADDITIONAL INFORMATION (added some comments after |||)

[debug 15:47:20.553553] -  -------- ||| Here we switch virtual desktop
[debug 15:47:20.553553] - 0 .  "DP-2"  -  Plasma::Types::TopEdge
[debug 15:47:20.553553] - 1 .  "DP-2"  -  Plasma::Types::BottomEdge
[debug 15:47:20.553553] -  -------- sorted -----
[debug 15:47:20.553553] - 0 .  false  -  "DP-2"  -  Plasma::Types::BottomEdge
[debug 15:47:20.553553] - 1 .  false  -  "DP-2"  -  Plasma::Types::TopEdge
[warning 15:47:20.553553] - Expected JSON property "X-Plasma-Provides" to be a single string. but it is a stringlist ||| IT FREEZES HERE
[warning 15:47:50.594594] - QProcess: Destroyed while process ("kreadconfig5") is still running. ||| Every few minutes
[warning 15:48:50.728728] - QProcess: Destroyed while process ("kreadconfig5") is still running. ||| Every few minutes
[warning 15:49:50.938938] - QProcess: Destroyed while process ("kreadconfig5") is still running. ||| Every few minutes
[warning 15:50:20.996996] - QXcbClipboard::setMimeData: Cannot set X11 selection owner ||| Included this to show recovery time. This is not related and can be any other message.
Comment 1 Ruben Bakker 2019-08-29 14:53:00 UTC
I want to add that it seems to not happen when using the pager plasmoid, or only very rarely when using the mouse scroll on desktop. It ALWAYS immediately happens when I use a keyboard shortcut. (Plasma Settings>Shortcuts>Global Shortcuts>Kwin>Switch One Desktop Down/Up/Left/Right.

Here is a video through streamable: https://streamable.com/5e4uk
Comment 2 Ruben Bakker 2019-08-29 14:56:19 UTC
coincidentally, this morning another very similar issue was posted by another user: https://bugs.kde.org/show_bug.cgi?id=411415
Comment 3 Ruben Bakker 2019-08-29 15:24:39 UTC
more information. it happens when I press modifier key super/windows for an extended period of time too.
Comment 4 Michail Vourlakos 2019-08-29 15:58:25 UTC
1. Run Latte with default layout, latte-dock --default-layout is the problem remain?
Comment 5 Ruben Bakker 2019-08-29 16:11:54 UTC
Yes, with "latte-dock --default-layout" same issue persists, but output is slightly different:

[debug 18:10:24.057057] -  -------- 
[debug 18:10:24.057057] - 0 .  "DP-2"  -  Plasma::Types::BottomEdge
[debug 18:10:24.057057] -  -------- sorted -----
[debug 18:10:24.057057] - 0 .  false  -  "DP-2"  -  Plasma::Types::BottomEdge
[warning 18:10:24.057057] - Expected JSON property "X-Plasma-Provides" to be a single string. but it is a stringlist
[warning 18:10:24.057057] - Expected JSON property "X-Plasma-Provides" to be a single string. but it is a stringlist


I also tried to install and build from source through AUR latte-dock-git, latest version. But no luck.
Comment 6 Ruben Bakker 2019-08-29 16:14:47 UTC
To confirm, It happens in any situation where windows/meta/super key is pressed for more than 1 second.
Comment 7 Michail Vourlakos 2019-08-29 16:22:10 UTC
(In reply to Ruben Bakker from comment #6)
> To confirm, It happens in any situation where windows/meta/super key is
> pressed for more than 1 second.

Sorry, I have no idea why this occurs in your system, the debug messages are irrelevant
Comment 8 Ruben Bakker 2019-08-30 09:11:49 UTC
completely fresh, newly installed arch linux, still the same issue. I am not the only one. https://bugs.kde.org/show_bug.cgi?id=411415#c4
Comment 9 Michail Vourlakos 2019-08-30 10:44:39 UTC
(In reply to Ruben Bakker from comment #8)
> completely fresh, newly installed arch linux, still the same issue. I am not
> the only one. https://bugs.kde.org/show_bug.cgi?id=411415#c4

something was updated in Arch in that as mentioned also in the referenced bug report does not break only Latte but plenty other Plasma/Qt apps. You can hope that Arch will find a fix or something...
Comment 10 Ruben Bakker 2019-08-30 10:51:21 UTC
Thank you Michail.
Comment 12 Ruben Bakker 2019-08-31 14:58:48 UTC
Thanks, I'll follow that discussion.
Comment 13 whatever2346 2019-08-31 19:11:08 UTC
(In reply to Michail Vourlakos from comment #9)
> (In reply to Ruben Bakker from comment #8)
> > completely fresh, newly installed arch linux, still the same issue. I am not
> > the only one. https://bugs.kde.org/show_bug.cgi?id=411415#c4
> 
> something was updated in Arch in that as mentioned also in the referenced
> bug report does not break only Latte but plenty other Plasma/Qt apps. You
> can hope that Arch will find a fix or something...

i also ran into this issue recently. triggers when superkey is held down to show dock/switch to a task using global shortcuts. latte will freeze. the relevant behavior mentioned in the thread you linked to occurs only when latte has frozen first and will cease to be a problem once latte is killed/restarted until it freezes again.
Comment 14 whatever2346 2019-08-31 19:13:41 UTC
(In reply to whatever2346 from comment #13)
> (In reply to Michail Vourlakos from comment #9)
> > (In reply to Ruben Bakker from comment #8)
> > > completely fresh, newly installed arch linux, still the same issue. I am not
> > > the only one. https://bugs.kde.org/show_bug.cgi?id=411415#c4
> > 
> > something was updated in Arch in that as mentioned also in the referenced
> > bug report does not break only Latte but plenty other Plasma/Qt apps. You
> > can hope that Arch will find a fix or something...
> 
> i also ran into this issue recently. triggers when superkey is held down to
> show dock/switch to a task using global shortcuts. latte will freeze. the
> relevant behavior mentioned in the thread you linked to occurs only when
> latte has frozen first and will cease to be a problem once latte is
> killed/restarted until it freezes again.

to clarify: for me, no parts of kde plasma show any problems until latte freezes. then various other things freeze as well, like file renaming on plasma desktop.
Comment 15 Michail Vourlakos 2019-08-31 19:20:35 UTC
sorry but this is as far as I can help. I don't have any such issue in Tumbleweed. Possibly it will be open for long until more info or ways to reproduce to other systems appear
Comment 16 Ruben Bakker 2019-09-05 06:59:24 UTC
for sake of completeness, crossposting my comment here as well:

I can also confirm the issue is with ostree. Downgrading it solved my problem as well. 

when pressing super/meta key for a period longer than 1 second, latte dock pops up and shows pinned applications and their respective shortcut keys.

This is the exact behavior that does not happen when ostree is at latest version, it hangs before it shows the dock + shortcuts.
Comment 17 Michail Vourlakos 2019-09-05 11:12:49 UTC
ok, this is upstream and should influence plenty plasma cases and ostree cases...