Bug 410376

Summary: x2go plasma session crash when starting
Product: [Plasma] krunner Reporter: Samuel Bernardo <samuelbernardo.mail>
Component: generalAssignee: Kai Uwe Broulik <kde>
Status: RESOLVED WORKSFORME    
Severity: crash CC: alexander.lohnau
Priority: NOR Keywords: drkonqi
Version: 5.16.3   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Samuel Bernardo 2019-07-29 21:41:53 UTC
Application: krunner (5.16.3)
 (Compiled from sources)
Qt Version: 5.12.4
Frameworks Version: 5.60.0
Operating System: Linux 4.19.60-gentoo-zerg x86_64
Distribution: "Gentoo Base System release 2.6"

-- Information about the crash:
- What I was doing when the application crashed:
I was starting a kde session in x2go

This topic is related to the bug:
https://bbs.archlinux.org/viewtopic.php?id=168667

-- Backtrace:
Application: krunner (krunner), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff8cb590880 (LWP 14579))]

Thread 3 (Thread 0x7ff8c3fff700 (LWP 14659)):
#0  0x00007ff8d0edbf7b in poll () from /lib64/libc.so.6
#1  0x00007ff8cf0173ae in g_main_context_iterate.isra () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff8cf0174cc in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff8d146fc3b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007ff8d141aa8b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007ff8d1282ce6 in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007ff8d1bf95a5 in QDBusConnectionManager::run() () from /usr/lib64/libQt5DBus.so.5
#7  0x00007ff8d1283f71 in QThreadPrivate::start(void*) () from /usr/lib64/libQt5Core.so.5
#8  0x00007ff8cfdab508 in start_thread () from /lib64/libpthread.so.0
#9  0x00007ff8d0ee846f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff8c8f97700 (LWP 14595)):
#0  0x00007ff8d0edbf7b in poll () from /lib64/libc.so.6
#1  0x00007ff8d08c381f in _xcb_conn_wait () from /usr/lib64/libxcb.so.1
#2  0x00007ff8d08c54da in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007ff8caf22118 in QXcbEventQueue::run() () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007ff8d1283f71 in QThreadPrivate::start(void*) () from /usr/lib64/libQt5Core.so.5
#5  0x00007ff8cfdab508 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff8d0ee846f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff8cb590880 (LWP 14579)):
[KCrash Handler]
#6  0x00007ff8d0e162db in raise () from /lib64/libc.so.6
#7  0x00007ff8d0dff535 in abort () from /lib64/libc.so.6
#8  0x00007ff8d124bb6d in QMessageLogger::fatal(char const*, ...) const () from /usr/lib64/libQt5Core.so.5
#9  0x00007ff8c8763d28 in QGLXContext::init(QXcbScreen*, QPlatformOpenGLContext*) [clone .cold.52] () from /usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so
#10 0x00007ff8c87641f7 in QXcbGlxIntegration::createPlatformOpenGLContext(QOpenGLContext*) const () from /usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so
#11 0x00007ff8caef9576 in QXcbIntegration::createPlatformOpenGLContext(QOpenGLContext*) const () from /usr/lib64/libQt5XcbQpa.so.5
#12 0x00007ff8d181407d in QOpenGLContext::create() () from /usr/lib64/libQt5Gui.so.5
#13 0x00007ff8c8767381 in QGLXContext::queryDummyContext() () from /usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so
#14 0x00007ff8c8767c59 in QGLXContext::supportsThreading() () from /usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so
#15 0x00007ff8d2b79ad5 in QSGRenderLoop::instance() () from /usr/lib64/libQt5Quick.so.5
#16 0x00007ff8d2bf17ea in QQuickWindowPrivate::init(QQuickWindow*, QQuickRenderControl*) () from /usr/lib64/libQt5Quick.so.5
#17 0x00007ff8d2f044de in PlasmaQuick::Dialog::Dialog(QQuickItem*) () from /usr/lib64/libKF5PlasmaQuick.so.5
#18 0x000055ea58c8195e in View::View(QWindow*) ()
#19 0x000055ea58c7fda1 in main ()
[Inferior 1 (process 14579) detached]

The reporter indicates this bug may be a duplicate of or related to bug 394521.

Possible duplicates by query: bug 394521.

Reported using DrKonqi
Comment 1 Kai Uwe Broulik 2019-07-30 06:39:41 UTC
Can you confirm plasmashell comes up fine and shows a "software rendering in use" tray icon?

That linked topic doesn't seem related at all, and is also about Plasma 4.