Bug 409403

Summary: akonadiserver crashes immediately
Product: [Frameworks and Libraries] Akonadi Reporter: Luca Weiss <luca>
Component: serverAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 5.11.2   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Luca Weiss 2019-07-02 09:48:24 UTC
SUMMARY
After the upgrade to Qt 5.13, Akonadi is crashing all the time and is unusable.


STEPS TO REPRODUCE
1. Start akonadi, e.g. open KMail or run "akonadictl start"


SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.13.0

ADDITIONAL INFORMATION
Backtrace from gdb: https://pastebin.com/raw/RJnK6s0d

Bug 408897 seems to be relatively similar but the backtrace points to a different function, so I've opened this issue.
Comment 1 Christophe Marin 2019-07-02 10:11:49 UTC
Pasting inline:

#8  0x0000564b2259d08c in QTypedArrayData<unsigned short>::deallocate (data=<optimized out>)
    at /usr/include/qt/QtCore/qarraydata.h:236
#9  QString::~QString (this=0x7f924c01c060, __in_chrg=<optimized out>) at /usr/include/qt/QtCore/qstring.h:1133
#10 QHashNode<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::~QHashNode (this=0x7f924c01c050, 
    __in_chrg=<optimized out>) at /usr/include/qt/QtCore/qhash.h:149
#11 QHash<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::deleteNode2 (node=0x7f924c01c050)
    at /usr/include/qt/QtCore/qhash.h:547
#12 QHash<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::deleteNode (this=0x564b2369f3f0, node=0x7f924c01c050)
    at /usr/include/qt/QtCore/qhash.h:537
#13 QHash<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::erase (this=this@entry=0x564b2369f3f0, it=..., 
    it@entry=...) at /usr/include/qt/QtCore/qhash.h:874
#14 0x0000564b2259b55b in QHash<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::erase (it=..., 
    this=0x564b2369f3f0) at /usr/include/qt/QtCore/qhash.h:477
#15 Akonadi::Server::ItemRetrievalManager::processRequest (this=0x564b2369f3c0)
    at /usr/src/debug/akonadi-19.04.2/src/server/storage/itemretrievalmanager.cpp:184
Comment 2 Luca Weiss 2019-07-30 19:30:15 UTC

*** This bug has been marked as a duplicate of bug 409224 ***