Bug 402387

Summary: Let's talk about Plasma usability on the plain old PC desktop
Product: plasmashell Reporter: Artem S. Tashkinov <aros>
Component: PanelAssignee: Plasma Bugs List <plasma-bugs>
Status: CLOSED NOT A BUG    
Severity: grave CC: kde
Priority: NOR    
Version: master   
Target Milestone: 1.0   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: XFCE Task Bar

Description Artem S. Tashkinov 2018-12-20 16:16:53 UTC
I'm really interested in understanding the reasoning behind the Plasma project and its applicability to the plain old desktop PC. Let me explain myself. Most PC users never look at the desktop for extended periods of time and their interaction with the desktop begins and ends with applications links, files and folders located there.

It looks like plasma developers insist that plasmoids should be a sort of wonder which the end user is supposed to marvel at. Unfortunately that's not the case. Most PC users spend next to zero time interacting with the desktop and I suspect they are much more interested in getting up-to-date information and readings from the task panel (kicker/whatever it's called nowadays).

Under KDE 3.5.x/KDE 4.x/XFCE 4/other environments I can embed the following monitors in the task panel:

1) A CPU usage monitor which monitors all cores individually (several narrow bars) and overall CPU utilization as one extra bar. There's no such plasmoid or feature for KDE 5.

2) A RAM usage monitor which shows free/occupied RAM as a simple narrow bar. There's no such plasmoid or feature for KDE 5.

3) I want something akin to KNetStats which creates icons for network interfaces *on the fly* (long unmaintained KNemo can't do that) and flashes them when there's network activity. There's no such plasmoid or feature for KDE 5.

4) I need to be able to embed certain HW sensors as simple configurable numbers, not as bars or circles which are very hard to read. There's no such plasmoid or feature for KDE 5.

5) I want to be able to see my average CPUs frequency as a number. There's no such plasmoid or feature for KDE 5.

6) I want to be able to see the output of certain commands run/updated at certain intervals, e.g. something akin to Generic Monitor from XFCE. There's no such plasmoid or feature for KDE 5.

7) I need to see the current temperature and weather conditions.

I'm now looking at what's available in KDE 5 and I cannot find anything which suits my needs. No system monitor works properly when placed in the task bar.

For some reasons these simple features are available in KDE 3.5.x, KDE 4.x and XFCE, yet KDE 5 doesn't offer anything.

Please see the attached screenshot for my XFCE configuration.
Comment 1 Artem S. Tashkinov 2018-12-20 16:18:31 UTC
Created attachment 117029 [details]
XFCE Task Bar
Comment 2 Artem S. Tashkinov 2018-12-20 16:23:56 UTC
Of course, I could file seven feature requests which will linger on for ages and will be closed due to "not enough spare time"/"resources"/"we don't think anyone will need it" but I don't want to SPAM this bugzilla with my petty requests given that KDE 5 was released over four years ago and none of the features I'm looking for are available in any state or form which is quite bleak and sad.
Comment 3 David Edmundson 2018-12-20 16:44:40 UTC
Multiple issues in one report is also not useful. 
However, I'll write a quick reply.

1) There is. System load viewer -> options -> show individual CPUs

2) Also system load viewer. 

If those don't work for you, do file a specific report explaining the problem.

As for the rest. We don't want feature requests on the bug tracker, especially for whole new plasmoids. 
 
But please see store.kde.org for more plasmoids. What we ship is not the entire ecosystem. 

I'm sure there's something for 4, there is definitely one that covers (6) that's quite good, and there are many weather applets for (7).
Comment 4 Artem S. Tashkinov 2018-12-20 19:07:55 UTC
I knew this bug report will be completely disregarded and on my part I will be completely avoiding the beautiful KDE environment.

(In reply to David Edmundson from comment #3)
> Multiple issues in one report is also not useful. 
> However, I'll write a quick reply.
> 
> 1) There is. System load viewer -> options -> show individual CPUs

Try to embed it in the system panel and tell me how absolutely unsuitable it is.

> 
> 2) Also system load viewer. 

Exactly the same issue.

> 
> If those don't work for you, do file a specific report explaining the
> problem.

I'm not gonna file seven individual reports in regard to Plasmoids which do NOT work when being embedded in the task panel. When you created them no one thought about their usability and let's STOP pretending a single line of code will be added to resolve the huge glaring issue I've identified.

> 
> As for the rest. We don't want feature requests on the bug tracker,
> especially for whole new plasmoids. 

KDE developers don't want any input in regard to the usability of KDE because you know better. Right. Exactly what I expected to hear.

>  
> But please see store.kde.org for more plasmoids. What we ship is not the
> entire ecosystem. 

You are again completely OVERLOOKING what I'm trying to say here: the task panel does NOT work for KDE 5 plasmoids and they are created PURELY to be huge tiles on the desktop.

> 
> I'm sure there's something for 4, there is definitely one that covers (6)
> that's quite good, and there are many weather applets for (7).

I will reopen this bug report one last time, so that you could at least admit that what you're saying does not pertain to the issue.
Comment 5 Christoph Feck 2018-12-20 19:10:09 UTC
Please create separate tickets.
Comment 6 Artem S. Tashkinov 2018-12-20 19:14:35 UTC
(In reply to Christoph Feck from comment #5)
> Please create separate tickets.

OK.

Please tell me what the product / component is.
Comment 7 Christoph Feck 2018-12-20 19:28:03 UTC
For issues in the system monitor: plasmashell/System Monitor
For issues in the weather widget: kdeplasma-addons/weather

As David said, we don't track new widgets requests, because there is hardly enough manpower to maintain existing widgets.

For 6) check https://github.com/lipido/kargos
Comment 8 David Edmundson 2018-12-20 22:16:35 UTC
>I knew this bug report will be completely disregarded

I spent quite a while of my time clearly reading, and wrote a reply. That is not completely disregarding anything.

>KDE developers don't want any input in regard to the usability of KDE because you know better. 

That's not what was said.
Comment 9 Artem S. Tashkinov 2018-12-22 15:38:12 UTC
(In reply to Christoph Feck from comment #7)
> For issues in the system monitor: plasmashell/System Monitor
> For issues in the weather widget: kdeplasma-addons/weather
> 
> As David said, we don't track new widgets requests, because there is hardly
> enough manpower to maintain existing widgets.

That summarizes everything.

Either someone steps up and fixes the issue I've identified (all monitoring KDE plasmoids are completely unsuitable for the taskbar) or I just don't want to bother filing close to seven bug reports which will most likely receive zero attention only to be closed 10 years later once you release KDE 6 (with "Is this still an issue?" reason). I've seen it too much in this bugzilla.

After all I've been asking to revive KNetStats for six years now. No one cares. I've been asking to revive Juk for the same amount of time. Only this year it was been finally ported to KF5 albeit it constantly crashes (tried it in Fedora which contains the last available release) and it doesn't look and behave like its KDE3 ancestor.

KSensors is all but dead and forgotten. There's no alternative in KDE4/5 - something which monitors temperatures _and_ voltages _and_ fan speeds and has a nice tiny panel with all the required sensors and which can show everything in the system tray.

Again, PC users barely interact with the desktop which is the whole premise of KDE 5 and it's silly (not that I want to hurt someone's feeling but it's just a sad fact). For some reasons Plasma was created with tablet users in mind. I suspect the whole ten people in the world use Plasma on their tablets - all others are quite content with Android and iOS.

I love some new KDE5 features but Plasma has never been one of them. It's a shiny mostly useless distraction people rarely if ever interact with and I'm quite sure core KDE developers hardly have any plasmoids running on the desktop.

> 
> For 6) check https://github.com/lipido/kargos

This must be built-in and configurable. Also this thing works as a desktop plasmoid and I'm quite sure it will completely break once being embedded in the task panel.

P.S. "CLOSED NOT A BUG" - that's an obvious falsehood but who cares.