Bug 400300

Summary: KSysGuard crashed upon close
Product: [Applications] ksysguard Reporter: Alexander Mentyu <notuxius>
Component: generalAssignee: KSysGuard Developers <ksysguard-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alexander Mentyu 2018-10-25 15:47:40 UTC
Application: ksysguard (5.14.2)

Qt Version: 5.11.2
Frameworks Version: 5.51.0
Operating System: Linux 4.19.0-1-MANJARO x86_64
Distribution: "Netrunner Rolling"

-- Information about the crash:
- What I was doing when the application crashed:
Opened KSysGuard from System Load Viewer desktop widget, after that closed KSysGuard window and it crashed

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7174a18000 (LWP 2689))]

Thread 5 (Thread 0x7f716a879700 (LWP 2694)):
#0  0x00007f71818d2afc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f716ae131ac in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f716ae12ee8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f71818cca9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f71819e6b23 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f717114f700 (LWP 2692)):
#0  0x00007f71819dbc21 in poll () at /usr/lib/libc.so.6
#1  0x00007f717af1aee0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f717af1afce in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f7180155fe4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f71801018cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f717ff4aeb9 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f7180440ba6 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007f717ff54f65 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f71818cca9d in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f71819e6b23 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f717276a700 (LWP 2691)):
#0  0x00007f71819dbc21 in poll () at /usr/lib/libc.so.6
#1  0x00007f717bbd1630 in  () at /usr/lib/libxcb.so.1
#2  0x00007f717bbd32db in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007f71738e6c5a in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f717ff54f65 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f71818cca9d in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f71819e6b23 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f7174a11700 (LWP 2690)):
#0  0x00007f71818d2afc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f717fdb7cd1 in __gthread_cond_wait (__mutex=<optimized out>, __cond=<optimized out>) at /build/gcc/src/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu/bits/gthr-default.h:864
#2  0x00007f717fdb7cd1 in std::condition_variable::wait(std::unique_lock<std::mutex>&) (this=<optimized out>, __lock=...) at /build/gcc/src/gcc/libstdc++-v3/src/c++11/condition_variable.cc:53
#3  0x00007f717ebeef14 in  () at /usr/lib/libQt5WebKit.so.5
#4  0x00007f717ebef039 in  () at /usr/lib/libQt5WebKit.so.5
#5  0x00007f717fdbe063 in std::execute_native_thread_routine(void*) (__p=0x5654535cbcd0) at /build/gcc/src/gcc/libstdc++-v3/src/c++11/thread.cc:80
#6  0x00007f71818cca9d in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f71819e6b23 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f7174a18000 (LWP 2689)):
[KCrash Handler]
#6  0x00007f717ffc8da6 in operator==(QString const&, QString const&) () at /usr/lib/libQt5Core.so.5
#7  0x00007f7180cd5358 in QLabel::setText(QString const&) () at /usr/lib/libQt5Widgets.so.5
#8  0x00007f7181b1fe15 in  () at /usr/lib/libkdeinit5_ksysguard.so
#9  0x00007f718176b5b9 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/libksgrd.so.7
#10 0x00007f7181772cd0 in  () at /usr/lib/libksgrd.so.7
#11 0x00007f718012cbd0 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#12 0x00007f71800952eb in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#13 0x00007f718009af44 in  () at /usr/lib/libQt5Core.so.5
#14 0x00007f718009b3a0 in  () at /usr/lib/libQt5Core.so.5
#15 0x00007f718012ca7c in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#16 0x00007f71801386ba in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#17 0x00007f7180138a12 in QSocketNotifier::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#18 0x00007f7180ba4e14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#19 0x00007f7180bac6e1 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#20 0x00007f7180102c39 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#21 0x00007f7180156c2b in  () at /usr/lib/libQt5Core.so.5
#22 0x00007f717af193cf in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#23 0x00007f717af1af89 in  () at /usr/lib/libglib-2.0.so.0
#24 0x00007f717af1afce in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#25 0x00007f7180155fc9 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#26 0x00007f717397ce12 in  () at /usr/lib/libQt5XcbQpa.so.5
#27 0x00007f71801018cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#28 0x00007f7180109bc6 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#29 0x00007f7181b21c23 in kdemain () at /usr/lib/libkdeinit5_ksysguard.so
#30 0x00007f718190f223 in __libc_start_main () at /usr/lib/libc.so.6
#31 0x000056545307905e in _start ()
[Inferior 1 (process 2689) detached]

Reported using DrKonqi
Comment 1 Christoph Feck 2018-10-28 04:06:38 UTC

*** This bug has been marked as a duplicate of bug 350140 ***