Bug 398013

Summary: Pinned LibreOffice icons move to the end when launching them
Product: plasmashell Reporter: David <david.cortes.rivera>
Component: Icons-only Task ManagerAssignee: Eike Hein <hein>
Status: CLOSED DUPLICATE    
Severity: normal CC: nate, pip.kde, plasma-bugs
Priority: NOR    
Version: 5.13.4   
Target Milestone: 1.0   
Platform: Debian unstable   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: LO-Icon-At-End
kde-4.14.7-launcher-matching-rules

Description David 2018-08-29 11:16:24 UTC
Steps to reproduce:
-Set task manager to the icons-only task manager.
-Pin icons for LO Writer and Calc in the task manager, but don't put them at the end after which new application icons appear.
-Launch Writer from the task manager.

Expected behavior:
-Application should open a window that is accessible under the Writer icon, right where it was put.

Actual behavior:
-The application opens under the Writer icon, but it shifts the icon towards the last (rightmost) spot in the task manager. The icon comes back to the position where it was pinned after closing Writer. Sometimes, at first it creates an additional Writer icon that appears at the end of the task manager, and later somehow it gets merged with the pinned icon.

Reproducible: most of the times.
Comment 1 Nate Graham 2018-08-29 20:19:16 UTC

*** This bug has been marked as a duplicate of bug 396871 ***
Comment 2 Paul 2018-08-30 09:35:04 UTC
Created attachment 114697 [details]
LO-Icon-At-End

@Nate

Sorry, but this is *not* fixed, at least for LibreOffice...

See yet another screen-shot illustrating the problem.

The LO icon moves to far right when the application is launched. (It's 'normal' position being between kate and digikam).
Comment 3 Paul 2018-08-30 10:50:54 UTC
Created attachment 114700 [details]
kde-4.14.7-launcher-matching-rules

An afterthought...

LibreOffice always was problematic, however the Icon Only Task Manager of (KDE) 4.x had the ability to define Launcher Matching Rules.

Perhaps that could be implemented for the current plasma 5 version?
Comment 4 Nate Graham 2018-08-30 13:47:31 UTC
I know it's not fixed. Marking this bug report as a duplicate doesn't mean that it's fixed for you, just that the issue is already tracked elsewhere.

Those two places are:
- Task Manager implements a local workaround (Bug 396871)
- LibreOffice fixes the problem (https://bugs.documentfoundation.org/show_bug.cgi?id=119202)

*** This bug has been marked as a duplicate of bug 396871 ***
Comment 5 Eike Hein 2018-09-04 12:34:01 UTC
> Perhaps that could be implemented for the current plasma 5 version?

The rules system still exists (and in fact has grown in ability).
Comment 6 Paul 2018-09-04 14:40:46 UTC
(In reply to Eike Hein from comment #5)
> The rules system still exists (and in fact has grown in ability).

By manually editing taskmanagerrulesrc ?

I doubt an average user would be aware of that...

Could you perhaps provide a link to where, if at all, it's documented?  I've only found odd references to it, mainly on github in relation to specific fixes.

Or am I barking up the wrong tree? :)
Comment 7 Eike Hein 2018-09-04 14:48:30 UTC
Sooort of :)

The rules system is there, but it's sort of a last-resort measure we use to deal with broken app for pragmatic reasons. We don't really want users to have to use it. So no effort has been made to give it a GUI or even docs, sorry.
Comment 8 Paul 2018-09-04 15:36:57 UTC
OK...  Thanks.