Bug 396996

Summary: KDE system settings crashes
Product: [Plasma] KScreen Reporter: dieter <ginschter>
Component: kcmAssignee: Sebastian K├╝gler <sebas>
Status: RESOLVED FIXED    
Severity: crash CC: nate, oliver
Priority: NOR Keywords: drkonqi
Version: 5.12.5   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In: 5.17.0

Description dieter 2018-07-30 22:02:34 UTC
Application: systemsettings5 (5.12.5)

Qt Version: 5.9.4
Frameworks Version: 5.45.0
Operating System: Linux 4.12.14-lp150.12.7-default x86_64
Distribution: "openSUSE Leap 15.0"

-- Information about the crash:
- What I was doing when the application crashed:
I've purchased a 4k Monitor (3840x2160). But KDE seems to be unable to accept this size on start up. xrandr shows the correct resolution. But I set the resolution again to 4k. In KDE system settings the resolution was set to 2560x1440. Also allows system settings to change the resolution to 4k. Sometimes it works, sometimes system setting crashes. After a crash only the 2560x1440 resolution is offered. Then I try to monitor settings, e.g. select HDMI1 and then going back to DP-1. Most times KDE system settings offers than the 4k resolution. But sometimes I can now switch to 4k, sometimes system setting crashes again.
I've noticed that KDE automatically resets the resolution to 2560x1440 when the screen was locked (I've set automatic screen lock after 15 min.)

Monitor data: ACER ET322QKwmiipx 80 cm (32")

-- Backtrace:
Application: Systemeinstellungen (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f908e3c5dc0 (LWP 21184))]

Thread 3 (Thread 0x7f906237b700 (LWP 21196)):
#0  0x00007f9089c0808b in poll () from /lib64/libc.so.6
#1  0x00007f90833f2109 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f90833f221c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f908a536c0b in QEventDispatcherGlib::processEvents (this=0x7f905c000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f908a4df09a in QEventLoop::exec (this=this@entry=0x7f906237ac70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#5  0x00007f908a30e4da in QThread::exec (this=<optimized out>) at thread/qthread.cpp:515
#6  0x00007f9087e87cb5 in ?? () from /usr/lib64/libQt5Qml.so.5
#7  0x00007f908a3130ce in QThreadPrivate::start (arg=0x5624b677e6b0) at thread/qthread_unix.cpp:368
#8  0x00007f9085808559 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9089c1282f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9071e3d700 (LWP 21187)):
#0  0x00007f9089c03b78 in read () from /lib64/libc.so.6
#1  0x00007f9083436420 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f90833f1bf7 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f90833f20b0 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f90833f221c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f908a536c0b in QEventDispatcherGlib::processEvents (this=0x7f906c000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f908a4df09a in QEventLoop::exec (this=this@entry=0x7f9071e3cc60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#7  0x00007f908a30e4da in QThread::exec (this=<optimized out>) at thread/qthread.cpp:515
#8  0x00007f908a9b6985 in ?? () from /usr/lib64/libQt5DBus.so.5
#9  0x00007f908a3130ce in QThreadPrivate::start (arg=0x7f908ac26d60) at thread/qthread_unix.cpp:368
#10 0x00007f9085808559 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f9089c1282f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f908e3c5dc0 (LWP 21184)):
[KCrash Handler]
#6  QString::QString (other=<error reading variable: Cannot access memory at address 0x10>, this=this@entry=0x7ffe69e4dc70) at /usr/include/qt5/QtCore/qstring.h:906
#7  KScreen::Mode::id (this=this@entry=0x0) at /usr/src/debug/libkscreen2-5.12.5-lp150.1.2.x86_64/src/mode.cpp:69
#8  0x00007f90625e5d28 in OutputConfig::slotResolutionChanged (this=0x5624b68cc580, size=...) at /usr/src/debug/kscreen5-5.12.5-lp150.1.1.x86_64/kcm/src/outputconfig.cpp:197
#9  0x00007f908a50e14c in QtPrivate::QSlotObjectBase::call (a=0x7ffe69e4ddc0, r=0x5624b68cc580, this=0x5624b682ffc0) at ../../include/QtCore/../../src/corelib/kernel/qobject_impl.h:101
#10 QMetaObject::activate (sender=sender@entry=0x5624b68cc670, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe69e4ddc0) at kernel/qobject.cpp:3749
#11 0x00007f908a50e757 in QMetaObject::activate (sender=sender@entry=0x5624b68cc670, m=m@entry=0x7f9062809960 <ResolutionSlider::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe69e4ddc0) at kernel/qobject.cpp:3628
#12 0x00007f90625fc862 in ResolutionSlider::resolutionChanged (this=this@entry=0x5624b68cc670, _t1=...) at /usr/src/debug/kscreen5-5.12.5-lp150.1.1.x86_64/build/kcm/src/kcm_kscreen_autogen/EWIEGA46WW/moc_resolutionslider.cpp:140
#13 0x00007f90625ee43b in ResolutionSlider::slotValueChanged (this=0x5624b68cc670, value=<optimized out>) at /usr/src/debug/kscreen5-5.12.5-lp150.1.1.x86_64/kcm/src/resolutionslider.cpp:164
#14 0x00007f908a50e14c in QtPrivate::QSlotObjectBase::call (a=0x7ffe69e4df30, r=0x5624b68cc670, this=0x5624b6845e70) at ../../include/QtCore/../../src/corelib/kernel/qobject_impl.h:101
#15 QMetaObject::activate (sender=sender@entry=0x5624b68d02b0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe69e4df30) at kernel/qobject.cpp:3749
#16 0x00007f908a50e757 in QMetaObject::activate (sender=sender@entry=0x5624b68d02b0, m=m@entry=0x7f908bb9fa80 <QAbstractSlider::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe69e4df30) at kernel/qobject.cpp:3628
#17 0x00007f908b5e6cfe in QAbstractSlider::valueChanged (this=this@entry=0x5624b68d02b0, _t1=<optimized out>, _t1@entry=13) at .moc/moc_qabstractslider.cpp:304
#18 0x00007f908b5e7337 in QAbstractSlider::setValue (this=this@entry=0x5624b68d02b0, value=13) at widgets/qabstractslider.cpp:546
#19 0x00007f908b5e7572 in QAbstractSlider::triggerAction (this=this@entry=0x5624b68d02b0, action=action@entry=QAbstractSlider::SliderPageStepAdd) at widgets/qabstractslider.cpp:635
#20 0x00007f908b684a54 in QSlider::mousePressEvent (this=0x5624b68d02b0, ev=0x7ffe69e4e490) at widgets/qslider.cpp:394
#21 0x00007f908b5356f9 in QWidget::event (this=this@entry=0x5624b68d02b0, event=event@entry=0x7ffe69e4e490) at kernel/qwidget.cpp:8895
#22 0x00007f908b5e8165 in QAbstractSlider::event (this=this@entry=0x5624b68d02b0, e=e@entry=0x7ffe69e4e490) at widgets/qabstractslider.cpp:956
#23 0x00007f908b685136 in QSlider::event (this=0x5624b68d02b0, event=0x7ffe69e4e490) at widgets/qslider.cpp:349
#24 0x00007f908b4f8e8c in QApplicationPrivate::notify_helper (this=this@entry=0x5624b340dd70, receiver=receiver@entry=0x5624b68d02b0, e=e@entry=0x7ffe69e4e490) at kernel/qapplication.cpp:3723
#25 0x00007f908b50079f in QApplication::notify (this=<optimized out>, receiver=0x5624b68d02b0, e=0x7ffe69e4e490) at kernel/qapplication.cpp:3199
#26 0x00007f908a4e0a88 in QCoreApplication::notifyInternal2 (receiver=receiver@entry=0x5624b68d02b0, event=event@entry=0x7ffe69e4e490) at kernel/qcoreapplication.cpp:1016
#27 0x00007f908b4ff7ef in QCoreApplication::sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:233
#28 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x5624b68d02b0, event=event@entry=0x7ffe69e4e490, alienWidget=alienWidget@entry=0x5624b68d02b0, nativeWidget=0x5624b34bd270, buttonDown=buttonDown@entry=0x7f908bbc87d0 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:2705
#29 0x00007f908b54f2ab in QWidgetWindow::handleMouseEvent (this=this@entry=0x5624b3800c60, event=event@entry=0x7ffe69e4e880) at kernel/qwidgetwindow.cpp:628
#30 0x00007f908b551701 in QWidgetWindow::event (this=0x5624b3800c60, event=0x7ffe69e4e880) at kernel/qwidgetwindow.cpp:250
#31 0x00007f908b4f8e8c in QApplicationPrivate::notify_helper (this=this@entry=0x5624b340dd70, receiver=receiver@entry=0x5624b3800c60, e=e@entry=0x7ffe69e4e880) at kernel/qapplication.cpp:3723
#32 0x00007f908b500244 in QApplication::notify (this=0x7ffe69e4ece0, receiver=0x5624b3800c60, e=0x7ffe69e4e880) at kernel/qapplication.cpp:3482
#33 0x00007f908a4e0a88 in QCoreApplication::notifyInternal2 (receiver=receiver@entry=0x5624b3800c60, event=event@entry=0x7ffe69e4e880) at kernel/qcoreapplication.cpp:1016
#34 0x00007f908ad3a18b in QCoreApplication::sendSpontaneousEvent (event=0x7ffe69e4e880, receiver=0x5624b3800c60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#35 QGuiApplicationPrivate::processMouseEvent (e=0x5624b67556e0) at kernel/qguiapplication.cpp:1952
#36 0x00007f908ad3bac5 in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x5624b67556e0) at kernel/qguiapplication.cpp:1733
#37 0x00007f908ad1465b in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:946
#38 0x00007f907d3c20f0 in userEventSourceDispatch (source=<optimized out>) at qeventdispatcher_glib.cpp:77
#39 0x00007f90833f1f57 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f90833f2190 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f90833f221c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f908a536bef in QEventDispatcherGlib::processEvents (this=0x5624b3471ac0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#43 0x00007f908a4df09a in QEventLoop::exec (this=this@entry=0x7ffe69e4ec10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#44 0x00007f908a4e79e4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1289
#45 0x00005624b2f679b0 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/systemsettings5-5.12.5-lp150.1.1.x86_64/app/main.cpp:70

Reported using DrKonqi
Comment 1 Christoph Feck 2018-10-01 14:16:21 UTC
*** Bug 399247 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2019-09-09 14:20:22 UTC
This should have been fixed in Plasma 5.17 (not released yet). Please check! :)