Bug 396159

Summary: Quick open doesn't show any document
Product: [Applications] kate Reporter: Louis Moureaux <m_louis30>
Component: applicationAssignee: KWrite Developers <kwrite-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: christoph, nate
Priority: NOR    
Version: 18.04.2   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Screenshot demonstrating the problem (in French)

Description Louis Moureaux 2018-07-04 12:11:17 UTC
Created attachment 113753 [details]
Screenshot demonstrating the problem (in French)

Since the last update, Kate doesn't show any document in the Quick Open view (Ctrl-Shift-O). I have this problem on both of Kde Neon and Arch Linux.
Comment 1 Christoph Cullmann 2018-07-14 16:58:58 UTC
I assume this is the Qt 5.11 regression


commit 291b68994d7c6176dbc1983c956e2bb7135559e0
Author: Sven Brauch <mail@svenbrauch.de>
Date:   Wed Jun 13 17:25:20 2018 +0200

    Fix QuickOpen with Qt 5.11
    
    It remains to be investigated whether this is a regression in Qt
    itself, or misuse of the API on our side. There is at least one
    misuse (the call to mapFromSource) which is wrong in the old version,
    so this patch improves the situation in either case.
    
    Differential Revision: https://phabricator.kde.org/D13517
    BUG:395039