Bug 394968

Summary: No way to re-enable confirmation on empty wastebin action
Product: [Applications] dolphin Reporter: KDE end user <jim.crew>
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: elvis.angelaccio
Priority: NOR Keywords: reproducible
Version: unspecified   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: attachment-25135-0.html
attachment-28969-0.html

Description KDE end user 2018-06-02 20:54:52 UTC
This is dealing with deleting data, not providing a way to re-enable confirmation of emptying wastebin action is unprofessional/reckless.
Comment 1 Elvis Angelaccio 2018-06-03 11:04:11 UTC
You can do it in 'Configure Dolphin -> General -> Confirmations'.
Comment 2 KDE end user 2018-06-03 16:59:13 UTC
Created attachment 113042 [details]
attachment-25135-0.html

Hi Elvis,

    Thank you for your prompt reply.

    I have 2 checkboxes that I can apply in the Dolphin Preference ->
General -> Confirmations:

  1)  Moving files or folders to trash
   2) Deleting Files or Folders

   Both are checked (have a small blue Square inside them).

   If I select a file in Dolphin, choose Move to Trash, I get a dialog
asking if I really want to move this item to the wastebin. If I click the
Move to Wastebin button, the file is moved to the wastebin.

   When I select the Trash icon in Dolphin, Choose the Empty Trash option,
the Wastebin is emptied, directly, that is,  without a dialog box to ask if
I am sure.

  Apart from not being prompted to confirm emptying the wastebin, it might
be a bit clearer if option (2), above, actually said Confirm when Emptying
Trash, as this is the action listed on the pop-up menu.

   I am using Ubuntu 16.04.4 amd64. Dolphin version, from Dolphin Help ->
About Dolphin is:

  Dolphin 15.12.3,
  KDE frameworks 5.18.0,
  Qt 5.5.1 (built against 5.5.1)
  the xcb windowing system.

  Hope this helps,

  Kind regards,

  Jim

On Sun, 3 Jun 2018, 12:04 Elvis Angelaccio, <bugzilla_noreply@kde.org>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=394968
>
> Elvis Angelaccio <elvis.angelaccio@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>          Resolution|---                         |WORKSFORME
>              Status|UNCONFIRMED                 |RESOLVED
>
> --- Comment #1 from Elvis Angelaccio <elvis.angelaccio@kde.org> ---
> You can do it in 'Configure Dolphin -> General -> Confirmations'.
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 3 KDE end user 2018-06-03 17:20:51 UTC
Created attachment 113043 [details]
attachment-28969-0.html

Hi Elvis,

   Quick follow up - there is a Delete option on the Dolphin File menu,
which I never use, which might be for the second option. But in that case,
there is no option to confirm emptying the trash, which was my original bug
report.

  Thanks again,

   Kind regards,

   Jim

On Sun, 3 Jun 2018, 17:58 Jim Crew, <jim.crew@gmail.com> wrote:

> Hi Elvis,
>
>     Thank you for your prompt reply.
>
>     I have 2 checkboxes that I can apply in the Dolphin Preference ->
> General -> Confirmations:
>
>   1)  Moving files or folders to trash
>    2) Deleting Files or Folders
>
>    Both are checked (have a small blue Square inside them).
>
>    If I select a file in Dolphin, choose Move to Trash, I get a dialog
> asking if I really want to move this item to the wastebin. If I click the
> Move to Wastebin button, the file is moved to the wastebin.
>
>    When I select the Trash icon in Dolphin, Choose the Empty Trash option,
> the Wastebin is emptied, directly, that is,  without a dialog box to ask if
> I am sure.
>
>   Apart from not being prompted to confirm emptying the wastebin, it might
> be a bit clearer if option (2), above, actually said Confirm when Emptying
> Trash, as this is the action listed on the pop-up menu.
>
>    I am using Ubuntu 16.04.4 amd64. Dolphin version, from Dolphin Help ->
> About Dolphin is:
>
>   Dolphin 15.12.3,
>   KDE frameworks 5.18.0,
>   Qt 5.5.1 (built against 5.5.1)
>   the xcb windowing system.
>
>   Hope this helps,
>
>   Kind regards,
>
>   Jim
>
> On Sun, 3 Jun 2018, 12:04 Elvis Angelaccio, <bugzilla_noreply@kde.org>
> wrote:
>
>> https://bugs.kde.org/show_bug.cgi?id=394968
>>
>> Elvis Angelaccio <elvis.angelaccio@kde.org> changed:
>>
>>            What    |Removed                     |Added
>>
>> ----------------------------------------------------------------------------
>>          Resolution|---                         |WORKSFORME
>>              Status|UNCONFIRMED                 |RESOLVED
>>
>> --- Comment #1 from Elvis Angelaccio <elvis.angelaccio@kde.org> ---
>> You can do it in 'Configure Dolphin -> General -> Confirmations'.
>>
>> --
>> You are receiving this mail because:
>> You reported the bug.
>
>
Comment 4 Elvis Angelaccio 2018-06-03 18:20:23 UTC
Ah sorry, Ubuntu 16.04 does not have what I was looking at. We added "Emptying trash" to the Confirmations page only recently (see duplicate #340572)

For now you can workaround this limitation by manually editing ~/.config/kiorc

*** This bug has been marked as a duplicate of bug 340572 ***