Bug 394787

Summary: Mouse flat profile does not work
Product: systemsettings Reporter: tromzy
Component: kcm_mouseAssignee: Roman Gilg <subdiff>
Status: RESOLVED FIXED    
Severity: normal CC: bugseforuns, kde, kde, matejm98mthw, nate, unassigned-bugs
Priority: NOR    
Version: 5.12.90   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description tromzy 2018-05-28 10:07:04 UTC
On Plasma 5.13 beta, on Wayland, the flat acceleration profile for the mouse does not work. I can select it in the mouse KCM module, but when I click "Apply", it selects "Adaptive" again.
Comment 1 Matej Mrenica 2018-05-28 11:32:39 UTC
Can confirm on Arch
Comment 2 Roman Gilg 2018-06-01 13:52:59 UTC
Thank you both for reporting and confirming. Seems to be a simple copy-paste issue: https://phabricator.kde.org/D13270
Comment 3 Roman Gilg 2018-06-01 14:08:40 UTC
Git commit 7a03d8d3fab05065f32501d51518c5b80204901c by Roman Gilg.
Committed on 01/06/2018 at 14:08.
Pushed by romangilg into branch 'Plasma/5.13'.

[Mouse KCM] Fix writing selected profile value

Summary:
Wrote the default value resulting in no change at all.

Test Plan: Manually

Reviewers: #plasma, davidedmundson

Reviewed By: #plasma, davidedmundson

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13270

M  +2    -2    kcms/mouse/backends/kwin_wl/kwin_wl_device.cpp

https://commits.kde.org/plasma-desktop/7a03d8d3fab05065f32501d51518c5b80204901c