Bug 394048

Summary: Software Centre Discover crashed three times out of three when searching for "latte" after hiting return
Product: [Applications] Discover Reporter: Julian Morgan <jcmorgan65>
Component: discoverAssignee: Aleix Pol <aleixpol>
Status: RESOLVED FIXED    
Severity: normal CC: 1830811478, ants.karner, betelanus, bugs.kde.org.facelift226, charlus194, cheers0, d1m, danhuckson, deciccomarco71, Enygma2002_ro, idiot, jbeckert, jorgealtx, kde-bugs, leviatan1, lordcube777, m.cankarakurt, mu, nate, otrapersonabugs, pretomisturado, rdieter, romainfleurette, rudranilroy1, s1512783, samarth.khandelwal39, shwaybotx, tommybeauclair, vovakozlouskiy
Priority: NOR Keywords: drkonqi
Version: 5.12.5   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In: 5.12.5.1

Description Julian Morgan 2018-05-09 17:04:10 UTC
Application: plasma-discover (5.12.5)

Qt Version: 5.10.0
Frameworks Version: 5.45.0
Operating System: Linux 4.13.0-41-generic x86_64
Distribution: KDE neon User Edition 5.12

-- Information about the crash:
- What I was doing when the application crashed: I have just installed KDE neon (current user on 9/5/18) today on MacBook 3,1 from USB installer created with Etcher, in the hope that it might give me faster boot times compared to UbuntuMate. I have done very little from fresh install: Updated using built in updater, moved bottom panel to top of screen and lastly opened Discover to search for Latte as a "dock" alternative. After enter the letters "latte" into the search bar I hit return and it crashed, tried again and a third time same result. Hence this report. I hope it maybe useful because I've done nothing since fresh install. Also might be relevant that I am getting very slow start up times and on Mate this was due to drm_kms_helper errors in that applying the worka round kernel boot parameter video=SVIDEO-1:d into grub massively improved start up time. It seems to be someting to do with the GMA945 (?) graphics on older macbooks removed from more recent kernel versions, in that this error did not happen before 13.x I only mention it because it is peculiar to this hardware

- Unusual behavior I noticed:
Bottom left of desktop is a vertical text saying 'Default'

The crash can be reproduced every time.

-- Backtrace:
Application: Discover (plasma-discover), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f680bc7b8c0 (LWP 2010))]

Thread 7 (Thread 0x7f67c5cd0700 (LWP 2019)):
#0  0x00007fff71842b6d in clock_gettime ()
#1  0x00007f6806faf876 in __GI___clock_gettime (clock_id=1, tp=0x7f67c5ccfa70) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f6807bd0ed1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f6807bcf6c9 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f6807bcfc35 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6807bd196c in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6801bf091d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f6801bf12bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f6801bf149c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f6807bd15cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f6807b7864a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f6807998554 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f680799d6eb in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f6803ce86ba in start_thread (arg=0x7f67c5cd0700) at pthread_create.c:333
#14 0x00007f6806fa141d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f67d53ae700 (LWP 2017)):
#0  0x00007f6801bf1245 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6801bf149c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6807bd15cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f6807b7864a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f6807998554 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f680799d6eb in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6803ce86ba in start_thread (arg=0x7f67d53ae700) at pthread_create.c:333
#7  0x00007f6806fa141d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f67d68e7700 (LWP 2016)):
#0  0x00007f6801bf1323 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6801bf149c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6807bd15cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f6807b7864a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f6807998554 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f680799d6eb in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6803ce86ba in start_thread (arg=0x7f67d68e7700) at pthread_create.c:333
#7  0x00007f6806fa141d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f67df76f700 (LWP 2015)):
#0  0x00007f6806f9574d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f6801bf138c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6801bf149c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6807bd15cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f6807b7864a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6807998554 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f680ad921c6 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f680799d6eb in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6803ce86ba in start_thread (arg=0x7f67df76f700) at pthread_create.c:333
#9  0x00007f6806fa141d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f67eecdd700 (LWP 2014)):
#0  0x00007fff71842b6d in clock_gettime ()
#1  0x00007f6806faf876 in __GI___clock_gettime (clock_id=1, tp=0x7f67eecdca40) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f6807bd0ed1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f6807bcf6c9 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f6807bcfc35 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6807bd133e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6801bf091d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f6801bf12bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f6801bf149c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f6807bd15cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f6807b7864a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f6807998554 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f6808573a35 in QQmlThreadPrivate::run (this=0x24fed20) at qml/ftw/qqmlthread.cpp:147
#13 0x00007f680799d6eb in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f6803ce86ba in start_thread (arg=0x7f67eecdd700) at pthread_create.c:333
#15 0x00007f6806fa141d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f67efeee700 (LWP 2013)):
#0  0x00007fff71842b6d in clock_gettime ()
#1  0x00007f6806faf876 in __GI___clock_gettime (clock_id=1, tp=0x7f67efeeda30) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f6807bd0ed1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f6807bcf6c9 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f6807bcfc35 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6807bd133e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6801bf091d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f6801bf12bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f6801bf149c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f6807bd15cb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f6807b7864a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f6807998554 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f68098992c5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#13 0x00007f680799d6eb in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f6803ce86ba in start_thread (arg=0x7f67efeee700) at pthread_create.c:333
#15 0x00007f6806fa141d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f680bc7b8c0 (LWP 2010)):
[KCrash Handler]
#6  AppStream::Component::name (this=0x0) at /workspace/build/qt/component.cpp:246
#7  0x00007f67c79d604b in AppPackageKitResource::name (this=0x2b199a0) at /workspace/build/libdiscover/backends/PackageKitBackend/AppPackageKitResource.cpp:50
#8  0x00007f680aa461c1 in AbstractResource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /workspace/build/obj-x86_64-linux-gnu/libdiscover/moc_AbstractResource.cpp:297
#9  0x00007f68084a579f in QQmlPropertyData::readProperty (property=0x7fff718257d0, target=0x2b199a0, this=0x3801e68) at ../../include/QtQml/5.10.0/QtQml/private/../../../../../src/qml/qml/qqmlpropertycache_p.h:302
#10 loadProperty (v4=0x253a3e0, object=0x2b199a0, property=...) at jsruntime/qv4qobjectwrapper.cpp:147
#11 0x00007f68084a6576 in QV4::QObjectWrapper::getQmlProperty (this=0x7f67edc9e3e8, qmlContext=0x3a70dc0, name=0x7f67edc9e3e0, revisionMode=QV4::QObjectWrapper::IgnoreRevision, hasProperty=0x0, includeImports=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:326
#12 0x00007f68084bd627 in QV4::Object::get (hasProperty=0x0, name=<optimized out>, this=<optimized out>) at jsruntime/qv4object_p.h:380
#13 QV4::Runtime::method_getProperty (engine=0x253a3e0, object=..., nameIndex=<optimized out>) at jsruntime/qv4runtime.cpp:769
#14 0x00007f67ec0e5b55 in ?? ()
#15 0x0000000003acda10 in ?? ()
#16 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 Julian Morgan 2018-05-09 20:49:48 UTC
After rebooting several times (trying to check start up times) there were eventually a number of other updates available many of which referenced Discover. I assumed after installing these that the bug I reported would be fixed, however I have just reproduced it again and its really bizarre. If I enter the search term Latte it crashes, however if I enter the search term "coffee" it finds Latte and remains stable!!!!
Also wanted to add my apologies - I am searching for a distro/kernel version that will reliably boot my MacBook 3,1 without triggering the bug described here: https://askubuntu.com/questions/893817/boot-very-slow-because-of-drm-kms-helper-errors#916112
The workaround makes a big difference but from what I've read this bug didnt exist in earlier versions of the kernel and was introduced (or aprevious fix stopped working) after 14.x so I'll be trying something different and won't be able to contribute further. Many thanks.
Comment 2 Aleix Pol 2018-05-10 13:38:07 UTC
*** Bug 394052 has been marked as a duplicate of this bug. ***
Comment 3 Aleix Pol 2018-05-10 14:14:10 UTC
Git commit f2d87ea7f3fb0e2ef34667694064796a3c5f43ad by Aleix Pol.
Committed on 10/05/2018 at 14:13.
Pushed by apol into branch 'Plasma/5.12'.

Fix crash when rendering a delegate that extends an unexisting component

M  +8    -3    libdiscover/backends/PackageKitBackend/AppPackageKitResource.cpp

https://commits.kde.org/discover/f2d87ea7f3fb0e2ef34667694064796a3c5f43ad
Comment 4 Aleix Pol 2018-05-14 13:55:20 UTC
*** Bug 394192 has been marked as a duplicate of this bug. ***
Comment 5 Aleix Pol 2018-05-14 13:55:45 UTC
*** Bug 394244 has been marked as a duplicate of this bug. ***
Comment 6 Aleix Pol 2018-05-14 13:56:10 UTC
*** Bug 394122 has been marked as a duplicate of this bug. ***
Comment 7 Aleix Pol 2018-05-14 13:56:24 UTC
*** Bug 394170 has been marked as a duplicate of this bug. ***
Comment 8 Aleix Pol 2018-05-15 10:42:17 UTC
*** Bug 394085 has been marked as a duplicate of this bug. ***
Comment 9 Aleix Pol 2018-05-15 11:04:26 UTC
*** Bug 394265 has been marked as a duplicate of this bug. ***
Comment 10 Jim Jin 2018-05-15 12:46:24 UTC
(In reply to Julian Morgan from comment #0)
> Application: plasma-discover (5.12.5)
> 
> Qt Version: 5.10.0
> Frameworks Version: 5.45.0
> Operating System: Linux 4.13.0-41-generic x86_64
> Distribution: KDE neon User Edition 5.12
> 
> -- Information about the crash:
> - What I was doing when the application crashed: I have just installed KDE
> neon (current user on 9/5/18) today on MacBook 3,1 from USB installer
> created with Etcher, in the hope that it might give me faster boot times
> compared to UbuntuMate. I have done very little from fresh install: Updated
> using built in updater, moved bottom panel to top of screen and lastly
> opened Discover to search for Latte as a "dock" alternative. After enter the
> letters "latte" into the search bar I hit return and it crashed, tried again
> and a third time same result. Hence this report. I hope it maybe useful
> because I've done nothing since fresh install. Also might be relevant that I
> am getting very slow start up times and on Mate this was due to
> drm_kms_helper errors in that applying the worka round kernel boot parameter
> video=SVIDEO-1:d into grub massively improved start up time. It seems to be
> someting to do with the GMA945 (?) graphics on older macbooks removed from
> more recent kernel versions, in that this error did not happen before 13.x I
> only mention it because it is peculiar to this hardware
> 
> - Unusual behavior I noticed:
> Bottom left of desktop is a vertical text saying 'Default'
> 
> The crash can be reproduced every time.
> 
> -- Backtrace:
> Application: Discover (plasma-discover), signal: Segmentation fault
> Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
> [Current thread is 1 (Thread 0x7f680bc7b8c0 (LWP 2010))]
> 
> Thread 7 (Thread 0x7f67c5cd0700 (LWP 2019)):
> #0  0x00007fff71842b6d in clock_gettime ()
> #1  0x00007f6806faf876 in __GI___clock_gettime (clock_id=1,
> tp=0x7f67c5ccfa70) at ../sysdeps/unix/clock_gettime.c:115
> #2  0x00007f6807bd0ed1 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #3  0x00007f6807bcf6c9 in QTimerInfoList::updateCurrentTime() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #4  0x00007f6807bcfc35 in QTimerInfoList::timerWait(timespec&) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #5  0x00007f6807bd196c in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #6  0x00007f6801bf091d in g_main_context_prepare () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #7  0x00007f6801bf12bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #8  0x00007f6801bf149c in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #9  0x00007f6807bd15cb in
> QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
> () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #10 0x00007f6807b7864a in
> QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #11 0x00007f6807998554 in QThread::exec() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #12 0x00007f680799d6eb in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #13 0x00007f6803ce86ba in start_thread (arg=0x7f67c5cd0700) at
> pthread_create.c:333
> #14 0x00007f6806fa141d in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
> 
> Thread 6 (Thread 0x7f67d53ae700 (LWP 2017)):
> #0  0x00007f6801bf1245 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #1  0x00007f6801bf149c in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f6807bd15cb in
> QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
> () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #3  0x00007f6807b7864a in
> QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #4  0x00007f6807998554 in QThread::exec() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #5  0x00007f680799d6eb in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #6  0x00007f6803ce86ba in start_thread (arg=0x7f67d53ae700) at
> pthread_create.c:333
> #7  0x00007f6806fa141d in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
> 
> Thread 5 (Thread 0x7f67d68e7700 (LWP 2016)):
> #0  0x00007f6801bf1323 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #1  0x00007f6801bf149c in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f6807bd15cb in
> QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
> () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #3  0x00007f6807b7864a in
> QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #4  0x00007f6807998554 in QThread::exec() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #5  0x00007f680799d6eb in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #6  0x00007f6803ce86ba in start_thread (arg=0x7f67d68e7700) at
> pthread_create.c:333
> #7  0x00007f6806fa141d in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
> 
> Thread 4 (Thread 0x7f67df76f700 (LWP 2015)):
> #0  0x00007f6806f9574d in poll () at ../sysdeps/unix/syscall-template.S:84
> #1  0x00007f6801bf138c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #2  0x00007f6801bf149c in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #3  0x00007f6807bd15cb in
> QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
> () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #4  0x00007f6807b7864a in
> QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #5  0x00007f6807998554 in QThread::exec() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #6  0x00007f680ad921c6 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
> #7  0x00007f680799d6eb in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #8  0x00007f6803ce86ba in start_thread (arg=0x7f67df76f700) at
> pthread_create.c:333
> #9  0x00007f6806fa141d in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
> 
> Thread 3 (Thread 0x7f67eecdd700 (LWP 2014)):
> #0  0x00007fff71842b6d in clock_gettime ()
> #1  0x00007f6806faf876 in __GI___clock_gettime (clock_id=1,
> tp=0x7f67eecdca40) at ../sysdeps/unix/clock_gettime.c:115
> #2  0x00007f6807bd0ed1 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #3  0x00007f6807bcf6c9 in QTimerInfoList::updateCurrentTime() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #4  0x00007f6807bcfc35 in QTimerInfoList::timerWait(timespec&) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #5  0x00007f6807bd133e in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #6  0x00007f6801bf091d in g_main_context_prepare () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #7  0x00007f6801bf12bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #8  0x00007f6801bf149c in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #9  0x00007f6807bd15cb in
> QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
> () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #10 0x00007f6807b7864a in
> QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #11 0x00007f6807998554 in QThread::exec() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #12 0x00007f6808573a35 in QQmlThreadPrivate::run (this=0x24fed20) at
> qml/ftw/qqmlthread.cpp:147
> #13 0x00007f680799d6eb in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #14 0x00007f6803ce86ba in start_thread (arg=0x7f67eecdd700) at
> pthread_create.c:333
> #15 0x00007f6806fa141d in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
> 
> Thread 2 (Thread 0x7f67efeee700 (LWP 2013)):
> #0  0x00007fff71842b6d in clock_gettime ()
> #1  0x00007f6806faf876 in __GI___clock_gettime (clock_id=1,
> tp=0x7f67efeeda30) at ../sysdeps/unix/clock_gettime.c:115
> #2  0x00007f6807bd0ed1 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #3  0x00007f6807bcf6c9 in QTimerInfoList::updateCurrentTime() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #4  0x00007f6807bcfc35 in QTimerInfoList::timerWait(timespec&) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #5  0x00007f6807bd133e in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #6  0x00007f6801bf091d in g_main_context_prepare () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #7  0x00007f6801bf12bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #8  0x00007f6801bf149c in g_main_context_iteration () from
> /lib/x86_64-linux-gnu/libglib-2.0.so.0
> #9  0x00007f6807bd15cb in
> QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)
> () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #10 0x00007f6807b7864a in
> QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #11 0x00007f6807998554 in QThread::exec() () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #12 0x00007f68098992c5 in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
> #13 0x00007f680799d6eb in ?? () from
> /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
> #14 0x00007f6803ce86ba in start_thread (arg=0x7f67efeee700) at
> pthread_create.c:333
> #15 0x00007f6806fa141d in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
> 
> Thread 1 (Thread 0x7f680bc7b8c0 (LWP 2010)):
> [KCrash Handler]
> #6  AppStream::Component::name (this=0x0) at
> /workspace/build/qt/component.cpp:246
> #7  0x00007f67c79d604b in AppPackageKitResource::name (this=0x2b199a0) at
> /workspace/build/libdiscover/backends/PackageKitBackend/
> AppPackageKitResource.cpp:50
> #8  0x00007f680aa461c1 in AbstractResource::qt_static_metacall
> (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized
> out>) at
> /workspace/build/obj-x86_64-linux-gnu/libdiscover/moc_AbstractResource.cpp:
> 297
> #9  0x00007f68084a579f in QQmlPropertyData::readProperty
> (property=0x7fff718257d0, target=0x2b199a0, this=0x3801e68) at
> ../../include/QtQml/5.10.0/QtQml/private/../../../../../src/qml/qml/
> qqmlpropertycache_p.h:302
> #10 loadProperty (v4=0x253a3e0, object=0x2b199a0, property=...) at
> jsruntime/qv4qobjectwrapper.cpp:147
> #11 0x00007f68084a6576 in QV4::QObjectWrapper::getQmlProperty
> (this=0x7f67edc9e3e8, qmlContext=0x3a70dc0, name=0x7f67edc9e3e0,
> revisionMode=QV4::QObjectWrapper::IgnoreRevision, hasProperty=0x0,
> includeImports=<optimized out>) at jsruntime/qv4qobjectwrapper.cpp:326
> #12 0x00007f68084bd627 in QV4::Object::get (hasProperty=0x0, name=<optimized
> out>, this=<optimized out>) at jsruntime/qv4object_p.h:380
> #13 QV4::Runtime::method_getProperty (engine=0x253a3e0, object=...,
> nameIndex=<optimized out>) at jsruntime/qv4runtime.cpp:769
> #14 0x00007f67ec0e5b55 in ?? ()
> #15 0x0000000003acda10 in ?? ()
> #16 0x0000000000000000 in ?? ()
> 
> Reported using DrKonqi

I reported a similar crash bug and was indentified as duplicate as yours, however what interests more is not this bug but that SVIDEO-1:d fixing thing, I also have to use the walkaround on my old Dell D630 for fedora and ubuntu, it's has been a very persistent bug and I really hope one day it will be gone.
Comment 11 Rex Dieter 2018-05-16 13:40:14 UTC
*** Bug 394323 has been marked as a duplicate of this bug. ***
Comment 12 Aleix Pol 2018-05-17 10:36:41 UTC
*** Bug 394302 has been marked as a duplicate of this bug. ***
Comment 13 Aleix Pol 2018-05-17 10:44:36 UTC
*** Bug 394340 has been marked as a duplicate of this bug. ***
Comment 14 Aleix Pol 2018-05-18 22:56:27 UTC
*** Bug 394220 has been marked as a duplicate of this bug. ***
Comment 15 Aleix Pol 2018-05-18 22:56:33 UTC
*** Bug 394418 has been marked as a duplicate of this bug. ***
Comment 16 Aleix Pol 2018-05-21 22:57:33 UTC
*** Bug 394511 has been marked as a duplicate of this bug. ***
Comment 17 Aleix Pol 2018-05-21 22:58:52 UTC
*** Bug 394430 has been marked as a duplicate of this bug. ***
Comment 18 Aleix Pol 2018-05-21 23:00:30 UTC
*** Bug 394456 has been marked as a duplicate of this bug. ***
Comment 19 Aleix Pol 2018-05-21 23:00:54 UTC
*** Bug 394481 has been marked as a duplicate of this bug. ***
Comment 20 Aleix Pol 2018-05-21 23:01:20 UTC
*** Bug 394533 has been marked as a duplicate of this bug. ***
Comment 21 Aleix Pol 2018-05-21 23:02:11 UTC
*** Bug 394537 has been marked as a duplicate of this bug. ***
Comment 22 Aleix Pol 2018-05-22 14:01:48 UTC
*** Bug 394566 has been marked as a duplicate of this bug. ***
Comment 23 Aleix Pol 2018-05-23 11:03:32 UTC
*** Bug 394579 has been marked as a duplicate of this bug. ***
Comment 24 Aleix Pol 2018-05-23 11:03:49 UTC
*** Bug 394584 has been marked as a duplicate of this bug. ***
Comment 25 Aleix Pol 2018-05-26 00:22:36 UTC
*** Bug 394678 has been marked as a duplicate of this bug. ***
Comment 26 Aleix Pol 2018-05-26 00:22:45 UTC
*** Bug 394607 has been marked as a duplicate of this bug. ***
Comment 27 Aleix Pol 2018-05-26 00:22:59 UTC
*** Bug 394634 has been marked as a duplicate of this bug. ***
Comment 28 Aleix Pol 2018-05-27 22:53:31 UTC
*** Bug 394752 has been marked as a duplicate of this bug. ***
Comment 29 Aleix Pol 2018-05-28 23:31:28 UTC
*** Bug 394807 has been marked as a duplicate of this bug. ***
Comment 30 Aleix Pol 2018-06-01 00:44:50 UTC
*** Bug 394766 has been marked as a duplicate of this bug. ***
Comment 31 Aleix Pol 2018-06-01 00:44:57 UTC
*** Bug 394901 has been marked as a duplicate of this bug. ***
Comment 32 Aleix Pol 2018-06-04 01:48:09 UTC
*** Bug 395002 has been marked as a duplicate of this bug. ***
Comment 33 Aleix Pol 2018-06-07 14:00:29 UTC
*** Bug 395088 has been marked as a duplicate of this bug. ***