Bug 377876

Summary: kmail fails to display newly arrived emails (imap)
Product: [Applications] kmail2 Reporter: farandole
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: NEEDSINFO WAITINGFORINFO    
Severity: major CC: claudiu.cismaru, tcberner
Priority: NOR    
Version: 5.4.3   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:

Description farandole 2017-03-21 10:04:44 UTC
Seemingly randomly kmail checks email (auto or manual), progress bar completes but the new email do not appear in inbox.

I discovered this when after rebooting I would discover a backlog of several days worth of emails.

Quitting kmail, stopping and restarting akonadi and reopening kmail may help with those email appearing. Sometimes a reboot is the only way to fix this.

This is quite unnerving as I now can't trust kmail to tell me if I have new emails or not.
Comment 1 Claudiu Nicolaie CISMARU 2017-08-03 17:15:34 UTC
I have the same issue.

It seems the IMAP communication hangs in akonadi. Opening the accounts settings, opening the account settings window and then clicking OK will make the account to recover and downloads properly the new messages.

However, this is just a workaround is not a reliable way to use kmail.
Comment 2 Justin Zobel 2022-11-06 09:25:29 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 3 Bug Janitor Service 2022-11-21 05:12:37 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!