Bug 377033

Summary: Unable to view the phone's filesystem
Product: [Applications] kdeconnect Reporter: Luzius Auer <luzius>
Component: commonAssignee: Albert Vaca Cintora <albertvaka>
Severity: major CC: kdebugs, nate, rasmus, spleefer90
Priority: NOR    
Version: 1.5   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Screenshot of the issue (Cinnamon)

Description Luzius Auer 2017-02-28 19:24:14 UTC
Unable to view the phone's filesystem. After clicking the drawer icon, KDEConnect signals an error:
the directory /home/lar/.cache/kioexec/krun/6621_0/ exists already -> IN FRENCH:
(Un dossier nommé /home/lar/.cache/kioexec/krun/6653_0/ existe déjà.)
I'm using krusader as default file viewer.
Fedora25 64
Please help
Best regards Luzius
Comment 1 Rasmus B 2017-05-16 13:59:42 UTC
This bug is already mentioned and marked as fixed here: https://bugs.kde.org/show_bug.cgi?id=373967

However, I'm experiencing the same issue which it is still not fixed,so I can confirm this is not a one time issue.
Comment 2 Terry Coles 2017-07-17 11:59:35 UTC
I am running Kubuntu 17.04 and KDE Connect version 1.0.3-0ubuntu and get the same problem.  I have only noticed it in the past week or two, so maybe a patch has broken this again?
Comment 3 Martin 2017-08-09 07:01:32 UTC
Running Arch and Cinnamon, I ran into this issue too.
Comment 4 CnZhx 2018-10-14 04:16:03 UTC
Hi guys, are you still bothered by this issue with newer version apps as KDEConnect has evolved much during these days?

If it persists, does it help to remove the cached file/folder (for example, `/home/lar/.cache/kioexec/krun/6621_0/` as mentioned by the reporter?

I personally do not have this problem with openSUSE Tumbleweed with Dolphin.
Comment 5 Andrew Crouthamel 2018-11-01 18:49:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Martin 2018-11-01 23:34:27 UTC
Still an issue with Arch and Cinnamon here.

Removing the cache folder does not help, it errors out again on a different one.
Comment 7 Luzius Auer 2018-11-02 09:55:12 UTC
Resolved for me now with two pseudo directories visible from PC
* all files
* images
On double click all files or directories are accessible, but all with a single date (2018/05/12). Transfers from and to Android are possible

Fedora28, KDE, 64
Comment 8 Nate Graham 2018-11-05 21:43:02 UTC
Fixed in Frameworks 5.51 with the fix for 397742.

*** This bug has been marked as a duplicate of bug 397742 ***
Comment 9 Luzius Auer 2018-11-06 08:41:36 UTC
After upgrade to F29 and using latest version 1.10 of KDE Connect, it is again impossible to access the Android Filesystem, even after deleting the cache as suggested by CnZhx.
Krusader shows two pseudo-directories, but Krusader tells that the directory doesn't exist: so sad!
Comment 10 CnZhx 2018-11-06 09:19:08 UTC
I installed Krusader 2.7.1 just now on openSUSE Tumbleweed. I did not set it as default file manager, so I copy-n-paste the path from dolphin to open it in Krusader. No problem has been found with opening the paths but I have not tried to set Krusader as default (so that if I click the folder icon in KDE Connect it will ask Krusader instead of Dolpin to open the folder for me).

There is no problem to open the mount point. The path of the mount point for the Android device is like "/run/user/1000/ed411c49fbc8b0ca/storage/emulated/0/". And I also have no problem with opening a kdeconnect path such as "kdeconnect://ed411c49fbc8b0ca/".

So, maybe the problem is not with KDEConnect but lies in Fedora, such as with some common components?

For your reference, here is the detail of my system:
openSUSE Tumbleweed: 20181029
KDE Plasma: 5.14.2
Qt: 5.11.2
KDE Frameworks: 5.51.0
KDE Applications: 18.08.2
Kernel: 4.18.15-1-default
Comment 11 Nate Graham 2018-11-06 21:45:06 UTC
CnZhx: so what's the problem? It seems like the original issue is actually fixed for you, no?
Comment 12 CnZhx 2018-11-06 23:58:36 UTC
(In reply to Nate Graham from comment #11)
> CnZhx: so what's the problem? It seems like the original issue is actually
> fixed for you, no?

Yes, you are right. The original issue is fixed for me.

I was trying to help  Luzius Auer (the reporter) to hunt his problem. But I forgot to use the "reply" button to comment #7 or comment #9.
Comment 13 Nate Graham 2018-11-07 00:50:46 UTC
Great, thanks!

*** This bug has been marked as a duplicate of bug 397742 ***
Comment 14 Luzius Auer 2018-11-07 08:14:46 UTC
(In reply to Nate Graham from comment #13)
> Great, thanks!
> *** This bug has been marked as a duplicate of bug 397742 ***

Hy Nate,
Could you please explain the reason that you mark this bug as a duplicate. I don't see any resemblance between the two descriptions neither between comments.
Thank you
Best regards Luzius
Comment 15 Martin 2018-11-07 21:43:31 UTC
Created attachment 116164 [details]
Screenshot of the issue (Cinnamon)

Re-tested with desktop kdeconnect 1.3.3 and Android 1.10
Still experiencing this issue.
Comment 16 Christoph Feck 2018-11-07 23:49:22 UTC
Luzius, are you using KDE Frameworks 5.51 version?