Bug 375997

Summary: [hidpi] Tray icon size doesn't scale
Product: [Plasma] plasmashell Reporter: JR <zorael>
Component: System TrayAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kde, tterranigma
Priority: NOR    
Version: 5.9.0   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Tray icons too small (iconSize == 1)
Tray icons much better (iconSize == 2)

Description JR 2017-02-04 12:36:29 UTC
Created attachment 103817 [details]
Tray icons too small (iconSize == 1)

On hidpi monitors the standard tray icon size easily becomes too small to suit the size of the panel. See attached image.

A workaround is to edit /usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/config/main.xml and change iconSize from the default 1 to (generally) 2, but then it's still not scaling automatically and the change doesn't persist over package upgrades. It cannot be changed via systemsettings.

An additional workaround suggested by Fuchs over IRC is to keep a local copy in ~/.local/share/plasma/plasmoids, with the drawback of freezing it, not enjoying any further improvements or bugfixes to the plasmoid.

This is on a machine running Arch amd64, with Plasma 5.9 from the official repositories.
Comment 1 JR 2017-02-04 12:36:59 UTC
Created attachment 103818 [details]
Tray icons much better (iconSize == 2)
Comment 2 Nikolaos Kakouros 2017-02-07 19:49:23 UTC
This bug looks related to bug 360333.
Comment 3 David Edmundson 2017-02-08 09:15:33 UTC
This isn't anything to do with high DPI, it's just a design decision.
One that hopefully we will revisit.

*** This bug has been marked as a duplicate of bug 360333 ***