Bug 374108

Summary: Akregator - clicking some links in articles has no effect
Product: [Applications] akregator Reporter: naughtypine <naughtypine>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED WORKSFORME    
Severity: major CC: jjm, richard.bos
Priority: NOR    
Version: 5.3.0   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description naughtypine@openmailbox.org 2016-12-24 07:19:10 UTC
Clicking (left or middle) on some article links, whether in "feed summary" or "load full page" article viewer mode, has no effect -- does not open internally or externally (i.e. firefox). Right-clicking the SAME LINK and selecting an option to open in tab/external browser/etc. DOES work, however. 

Other links in the same article work normally. I.e. in "feed summary" viewing mode, the "Complete Story" link seems to always work, although I don't believe that link to be part of the article proper and is generated by Akregator.
Comment 1 Richard Bos 2018-07-24 10:48:05 UTC
Looks like this bug: https://bugreports.qt.io/browse/QTBUG-67870

As described at: https://blogs.kde.org/2018/07/24/2018-toulouse-pim-sprint-report
(look for Investigated Qt 5.11 bug which broke clicking on links in KMail... fixed)
Comment 2 Justin Zobel 2022-11-29 05:06:05 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 3 Richard Bos 2022-12-03 11:27:16 UTC
Let's close it.  I'm not aware of this kind of issues.