Bug 372976

Summary: dialog's editorial confusion on password storage
Product: [Applications] kmail2 Reporter: Nick Levinson <Nick_Levinson>
Component: UIAssignee: kdepim bugs <kdepim-bugs>
Status: NEEDSINFO WAITINGFORINFO    
Severity: normal CC: lueck
Priority: NOR    
Version: 4.14.10   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: screenshot

Description Nick Levinson 2016-11-27 00:48:02 UTC
Created attachment 102463 [details]
screenshot

Tools > Account Wizard > Account Assistant > KWallet Not Available - Account Assistant has wording that is odd. You say KWallet is not available but you urge that it be used. I suggest that you delete the second sentence ("It is strongly recommended to use KWallet for managing your passwords.") if the first and third sentences and what follows say everything the user needs to know.

I'm running KMail on openSuse 13.2 Linux, kept evergreen. I don't know if this is KMail2, but your bug tracking system doesn't list KMail as a product, so I guess this is the same thing.
Comment 1 Burkhard Lück 2016-11-27 13:54:59 UTC
Changing
"However, the password can be stored in the configuration file instead."
to
"However, the password can be stored in the KMail configuration file instead."
does that clarify what is meant here?
Comment 2 Nick Levinson 2016-12-03 02:58:24 UTC
No, the first two sentences need editing. No objection to the edit you propose, but it still leaves the first two sentences in conflict with each other. Would deleting the second sentence from the original text mean that the remaining text (with your edit) would accurately describe the facts and the options for the user?
Comment 3 Justin Zobel 2022-10-27 02:48:32 UTC
Thank you for reporting this bug in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 4 Bug Janitor Service 2022-11-11 05:19:12 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Nick Levinson 2022-11-13 02:43:39 UTC
I don't have KMail on a laptop anymore and I can't test it, so I wouldn't say WORKSFORME.

To say that a program is not available and that the user should use it is essentially contradictory and if KMail still says that then someone should correct it. Maybe someone else can check what KMail says now, or at least apply a LATER or similar label.
Comment 6 Bug Janitor Service 2022-11-28 05:12:30 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!