Bug 372657

Summary: Details
Product: [Applications] systemsettings Reporter: Bipin <bipinsadasivan97>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: putz.alexey
Priority: NOR Keywords: drkonqi
Version: 5.5.5   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Bipin 2016-11-19 09:28:20 UTC
Application: systemsettings5 (5.5.5)

Qt Version: 5.5.1
Operating System: Linux 4.4.0-31-generic i686
Distribution: Ubuntu 16.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:

I was just cheking the system settings, then it crashed . The whole window freezed and then the crashed message was shown

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2525800 (LWP 2875))]

Thread 5 (Thread 0xab8d3b40 (LWP 2901)):
#0  0xb77cec31 in __kernel_vsyscall ()
#1  0xb5d30f8f in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb4ae2b10 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4ad410c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4ad4529 in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xa4279955 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb4afb00a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb4c1c2b5 in start_thread (arg=0xab8d3b40) at pthread_create.c:333
#8  0xb5d3b16e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:114

Thread 4 (Thread 0x95c61b40 (LWP 2900)):
#0  0xb77cec31 in __kernel_vsyscall ()
#1  0xb5d30f8f in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb4ae2b10 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4ad410c in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4ad4244 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4ad42a0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb4afb00a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb4c1c2b5 in start_thread (arg=0x95c61b40) at pthread_create.c:333
#8  0xb5d3b16e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:114

Thread 3 (Thread 0x9c487b40 (LWP 2899)):
#0  0xb4b1a48d in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4ad3adc in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4ad40a1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4ad4244 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb623cb14 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb61e1953 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb61e1daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb6007f1d in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb54cfaff in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#9  0xb600d43b in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb4c1c2b5 in start_thread (arg=0x9c487b40) at pthread_create.c:333
#11 0xb5d3b16e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:114

Thread 2 (Thread 0xb20e8b40 (LWP 2876)):
#0  0xb77cec31 in __kernel_vsyscall ()
#1  0xb5d30f8f in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb4c9641d in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb4c9859b in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb222e273 in ?? () from /usr/lib/i386-linux-gnu/libQt5XcbQpa.so.5
#5  0xb600d43b in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb4c1c2b5 in start_thread (arg=0xb20e8b40) at pthread_create.c:333
#7  0xb5d3b16e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:114

Thread 1 (Thread 0xb2525800 (LWP 2875)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb621855f in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xaedfb55c in KParts::PartManager::~PartManager() () from /usr/lib/i386-linux-gnu/libKF5Parts.so.5
#10 0xaedfb74a in KParts::PartManager::~PartManager() () from /usr/lib/i386-linux-gnu/libKF5Parts.so.5
#11 0xb6212970 in QObjectPrivate::deleteChildren() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#12 0xb621bf4c in QObject::~QObject() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#13 0xaedf35b8 in KParts::Part::~Part() () from /usr/lib/i386-linux-gnu/libKF5Parts.so.5
#14 0xaedf518e in KParts::ReadOnlyPart::~ReadOnlyPart() () from /usr/lib/i386-linux-gnu/libKF5Parts.so.5
#15 0xaf03ccb1 in KHTMLPart::~KHTMLPart() () from /usr/lib/i386-linux-gnu/libKF5KHtml.so.5
#16 0xaf03cdfa in KHTMLPart::~KHTMLPart() () from /usr/lib/i386-linux-gnu/libKF5KHtml.so.5
#17 0xb62135d4 in qDeleteInEventHandler(QObject*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#18 0xb6215269 in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#19 0xb6d6815a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#20 0xb6d6d81c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#21 0xb61e481f in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#22 0xb61e6eff in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#23 0xb61e73e7 in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#24 0xb623c703 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#25 0xb4ad3ed9 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb4ad4179 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0xb4ad4244 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#28 0xb623caf3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#29 0xb2263a81 in ?? () from /usr/lib/i386-linux-gnu/libQt5XcbQpa.so.5
#30 0xb61e1953 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#31 0xb61e1daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#32 0xb61ea385 in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#33 0xb67a9931 in QGuiApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5
#34 0xb6d64024 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#35 0x08053fc0 in main ()

Possible duplicates by query: bug 368230, bug 367884, bug 366515, bug 366489, bug 364754.

Reported using DrKonqi
Comment 1 Alexey Putz 2016-11-19 14:04:15 UTC
I 've had similar behaviour in kubuntu 16.04 

Crashes happened when navigating in system settings in workspace theme tab and desktop behaviour tab.
But I couldnt reproduce it in kubuntu 16.10 , system settings version 5.7.5



Kubuntu 16.10
KDE Plasma Version : 5.7.5
KDE Frameworks Version : 5.26.0
Qt Version : 5.6.1
Kernel Version : 4.8.0-22-generic
OS Type: 64-bit
Comment 2 Christoph Feck 2016-11-21 03:21:53 UTC
Alexey, your crash is likely unrelated. Please report it separately with your backtrace.

*** This bug has been marked as a duplicate of bug 355711 ***