Bug 369041

Summary: Some notifications do not disappear automatically
Product: plasmashell Reporter: Tom Mittelstädt <tom-kde.bugs>
Component: NotificationsAssignee: Kai Uwe Broulik <kde>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kde, mklapetek, nicolas.fella, r2b2x3+kdebug
Priority: NOR    
Version: 5.5.5   
Target Milestone: 1.0   
Platform: Kubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Tom Mittelstädt 2016-09-19 10:07:35 UTC
libkf5notifications5 Version: 5.18.0-0ubuntu1

There are some notifications (eg. those that are triggered by Opera) that do not disappear automatically but stay visible until they get clicked.
Others disappear after a few seconds.

Actually it would be nice if there would be the possibility to configure the notifications in terms of duration, stickiness etc on a per process base (like snarl on windows).

Reproducible: Always
Comment 1 Nick Cross 2020-11-30 15:15:18 UTC
Related ? : bug 413203
Comment 2 Nick Cross 2020-11-30 15:20:34 UTC
I am seeing this as well.

Info Center gives:
 
Operating System: Fedora 33
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.9.10-200.fc33.x86_64
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
Memory: 23.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620


Its not consistent , if I clear all notifications sometimes things sent with timeout do go away, sometimes things get stuck and then they all pile up. This even happens with kdialog with --passivepopup <msg> 3
Comment 3 Nick Cross 2020-11-30 15:21:55 UTC
If I clear all notifications, then e.g. "/usr/bin/kdialog --passivepopup "%subject from %sendername" 3" works again and messages stop piling up. 

I do wonder if its Firefox google chat pinned tab that is not timing out that then causes everything to pile up behind it.
Comment 4 Nicolas Fella 2021-01-17 23:00:37 UTC

*** This bug has been marked as a duplicate of bug 413203 ***