Bug 368166

Summary: KDE crash while killing process from KsysGuard
Product: [Applications] ksysguard Reporter: uc
Component: generalAssignee: KSysGuard Developers <ksysguard-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: elvis.angelaccio
Priority: NOR Keywords: drkonqi
Version: 5.5.5   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description uc 2016-09-02 20:26:37 UTC
Application: ksysguard (5.5.5)

Qt Version: 5.5.1
Operating System: Linux 4.1.27-27-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Had told Skanlite to close from the R-click menu in the panel.  Saw that it was still showing activity in KsysGuard, so selected it and R-clicked on the line and attempted to end process.  KDE crashed immediately.  Skanlike is owned by logged-in user.

- Unusual behavior I noticed:
Response to key strokes and mouse actions have been either slow or slifhtly delayed recently.  Have manually set CPU speed to 2.6 GHz on all four threads with little improvement.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2fdcf9f800 (LWP 30840))]

Thread 2 (Thread 0x7f2fc0ff5700 (LWP 30841)):
#0  0x00007f2fdc87cbfd in poll () from /lib64/libc.so.6
#1  0x00007f2fd0bd5422 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f2fd0bd700f in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f2fc2d203c9 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f2fd7d0832f in QThreadPrivate::start (arg=0x1d8c410) at thread/qthread_unix.cpp:331
#5  0x00007f2fd07b20a4 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f2fdc88502d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f2fdcf9f800 (LWP 30840)):
[KCrash Handler]
#6  0x00007f2fdb5ad6a4 in KNotification::flags (this=this@entry=0x23d53c0) at /usr/src/debug/knotifications-5.21.0/src/knotification.cpp:233
#7  0x00007f2fdb5cadd7 in NotifyByAudio::onAudioFinished (this=0x23dff70) at /usr/src/debug/knotifications-5.21.0/src/notifybyaudio.cpp:140
#8  0x00007f2fdb5d0525 in NotifyByAudio::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/knotifications-5.21.0/build/src/moc_notifybyaudio.cpp:83
#9  0x00007f2fd7f13cc6 in QMetaObject::activate (sender=0x253ee80, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x0) at kernel/qobject.cpp:3713
#10 0x00007f2fd7f142e7 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7f2fd1267500 <Phonon::MediaObject::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x0) at kernel/qobject.cpp:3578
#11 0x00007f2fd102d6a3 in Phonon::MediaObject::finished (this=<optimized out>) at /usr/src/debug/phonon-4.8.3/build/phonon/moc_mediaobject.cpp:426
#12 0x00007f2fd102fe75 in Phonon::MediaObject::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/phonon-4.8.3/build/phonon/moc_mediaobject.cpp:183
#13 0x00007f2fd7f14ac6 in QObject::event (this=0x253ee80, e=<optimized out>) at kernel/qobject.cpp:1239
#14 0x00007f2fd8bc7e7c in QApplicationPrivate::notify_helper (this=this@entry=0x1d71260, receiver=receiver@entry=0x253ee80, e=e@entry=0x23d1460) at kernel/qapplication.cpp:3716
#15 0x00007f2fd8bcccc8 in QApplication::notify (this=0x7ffcb82d6790, receiver=0x253ee80, e=0x23d1460) at kernel/qapplication.cpp:3499
#16 0x00007f2fd7ee3e95 in QCoreApplication::notifyInternal (this=0x7ffcb82d6790, receiver=0x253ee80, event=event@entry=0x23d1460) at kernel/qcoreapplication.cpp:965
#17 0x00007f2fd7ee6057 in QCoreApplication::sendEvent (event=0x23d1460, receiver=<optimized out>) at kernel/qcoreapplication.h:224
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1d707a0) at kernel/qcoreapplication.cpp:1593
#19 0x00007f2fd7ee6608 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1451
#20 0x00007f2fd7f3b8f3 in postEventSourceDispatch (s=0x1daffc0) at kernel/qeventdispatcher_glib.cpp:271
#21 0x00007f2fcfe37c84 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f2fcfe37ed8 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f2fcfe37f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f2fd7f3ad6c in QEventDispatcherGlib::processEvents (this=0x1dba5d0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f2fd7ee1d53 in QEventLoop::exec (this=this@entry=0x7ffcb82d6670, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f2fd7ee98f6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#27 0x00007f2fdcbc1884 in kdemain (argc=1, argv=<optimized out>) at /usr/src/debug/ksysguard-5.5.5/gui/ksysguard.cpp:596
#28 0x00007f2fdc7c1b25 in __libc_start_main () from /lib64/libc.so.6
#29 0x00000000004007ee in _start () at ../sysdeps/x86_64/start.S:122

Possible duplicates by query: bug 354518, bug 354451, bug 353597.

Reported using DrKonqi
Comment 1 Elvis Angelaccio 2016-10-19 17:32:16 UTC

*** This bug has been marked as a duplicate of bug 348414 ***