Bug 365569

Summary: After update to KF5.24 systemtray is missing its icons (and functionalities)
Product: [Plasma] plasmashell Reporter: slartibart70
Component: System TrayAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: major CC: asturm, cerebellum, cunio, hrvoje.senjan, kde, luca86, nucleo, pulfer, rdieter
Priority: NOR    
Version: 5.6.5   
Target Milestone: 1.0   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description slartibart70 2016-07-12 21:11:21 UTC
I did an update to kde frameworks 5.24 of fedora testing repos.
Reboot system, then login to kde.
- Systemtray seemed to be missing (no icons)
- i unlocked widgets
- systemtray was still there, but empty. Toggling systray entries (like battery of software updates) did not restore the icons
- i removed the systray completely and re-added it
- Icons reappeared, but kde was complaining about not being able to show laptop battery indicator (i also got some errors in .xsession-errors, e.g.
file:///usr/share/plasma/plasmoids/org.kde.plasma.battery/contents/ui/batterymonitor.qml: QML Plasmoid: Cannot anchor to an item that isn't a parent or sibling.)

- logout and login to kde
- systray gone missing again
- same procedure as above, remove systray and re-add it
- now, battery icon is available und works properly

- new logout and re-login: systray gone missing again... :-(


Reproducible: Always
Comment 1 David Edmundson 2016-07-13 18:24:05 UTC
What Qt version are you now on?
Comment 2 Colin J Thomson 2016-07-13 19:05:15 UTC
I am also seeing this and using Fedora 24, Qt version is 5.6.1
Comment 3 Jacek Pawlyta 2016-07-14 12:01:11 UTC
I see exactly the same problem with system tray. 
Fedora 24
KDE Frameworks 5.24.0
Qt 5.6.1 (built against 5.6.1)
Comment 4 Rex Dieter 2016-07-14 12:19:29 UTC
I can confirm this (clearing needinfo as well).
Comment 5 Rex Dieter 2016-07-14 12:23:58 UTC
If it matters, when qt-5.6.1 landed, only selected pieces of plasma were rebuilt, those known to use (or potentially use?) private apis:
plasma-integration
(all other existing plasma builds are done against qt-5.6.0).

and all of kf5-5.24.0 was built against qt-5.6.1 too.

I mention this in case anyone knows of other plasma modules that should be rebulit on Qt5 upgrades (besides plasma-integration).
Comment 6 Rex Dieter 2016-07-14 12:33:57 UTC
I upgraded plasma-5.6.5 to plasma-5.7.1 (which was all built against qt5-5.6.1), and this issue seems gone.  So seems either to be something fixed in 5.7.1 (or some other explanation, like some other plasma module(s) needed rebuilding against qt5-5.6.1 too).
Comment 7 slartibart70 2016-07-14 18:10:57 UTC
just to add my config:
fedora23, qt 5.6.1
Comment 8 Hrvoje Senjan 2016-07-14 20:50:52 UTC
(In reply to Rex Dieter from comment #5)
> I mention this in case anyone knows of other plasma modules that should be
> rebulit on Qt5 upgrades (besides plasma-integration).

Kwin and kwayland; though i doubt this makes a difference for this issue.
In KF5 land, kdeclarative needs rebuilding (shouldn't, but as it can sometimes happen, reality is different, see https://bugreports.qt.io/browse/QTBUG-46433 and https://bugs.launchpad.net/bugs/1426335)
Comment 9 rооt 2016-07-15 06:25:18 UTC
Kubuntu 16.10
KDE Frameworks 5.24.0
Qt 5.6.1 (built against 5.6.1)

system tray working again if the widgets are not locked

No icons in system tray if widgets are locked
https://bugs.kde.org/show_bug.cgi?id=365701
Comment 10 Rex Dieter 2016-07-15 13:39:41 UTC
*** Bug 365701 has been marked as a duplicate of this bug. ***
Comment 11 Pulfer 2016-07-15 16:13:31 UTC
(In reply to Hrvoje Senjan from comment #8)
> (In reply to Rex Dieter from comment #5)
> > I mention this in case anyone knows of other plasma modules that should be
> > rebulit on Qt5 upgrades (besides plasma-integration).
> 
> Kwin and kwayland; though i doubt this makes a difference for this issue.

Reverting these 2 commits seems to fix the issue: 
1. https://quickgit.kde.org/?p=plasma-framework.git&a=commitdiff&h=6f5816fc575927201a1aa9cc1fdb0c75a1a3ab69 
2. https://quickgit.kde.org/?p=plasma-framework.git&a=commitdiff&h=4f7ead27d659352efd5104af08f94cea079d35a6
Comment 12 David Edmundson 2016-07-15 17:01:53 UTC
That second commit won't make a difference to anything
Comment 13 slartibart70 2016-07-18 19:33:55 UTC
retesting with KF5.24, qt5.6.1 and plasma 5.7.1 of fedora testing repos.
Seems to be fixed, no more need to have 'widgets unlocked' for functioning systray.
Thanks!
Comment 14 Pulfer 2016-07-19 02:51:29 UTC
IMHO, KF 5 updates shouldn't break older Plasma 5 releases. It shouldn't be a game "guess which version of KF properly works with which version of Plasma". This bug is marked fixed now, but in fact it still exists in Plasma 5.6 branch used with KF 5.24.
Comment 15 Andreas Sturmlechner 2016-07-24 18:37:45 UTC
Yes, this should definitely be fixed.
Comment 16 Marco Martin 2016-09-20 13:04:19 UTC
Git commit c506c4b669747395755d1ff2b5dde1540b09ad0b by Marco Martin.
Committed on 20/09/2016 at 13:02.
Pushed by mart into branch 'Plasma/5.8'.

better bookeeping of the config

be able to destroy applets even when locked: delete their config
by hand.
Except in one case: when the applet gets automatically destroyed
by dbus activation do *not* clear the config, it should be
reused next time.
Related: bug 365618

M  +14   -4    applets/systemtray/systemtray.cpp

http://commits.kde.org/plasma-workspace/c506c4b669747395755d1ff2b5dde1540b09ad0b
Comment 17 Marco Martin 2016-09-20 13:04:19 UTC
Git commit 641d30c5d58f99d3f43a5b180692367343a74df5 by Marco Martin.
Committed on 20/09/2016 at 13:03.
Pushed by mart into branch 'Plasma/5.8'.

reuse existing applets config

When there is already a config for a given plasmoid, reuse it
instead of creating a brand new plasmoid (having config groups
endlessy accumulating in the config file)

https://phabricator.kde.org/D2817
Related: bug 365618

M  +18   -1    applets/systemtray/systemtray.cpp

http://commits.kde.org/plasma-workspace/641d30c5d58f99d3f43a5b180692367343a74df5