Bug 365355

Summary: Missing icons for some programs in taskbar
Product: plasmashell Reporter: Nick Stefanov <mo78>
Component: Task Manager and Icons-Only Task ManagerAssignee: Eike Hein <hein>
Status: RESOLVED FIXED    
Severity: normal CC: bugseforuns, jan-bugs, kdelibs-bugs, nate, notuxius, plasma-bugs, walch.martin
Priority: NOR    
Version: 5.7.0   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: .config/plasma-org.kde.plasma.desktop-appletsrc

Description Nick Stefanov 2016-07-11 12:56:06 UTC
Icons for some applications are missing. In my case there isn't icon for internet browser and kate/kwrite. The icon for the internet browser appears sometimes but not always. Icon for kate/kwrite never appears. Here you are a screenshot with the problem:

http://i64.tinypic.com/291c6ex.jpg


Reproducible: Always

Steps to Reproduce:
1. Start Plasma 5.7
2.
3.

Actual Results:  
Icons for some applications are missing.

Expected Results:  
There should be icons for programs in taskbar.
Comment 1 Eike Hein 2016-07-12 07:49:44 UTC
Please attach:

1. xprop outout for the KWrite window

2. the outout of: which kwrite

3. The name and location of KWrite's .desktop file on your system
Comment 2 Nick Stefanov 2016-07-12 09:30:58 UTC
Here you are, thank you:

1. https://mega.nz/#!3ARg1RDa
2. mozo@mozo ~]$ which kwrite
/usr/bin/kwrite
3. I don't use .desktop file for kwrite. I use it only from context menu like right button Create->New File and Open with->kwrite/kate.
Comment 3 Eike Hein 2016-07-12 09:32:56 UTC
#3 is still important though, because it's involved in the icon-finding code
Comment 4 Eike Hein 2016-07-12 09:33:27 UTC
#1 doesn't work for me, apparently I need some sort of decryption key - can you use http://paste.kde.org/?
Comment 5 Nick Stefanov 2016-07-12 09:41:15 UTC
Sorry for that. Mega has changed their terms of use obviously. Here you are:
https://cloud.mail.ru/public/Fhkh/2vYmpsbVU

I don't know what to do for step 3. Tell me and I'll do it :)
Comment 6 Martin Walch 2016-09-04 13:26:03 UTC
Created attachment 100927 [details]
.config/plasma-org.kde.plasma.desktop-appletsrc

This sounds very much like the problem that I have seen for several months now. However, today I looked into it and narrowed it down to the configuration file

~/.config/plasma-org.kde.plasma.desktop-appletsrc

The problem seems to be the section

[Containments][32]
activityId=00000000-0000-0000-0000-000000000000
formfactor=0
immutability=1
lastScreen=0
location=0
plugin=org.kde.desktopcontainment
wallpaperplugin=org.kde.image

[Containments][32][Wallpaper][org.kde.image][General]
height=1024
width=1280

which carries the index 32 [Containments][32], but is located before an entry with index [7].
I see this being automatically fixed when unlocking plasmoids and logging out and in again: Entry 32 is then moved to the end of the file with a new index and the icons are visible again.
Comment 7 Martin Walch 2016-09-04 15:36:54 UTC
There must be something else that I am missing. When starting plasmashell with locked plasmoids, some icons are missing. When starting plasmashell with unlocked plasmoids, everything is fine.
Comment 8 Alexander Mentyu 2018-02-28 08:24:51 UTC
@Nick Stefanov @Martin Walch is this issue still relevant for you?
Comment 9 Nick Stefanov 2018-02-28 09:40:16 UTC
Nope everything working fine :)
Comment 10 Martin Walch 2018-02-28 21:16:39 UTC
(In reply to Alexander Mentyu from comment #8)
> @Nick Stefanov @Martin Walch is this issue still relevant for you?

No, I have not seen this problem for more than a year now. Looks like it is fixed.