Bug 364967

Summary: Kmail message list does not remember rightmost column width
Product: [Applications] kmail2 Reporter: Jani-Matti Hätinen <jani-matti.hatinen>
Component: message listAssignee: kdepim bugs <kdepim-bugs>
Status: NEEDSINFO WAITINGFORINFO    
Severity: normal CC: christiandehne, gapon007, kaysimon, m4ngust
Priority: NOR    
Version: 5.2.1   
Target Milestone: ---   
Platform: Debian unstable   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jani-Matti Hätinen 2016-07-01 09:01:04 UTC
I've setup the Kmail message list using the two-row with clickable state style so that there's no horizontal scroll bar. Every time I restart Kmail, it needlessly expands the rightmost clickable state column and thus causes a horizontal scroll bar to appear. I have not modified the clickable state style in any way.



Reproducible: Always

Steps to Reproduce:
1. Adjust column widths to your liking
2. Restart Kmail

Actual Results:  
Rightmost column is expanded needlessly

Expected Results:  
Column widths should remain as set by the user
Comment 1 m4ngust 2016-11-13 19:08:20 UTC
I'm facing same issue. The rightmost column width is maximized whereas all other columns are set at the minimum. It is a bit difficult to trace. If developers can point out how to log this gui issue - would be great!
Thanks!
Comment 2 gapon 2017-08-29 07:48:12 UTC
Same for me, I have to arrange Kmail columns on every PC startup (not Kmail restart, it is remembered during one session).

Anything I can do to help resolve this issue? Thanks!
Comment 3 Justin Zobel 2022-11-08 06:49:59 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 4 Bug Janitor Service 2022-11-23 05:14:13 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!