Bug 364754

Summary: SystemSettings5 crash KDE5
Product: [Applications] systemsettings Reporter: Vladimir <VovanShu>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.5.5   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vladimir 2016-06-25 15:54:54 UTC
Application: systemsettings5 (5.5.5)

Qt Version: 5.5.1
Operating System: Linux 4.4.0-25-generic x86_64
Distribution: Ubuntu 16.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Config view menu by tree.
And after random select  needed section settings (without reconfig) exit from aplication crashed,
System Setting 5.5.5
KDE Framework 5.18.0
Qt 5.5.1

The crash can be reproduced sometimes.

-- Backtrace:
Application: Параметры системы (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f671a72e8c0 (LWP 1940))]

Thread 4 (Thread 0x7f6708b0d700 (LWP 1941)):
#0  0x00007f6716e00e8d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f6714aafc62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f6714ab18d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f670ae8f629 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f671750384e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f67142256fa in start_thread (arg=0x7f6708b0d700) at pthread_create.c:333
#6  0x00007f6716e0cb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f66f8945700 (LWP 1946)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f66fc890213 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f66fc88f937 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007f67142256fa in start_thread (arg=0x7f66f8945700) at pthread_create.c:333
#4  0x00007f6716e0cb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f66f22a5700 (LWP 5219)):
#0  0x00007f6713d3cae4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6713cf7c09 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6713cf8317 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6713cf84ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f671773aa9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f67176e1dea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f67174fe8a4 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f66f161d7d7 in KCupsConnection::run() () from /usr/lib/x86_64-linux-gnu/libkcupslib.so
#8  0x00007f671750384e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f67142256fa in start_thread (arg=0x7f66f22a5700) at pthread_create.c:333
#10 0x00007f6716e0cb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f671a72e8c0 (LWP 1940)):
[KCrash Handler]
#6  0x000000000000002a in ?? ()
#7  0x00007f67177171e9 in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f66f65601b3 in KParts::PartManager::~PartManager() () from /usr/lib/x86_64-linux-gnu/libKF5Parts.so.5
#9  0x00007f66f6560369 in KParts::PartManager::~PartManager() () from /usr/lib/x86_64-linux-gnu/libKF5Parts.so.5
#10 0x00007f671771152b in QObjectPrivate::deleteChildren() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f671771ada0 in QObject::~QObject() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f66f6ca631b in KHTMLPart::~KHTMLPart() () from /usr/lib/x86_64-linux-gnu/libKF5KHtml.so.5
#13 0x00007f66f6ca6439 in KHTMLPart::~KHTMLPart() () from /usr/lib/x86_64-linux-gnu/libKF5KHtml.so.5
#14 0x00007f6717713ec0 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f6718bc905c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007f6718bce516 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007f67176e462b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f67176e6a26 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f671773a673 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f6713cf81a7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f6713cf8400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f6713cf84ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f671773aa7f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f67176e1dea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007f67176e9e8c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x000000000040f7a1 in main ()

Possible duplicates by query: bug 364048, bug 363646, bug 363325, bug 363323, bug 362564.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-06-26 04:09:01 UTC

*** This bug has been marked as a duplicate of bug 355711 ***