Bug 363196

Summary: kwin crashes at least once as soon as I do anything with the desktop
Product: kwin Reporter: Peter Nehem <pnehem>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.6.4   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Peter Nehem 2016-05-18 01:30:31 UTC
Application: kwin_x11 (5.6.4)

Qt Version: 5.6.0
Frameworks Version: 5.22.0
Operating System: Linux 4.5.4-1-ck x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
I was bringing up the browser, or clicking on an icon, it really doesn;t matter what I do, just moving the cursor on the desk top will cause kwin to crash. 
 I downloaded all the qt debugging files and just recompiled kwin and loaded it through pacman, reboot and here is the error.

- Unusual behavior I noticed: Almost aways the same error or in same place if that is the right term to use. Usually I just restart the application and it will run fine for the session or it may crash again and in htop i'll notice entries that read /usr/bin/kwin_x11 ---crashes 1

--Other Notes:
I've only just recomplied kwin, please let me know if I need to recomplied and other modules.

THanks

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1aa8d30840 (LWP 810))]

Thread 6 (Thread 0x7f1a8c59f700 (LWP 824)):
#0  0x00007f1aa855368d in poll () from /usr/lib/libc.so.6
#1  0x00007f1aa600eae2 in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f1aa6010757 in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#3  0x00007f1a8d474a79 in QXcbEventReader::run (this=0xf7e070) at qxcbconnection.cpp:1313
#4  0x00007f1aa62d21d8 in QThreadPrivate::start (arg=0xf7e070) at thread/qthread_unix.cpp:340
#5  0x00007f1aa881d474 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f1aa855c69d in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f1a81b40700 (LWP 832)):
#0  0x00007f1aa8555353 in select () from /usr/lib/libc.so.6
#1  0x00007f1aa64f9fef in qt_safe_select (nfds=8, fdread=fdread@entry=0x7f1a7c000a98, fdwrite=fdwrite@entry=0x7f1a7c000d28, fdexcept=fdexcept@entry=0x7f1a7c000fb8, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f1aa64fb9dc in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f1a7c000fb8, writefds=0x7f1a7c000d28, readfds=0x7f1a7c000a98, nfds=<optimized out>, this=0x7f1a7c0008e0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f1a7c000900, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f1aa64fbeca in QEventDispatcherUNIX::processEvents (this=0x7f1a7c0008e0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f1aa64a646a in QEventLoop::exec (this=this@entry=0x7f1a81b3fd50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f1aa62cd2f3 in QThread::exec (this=this@entry=0x7f1a9f70cd20 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:503
#7  0x00007f1a9f499a65 in QDBusConnectionManager::run (this=0x7f1a9f70cd20 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:181
#8  0x00007f1aa62d21d8 in QThreadPrivate::start (arg=0x7f1a9f70cd20 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:340
#9  0x00007f1aa881d474 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f1aa855c69d in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f1a7b7fe700 (LWP 836)):
#0  0x00007f1aa8555353 in select () from /usr/lib/libc.so.6
#1  0x00007f1aa64f9fef in qt_safe_select (nfds=13, fdread=fdread@entry=0x7f1a6c000a98, fdwrite=fdwrite@entry=0x7f1a6c000d28, fdexcept=fdexcept@entry=0x7f1a6c000fb8, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f1aa64fb9dc in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f1a6c000fb8, writefds=0x7f1a6c000d28, readfds=0x7f1a6c000a98, nfds=<optimized out>, this=0x7f1a6c0008e0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f1a6c000900, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f1aa64fbeca in QEventDispatcherUNIX::processEvents (this=0x7f1a6c0008e0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f1aa64a646a in QEventLoop::exec (this=this@entry=0x7f1a7b7fdd60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f1aa62cd2f3 in QThread::exec (this=this@entry=0x108cf70) at thread/qthread.cpp:503
#7  0x00007f1aa0530915 in QQmlThreadPrivate::run (this=0x108cf70) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/ftw/qqmlthread.cpp:141
#8  0x00007f1aa62d21d8 in QThreadPrivate::start (arg=0x108cf70) at thread/qthread_unix.cpp:340
#9  0x00007f1aa881d474 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f1aa855c69d in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f1a79d85700 (LWP 846)):
#0  0x00007f1aa882309f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f1aa5227134 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f1aa550eec0 <QTWTF::pageheap_memory>) at /tmp/makepkg/qt5-script-debug/src/qtscript-opensource-src-5.6.0/src/3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f1aa5227179 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at /tmp/makepkg/qt5-script-debug/src/qtscript-opensource-src-5.6.0/src/3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f1aa881d474 in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f1aa855c69d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f19ea63f700 (LWP 4275)):
#0  0x00007f1aa64fbba8 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f19e40b3420, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:185
#1  0x00007f1aa64fbeca in QEventDispatcherUNIX::processEvents (this=0x7f19e4051410, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#2  0x00007f1aa64a646a in QEventLoop::exec (this=this@entry=0x7f19ea63ed60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#3  0x00007f1aa62cd2f3 in QThread::exec (this=this@entry=0x1606190) at thread/qthread.cpp:503
#4  0x00007f1aa0530915 in QQmlThreadPrivate::run (this=0x1606190) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/ftw/qqmlthread.cpp:141
#5  0x00007f1aa62d21d8 in QThreadPrivate::start (arg=0x1606190) at thread/qthread_unix.cpp:340
#6  0x00007f1aa881d474 in start_thread () from /usr/lib/libpthread.so.0
#7  0x00007f1aa855c69d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f1aa8d30840 (LWP 810)):
[KCrash Handler]
#5  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f19e9640320) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/include/QtQml/5.6.0/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:349
#6  QQmlBinding::write (this=this@entry=0x233b2b0, core=..., result=..., isUndefined=<optimized out>, flags=...) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/qqmlbinding.cpp:257
#7  0x00007f1aa051dcda in QQmlBinding::update (this=0x233b2b0, flags=...) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/qqmlbinding.cpp:191
#8  0x00007f1aa0526adf in QQmlObjectCreator::finalize (this=0x1edb1b0, interrupt=...) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/qqmlobjectcreator.cpp:1191
#9  0x00007f1aa04b326e in QQmlComponentPrivate::complete (enginePriv=0x11aab70, state=0x1754580) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/qqmlcomponent.cpp:912
#10 0x00007f1aa04b3337 in QQmlComponentPrivate::completeCreate (this=0x17544e0) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/qqmlcomponent.cpp:948
#11 0x00007f1aa04b31a0 in QQmlComponent::create (this=0x1754390, context=0x21e79b0) at /tmp/makepkg/qt5-declarative-debug/src/qtdeclarative-opensource-src-5.6.0/src/qml/qml/qqmlcomponent.cpp:774
#12 0x00007f1a80424d1d in Aurorae::Decoration::init (this=0x21e28b0) at /home/build/kwin/src/kwin-5.6.4/clients/aurorae/src/aurorae.cpp:316
#13 0x00007f1aa8178a5a in KWin::Decoration::DecorationBridge::createDecoration (this=0x1085530, client=client@entry=0x232dd50) at /home/build/kwin/src/kwin-5.6.4/decorations/decorationbridge.cpp:254
#14 0x00007f1aa804c2d9 in KWin::Client::createDecoration (this=this@entry=0x232dd50, oldgeom=...) at /home/build/kwin/src/kwin-5.6.4/client.cpp:393
#15 0x00007f1aa804cd96 in KWin::Client::updateDecoration (this=0x232dd50, check_workspace_pos=<optimized out>, force=<optimized out>) at /home/build/kwin/src/kwin-5.6.4/client.cpp:380
#16 0x00007f1aa80b0f05 in KWin::Client::manage (this=this@entry=0x232dd50, w=w@entry=58720286, isMapped=isMapped@entry=false) at /home/build/kwin/src/kwin-5.6.4/manage.cpp:385
#17 0x00007f1aa802e7cf in KWin::Workspace::createClient (this=this@entry=0x104fe70, w=58720286, is_mapped=is_mapped@entry=false) at /home/build/kwin/src/kwin-5.6.4/workspace.cpp:483
#18 0x00007f1aa8094803 in KWin::Workspace::workspaceEvent (this=0x104fe70, e=0x7f1a84001460) at /home/build/kwin/src/kwin-5.6.4/events.cpp:417
#19 0x00007f1aa64a55af in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f1a84001460, result=result@entry=0x7fff215b7e08) at kernel/qabstracteventdispatcher.cpp:460
#20 0x00007f1a8d476425 in QXcbConnection::handleXcbEvent (this=this@entry=0xf6ee60, event=event@entry=0x7f1a84001460) at qxcbconnection.cpp:1087
#21 0x00007f1a8d47738b in QXcbConnection::processXcbEvents (this=0xf6ee60) at qxcbconnection.cpp:1701
#22 0x00007f1aa64d6179 in QObject::event (this=0xf6ee60, e=<optimized out>) at kernel/qobject.cpp:1256
#23 0x00007f1aa71d07bc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0xf6ee60, e=0x7f1a84001cd0) at kernel/qapplication.cpp:3714
#24 0x00007f1aa71d595f in QApplication::notify (this=0x7fff215b8460, receiver=0xf6ee60, e=0x7f1a84001cd0) at kernel/qapplication.cpp:3495
#25 0x00007f1aa64a8280 in QCoreApplication::notifyInternal2 (receiver=0xf6ee60, event=event@entry=0x7f1a84001cd0) at kernel/qcoreapplication.cpp:1015
#26 0x00007f1aa64aa1fc in QCoreApplication::sendEvent (event=0x7f1a84001cd0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:227
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf4c0e0) at kernel/qcoreapplication.cpp:1650
#28 0x00007f1aa64fbdb2 in QEventDispatcherUNIX::processEvents (this=0xfa7dc0, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#29 0x00007f1a8d4e75dd in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#30 0x00007f1aa64a646a in QEventLoop::exec (this=this@entry=0x7fff215b8350, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#31 0x00007f1aa64aea0c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#32 0x00007f1aa69ebabc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1598
#33 0x00007f1aa71cd865 in QApplication::exec () at kernel/qapplication.cpp:2973
#34 0x00007f1aa8a38a75 in kdemain (argc=<optimized out>, argv=0x7fff215b85e8) at /home/build/kwin/src/kwin-5.6.4/main_x11.cpp:327
#35 0x00007f1aa8495741 in __libc_start_main () from /usr/lib/libc.so.6
#36 0x0000000000400779 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2016-05-18 06:07:49 UTC
As a workaround use the Breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***