Bug 360777

Summary: Due to faulty configuration desktop loading time is ~20 seconds longer
Product: kdeplasma-addons Reporter: soee <kontakt>
Component: GeneralAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED WORKSFORME    
Severity: normal CC: gustavosbarreto, kde, michael, piotr.budny+bugskde
Priority: NOR Keywords: triaged
Version: 5.5.5   
Target Milestone: ---   
Platform: Kubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description soee 2016-03-20 14:34:07 UTC
After some updates and testing various widgets i have noticed that my desktop is loading ~ 20 seconds longer (screen after sddm) - progress bar  reaches 100% and than waits mention time. 

To track down the issue i have removed whole .config folder. It helped but than i go further and located 'faulty' file. It was: `./config/plasma-org.kde.plasma.desktop-appletsrc`. And again going deeper i faound the problem inside following configuration (removing it solved the loading time problem):

[Containments][114]
activityId=795e1540-a8a7-486f-a0f4-f5c2ef8f9e0c
formfactor=0
immutability=1
lastScreen=1
location=0
plugin=org.kde.desktopcontainment
wallpaperplugin=org.kde.image

And related configuration to this path: [Containments][114] in this file is also:

[Containments][114][Applets][112]
immutability=1
plugin=org.kde.plasma.analogclock

[Containments][114][Applets][112][Configuration][ConfigDialog]
DialogHeight=660
DialogWidth=880

[Containments][114][ConfigDialog]
DialogHeight=660
DialogWidth=880

[Containments][114][General]
ItemsGeometries=Applet-112:1600,816,224,192,0;
ToolBoxButtonState=topright
ToolBoxButtonX=1883
pressToMove=false
showToolbox=false

[Containments][114][Wallpaper][org.kde.image][General]
FillMode=2
Image=file:///home/soee/ownCloud/Zdjęcia/Tapety/1920x1080 (2).png
height=1080
width=1920

The only wrong thing i noticed here (from my point of view) is path to not existing image: Image=file:///home/soee/ownCloud/Zdjęcia/Tapety/1920x1080 (2).png - i have removed whole ownCloud dir in my home folder some time ago (btw. shouldn't such invalid images path be handled/removed by Plasma automatically?). But removing this [Containments][114][Wallpaper][org.kde.image][General] part from configuration didn't solve the loading time problem so some other part of pasted configuration causes it.

We have some ToolBox related configuration here - i don't know itf it is important but the ToolBox (old cashew) i have disabled by default.


Reproducible: Always
Comment 1 Piotr Budny 2016-04-12 08:31:24 UTC
Removing ~/.kde/share/config/plasma-desktop-appletsrc helped (no ~20s wait after entering password).
Comment 2 soee 2016-04-12 15:14:50 UTC
I have switched GPU profile from nvidia to intel and this happend again. After i removed file mentioned in my first comment, bootking time is super fast again.
Comment 3 David Edmundson 2016-04-13 10:55:34 UTC
>After some updates and testing various widgets i have noticed that my desktop is loading ~ 20 seconds longer (screen after sddm) - progress bar reaches 100% and than waits mention time. 

does it affect the time when running:

 - kquitapp5 plasmashell
 - plasmashell 

?
Comment 4 Piotr Budny 2016-04-13 17:35:20 UTC
First of all, after removing .kde/share/config/plasma-desktop-appletsrc, no new file with that name was created.

Secondly, copying it back, it did not affect loading time (it is short)
Comment 5 Piotr Budny 2016-04-16 10:35:14 UTC
Aaand it's back. 
kquitapp5 plasmashell & plasmashell runs really fast. It is time to strace some apps, I suppose.
Comment 6 Piotr Budny 2016-04-16 11:06:45 UTC
When the progress bar is 100%, I hit ctrl+alt+esc (kill app shortcut), the login manager closes, and there's ready desktop undernath. The only thing I've seen, that the network is not ready yet (connecting to wifi)
Comment 7 Luis Gustavo S. Barreto 2016-04-18 19:17:08 UTC
Can you paste the output of the following command?

cat .xsession-errors | grep "startup completed"

 I think this bug is related to this change in plasma-framework:

commit 309c64f5e90453c5253baf19e6c01759e8aa6f83
Author: Aleix Pol <aleixpol@kde.org>
Date:   Wed Mar 16 12:33:10 2016 +0100

    Don't import an nonexistent layout
    
    It should have a containment at least
    
    REVIEW: 127345

https://git.reviewboard.kde.org/r/127345/
Comment 8 Michael Marley 2016-04-20 10:45:28 UTC
I ran that command on a system of mine that has the problem and it just says:

Plasma Shell startup completed
Plasma Shell startup completed
Comment 9 Andrew Crouthamel 2018-09-26 22:22:48 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 10 Andrew Crouthamel 2018-10-27 02:39:18 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!