Bug 359589

Summary: Configuracao do Sistema falhou apos mudar a navegacao para modo arvore e navegar item a item
Product: [Applications] systemsettings Reporter: freric <ricdefreitas>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.4.3   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description freric 2016-02-19 23:13:44 UTC
Application: systemsettings5 (5.4.3)

Qt Version: 5.5.1
Operating System: Linux 4.1.15-8-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
1 - I change the panel view from icon to tree
2 - I resize the panel to better view the right side
3 - I navegate through the menu (left side) item by item only to see how it looks
4 - crash

-- Backtrace:
Application: ConfiguraƧƵes do Sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0768660780 (LWP 1820))]

Thread 4 (Thread 0x7f0754ea0700 (LWP 1821)):
#0  0x00007f07643bcbbd in poll () from /lib64/libc.so.6
#1  0x00007f0761197422 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f076119900f in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f07578273c9 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f0764ab532f in QThreadPrivate::start (arg=0xc4d920) at thread/qthread_unix.cpp:331
#5  0x00007f075fa93754 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007f07609210a4 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f07643c4fed in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f073ce04700 (LWP 1837)):
#0  0x00007f0760446cf9 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f07604048fc in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0760404df8 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0760404f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f0764ce7d8b in QEventDispatcherGlib::processEvents (this=0x7f07380008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0x00007f0764c8ed53 in QEventLoop::exec (this=this@entry=0x7f073ce03d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f0764ab061a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f0763037df8 in ?? () from /usr/lib64/libQt5Qml.so.5
#8  0x00007f0764ab532f in QThreadPrivate::start (arg=0x441b730) at thread/qthread_unix.cpp:331
#9  0x00007f075fa93754 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f07609210a4 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f07643c4fed in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f0735926700 (LWP 1840)):
#0  0x00007f07643bcbbd in poll () from /lib64/libc.so.6
#1  0x00007f0760404e64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0760404f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0764ce7d8b in QEventDispatcherGlib::processEvents (this=0x7f07300c4570, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007f0764c8ed53 in QEventLoop::exec (this=this@entry=0x7f0735925d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f0764ab061a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f0763037df8 in ?? () from /usr/lib64/libQt5Qml.so.5
#7  0x00007f0764ab532f in QThreadPrivate::start (arg=0xbf9cd0) at thread/qthread_unix.cpp:331
#8  0x00007f075fa93754 in ?? () from /usr/X11R6/lib64/libGL.so.1
#9  0x00007f07609210a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f07643c4fed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f0768660780 (LWP 1820)):
[KCrash Handler]
#6  0x0000000000000060 in ?? ()
#7  0x00007f0764cc334b in QObject::disconnect (sender=0x100be20, signal=0x1698f79 "destroyed()", signal@entry=0x7f0742cb0c72 "2destroyed()", receiver=receiver@entry=0x10215b0, method=0x169cb59 "slotManagedTopLevelWidgetDestroyed()", method@entry=0x7f0742cb1af0 "1slotManagedTopLevelWidgetDestroyed()") at kernel/qobject.cpp:2932
#8  0x00007f0742c96485 in KParts::PartManager::~PartManager (this=0x10215b0, __in_chrg=<optimized out>) at /usr/src/debug/kparts-5.16.0/src/partmanager.cpp:136
#9  0x00007f0742c96629 in KParts::PartManager::~PartManager (this=0x10215b0, __in_chrg=<optimized out>) at /usr/src/debug/kparts-5.16.0/src/partmanager.cpp:146
#10 0x00007f0764cbf63c in QObjectPrivate::deleteChildren (this=this@entry=0x12fdde0) at kernel/qobject.cpp:1946
#11 0x00007f0764cc92cc in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1024
#12 0x00007f07433d64a6 in KHTMLPart::~KHTMLPart (this=this@entry=0x12fdd50, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/khtml-5.16.0/src/khtml_part.cpp:559
#13 0x00007f07433d6659 in KHTMLPart::~KHTMLPart (this=0x12fdd50, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/khtml-5.16.0/src/khtml_part.cpp:607
#14 0x00007f0764cc1b18 in QObject::event (this=0x12fdd50, e=<optimized out>) at kernel/qobject.cpp:1230
#15 0x00007f07667b3e7c in QApplicationPrivate::notify_helper (this=this@entry=0xc22180, receiver=receiver@entry=0x12fdd50, e=e@entry=0x1659bd0) at kernel/qapplication.cpp:3716
#16 0x00007f07667b8cc8 in QApplication::notify (this=0x7fff5fb1d820, receiver=0x12fdd50, e=0x1659bd0) at kernel/qapplication.cpp:3499
#17 0x00007f0764c90e95 in QCoreApplication::notifyInternal (this=0x7fff5fb1d820, receiver=0x12fdd50, event=event@entry=0x1659bd0) at kernel/qcoreapplication.cpp:965
#18 0x00007f0764c93057 in sendEvent (event=0x1659bd0, receiver=<optimized out>) at kernel/qcoreapplication.h:224
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xc217c0) at kernel/qcoreapplication.cpp:1593
#20 0x00007f0764c93608 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1451
#21 0x00007f0764ce88f3 in postEventSourceDispatch (s=0xd96570) at kernel/qeventdispatcher_glib.cpp:271
#22 0x00007f0760404c84 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f0760404ed8 in ?? () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f0760404f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f0764ce7d6c in QEventDispatcherGlib::processEvents (this=0xd96460, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#26 0x00007f0764c8ed53 in QEventLoop::exec (this=this@entry=0x7fff5fb1d6f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#27 0x00007f0764c968f6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#28 0x00000000004103cf in main (argc=1, argv=<optimized out>) at /usr/src/debug/systemsettings-5.4.3/app/main.cpp:55

Possible duplicates by query: bug 359547, bug 359536, bug 359221, bug 359099, bug 358874.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-02-22 22:38:13 UTC

*** This bug has been marked as a duplicate of bug 355711 ***