Bug 358251

Summary: Dolphin crashes after having selected several files for trash, seems to be in relation with the notification sound popping up.
Product: [Applications] dolphin Reporter: stakanov.s
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 15.12.0   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description stakanov.s 2016-01-20 13:12:24 UTC
Application: dolphin (15.12.0)

Qt Version: 5.5.1
Operating System: Linux 4.1.13-5-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was selecting multiple files in icon view for elimination.

- Unusual behavior I noticed:
I had dolphin open (icon view). I selected with the mouse several icons (no problem). I selected put into trash (no problem). System asked for confirmation (no problem). Clicked yes and  the "have been put into the recyclebin popup appeared, with sound, and the whole thing crashed immediately.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa6e1f1f7c0 (LWP 24687))]

Thread 2 (Thread 0x7fa6bf47b700 (LWP 24689)):
#0  0x00007fa6e17bbc1d in poll () from /lib64/libc.so.6
#1  0x00007fa6d6833e64 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fa6d6833f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fa6dbb38d8b in QEventDispatcherGlib::processEvents (this=0x7fa6b80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007fa6dbadfd53 in QEventLoop::exec (this=this@entry=0x7fa6bf47ae10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fa6db90161a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fa6db90632f in QThreadPrivate::start (arg=0x15d03a0) at thread/qthread_unix.cpp:331
#7  0x00007fa6d73b90a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007fa6e17c404d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fa6e1f1f7c0 (LWP 24687)):
[KCrash Handler]
#6  0x00007fa6e0ce51d4 in KNotification::flags (this=this@entry=0x1d24930) at /usr/src/debug/knotifications-5.16.0/src/knotification.cpp:233
#7  0x00007fa6e0d01e07 in NotifyByAudio::onAudioFinished (this=0x1d2ce90) at /usr/src/debug/knotifications-5.16.0/src/notifybyaudio.cpp:140
#8  0x00007fa6e0d07555 in NotifyByAudio::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/knotifications-5.16.0/build/src/moc_notifybyaudio.cpp:83
#9  0x00007fa6dbb11cc6 in QMetaObject::activate (sender=0x1f2c5c0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x0) at kernel/qobject.cpp:3713
#10 0x00007fa6dbb122e7 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7fa6dd5ed500 <Phonon::MediaObject::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x0) at kernel/qobject.cpp:3578
#11 0x00007fa6dd3b36a3 in Phonon::MediaObject::finished (this=<optimized out>) at /usr/src/debug/phonon-4.8.3/build/phonon/moc_mediaobject.cpp:426
#12 0x00007fa6dd3b5e75 in Phonon::MediaObject::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/phonon-4.8.3/build/phonon/moc_mediaobject.cpp:183
#13 0x00007fa6dbb12ac6 in QObject::event (this=0x1f2c5c0, e=<optimized out>) at kernel/qobject.cpp:1239
#14 0x00007fa6dcc56e7c in QApplicationPrivate::notify_helper (this=this@entry=0x1137590, receiver=receiver@entry=0x1f2c5c0, e=e@entry=0x19bb400) at kernel/qapplication.cpp:3716
#15 0x00007fa6dcc5bcc8 in QApplication::notify (this=0x7ffe4019a4b0, receiver=0x1f2c5c0, e=0x19bb400) at kernel/qapplication.cpp:3499
#16 0x00007fa6dbae1e95 in QCoreApplication::notifyInternal (this=0x7ffe4019a4b0, receiver=0x1f2c5c0, event=event@entry=0x19bb400) at kernel/qcoreapplication.cpp:965
#17 0x00007fa6dbae4057 in sendEvent (event=0x19bb400, receiver=<optimized out>) at kernel/qcoreapplication.h:224
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1135e80) at kernel/qcoreapplication.cpp:1593
#19 0x00007fa6dbae4608 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1451
#20 0x00007fa6dbb398f3 in postEventSourceDispatch (s=0x1185e60) at kernel/qeventdispatcher_glib.cpp:271
#21 0x00007fa6d6833c84 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fa6d6833ed8 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fa6d6833f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fa6dbb38d6c in QEventDispatcherGlib::processEvents (this=0x1180500, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fa6dbadfd53 in QEventLoop::exec (this=this@entry=0x7ffe4019a360, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fa6dbae78f6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#27 0x00007fa6e1ae65f1 in kdemain (argc=1, argv=<optimized out>) at /usr/src/debug/dolphin-15.12.0/src/main.cpp:150
#28 0x00007fa6e1700b05 in __libc_start_main () from /lib64/libc.so.6
#29 0x00000000004007ee in _start () at ../sysdeps/x86_64/start.S:122

Possible duplicates by query: bug 354518, bug 354451, bug 353597, bug 351073, bug 351019.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-04-06 23:49:35 UTC

*** This bug has been marked as a duplicate of bug 348414 ***