Bug 358171

Summary: Breeze theme breaks sddm - login screen presented three times
Product: systemsettings Reporter: Nikola Schnelle <n.schnelle>
Component: kcm_sddmAssignee: David Edmundson <kde>
Status: RESOLVED UPSTREAM    
Severity: normal CC: ahmedbassi, alvarenga, arojas, bruno.n.pagani, cedjo7, cyril.baletaud, demm, dr.robbi3, elvis.angelaccio, fademind, james, jed-bugs.kde.org, jonathan.doman, kde, kdebugs, kontakt, l.jirkovsky, littlebifi, mail2abhisek.maiti, marco_parillo, maxim.stargazer, me, mgraesslin, m_louis30, nils.acrimont+kde, radzevics.lauris, raul338, rdieter, vasyl.demin, wmii392
Priority: NOR    
Version: 5.5.3   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Nikola Schnelle 2016-01-18 16:06:22 UTC
On every boot login screen is presented three times so user need to enter password three times to get to the desktop. Issue seems to be connected with breeze theme. Changing theme to default Maui solves the problem.

More info about this bug can be found on manjaro forum: https://forum.manjaro.org/index.php?topic=29830.msg250489#new

Reproducible: Always
Comment 1 AJSlye 2016-01-18 16:13:13 UTC
I can confirm this issue.
Comment 2 Robbi3 2016-01-18 17:01:41 UTC
Yes can also confirm this issue..
Comment 3 Louis Moureaux 2016-01-18 22:19:37 UTC
I can also confirm. Having read [1], it seems to be related to the combination Breeze theme + Intel graphics.

[1] https://bbs.archlinux.org/viewtopic.php?id=207705
Comment 4 Blink 2016-01-19 06:53:59 UTC
Same problem here.
Comment 5 kdebugs 2016-01-19 09:30:35 UTC
I can also confirm this issue. Seems like this bug is related to Breeze theme so maybe that's a more proper place for it: https://bugs.kde.org/buglist.cgi?component=general&product=Breeze&resolution=---
Comment 6 David Edmundson 2016-01-19 15:11:18 UTC
How many screens do you have?
Comment 7 Elvis Angelaccio 2016-01-19 15:23:19 UTC
(In reply to David Edmundson from comment #6)
> How many screens do you have?
This happens on my laptop with no external monitors, so only one screen here.
Comment 8 Louis Moureaux 2016-01-19 15:25:54 UTC
Only one screen for me too.
Comment 9 AJSlye 2016-01-19 15:29:23 UTC
Personally, I only use one screen most of the time, the one inside the laptops.
This has been happening on more than one of them BTW.
I only have one laptop that i sometimes connect it to the TV when I want to watch a movie from my collection or via Popcorn Time, but this is never connected during startup, shutdown, or during login, log out. I only connect and disconnect the TV in a running session and have no issues with this functionality at all.
Comment 10 Elvis Angelaccio 2016-01-19 15:43:12 UTC
Btw, it really seems random. I just tried again with two boots:
1. The first boot, I had to enter the password only once, as expected.
2. The second one, I had to enter the password way more than 3 times. Only after changing the session from Plasma to LXQt I was able to finally login.
Comment 11 Raúl Arellano 2016-01-20 13:00:00 UTC
I'm also having this problem. I'm using KaOSx in a notebook with an intel b950. Every time it happens I see errors in Xorg log, if i login to plasma (wayland) everything works fine.

Forum thread: http://kaosx.us/phpBB3/viewtopic.php?f=10&t=1299
Error in Xorg: http://kaosx.us/phpBB3/viewtopic.php?p=6809#p6809 (full log: https://paste.kde.org/p4uvc9wcd)
Comment 12 David Edmundson 2016-01-20 13:25:50 UTC
Does it happen if you run:

sddm-greeter --theme /usr/share/sddm/themes/breeze/ --test-mode

?
Comment 13 David Edmundson 2016-01-20 13:26:55 UTC
@Raul, so you think it's X crashing 3 times but not the 4th time.
Comment 14 Bruno Pagani 2016-01-20 13:36:42 UTC
Same issue here (ArchLinux x64, fully updated, Intel 4600HD). I wasn’t able to pinpoint with which package this started, but this might be due to the non-deterministic behaviour of this bug.

Here, I’m sometimes able to login right away, sometimes never until reboot. When it fails, I have this in Xorg.0.log :
[    48.872] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[    48.903] (EE) 
[    48.903] (EE) Backtrace:
[    48.904] (EE) 0: /usr/lib/xorg-server/Xorg (OsLookupColor+0x139) [0x598499]
[    48.904] (EE) 1: /usr/lib/libc.so.6 (__restore_rt+0x0) [0x7f9afb8a967f]
[    48.904] (EE) 2: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0xf413f) [0x7f9af660eaaf]
[    48.904] (EE) 3: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0xf6727) [0x7f9af6613637]
[    48.905] (EE) 4: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0x64e60) [0x7f9af64f0380]
[    48.905] (EE) 5: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0x68b30) [0x7f9af64f7e20]
[    48.905] (EE) 6: /usr/lib/xorg-server/Xorg (WakeupHandler+0xaa) [0x43adca]
[    48.905] (EE) 7: /usr/lib/xorg-server/Xorg (WaitForSomething+0x1ef) [0x590caf]
[    48.905] (EE) 8: /usr/lib/xorg-server/Xorg (SendErrorToClient+0x10e) [0x43609e]
[    48.905] (EE) 9: /usr/lib/xorg-server/Xorg (remove_fs_handlers+0x453) [0x43a293]
[    48.905] (EE) 10: /usr/lib/libc.so.6 (__libc_start_main+0xf0) [0x7f9afb896610]
[    48.905] (EE) 11: /usr/lib/xorg-server/Xorg (_start+0x29) [0x4245c9]
[    48.906] (EE) 12: ? (?+0x29) [0x29]
[    48.906] (EE) 
[    48.906] (EE) Segmentation fault at address 0x0
[    48.906] (EE) 
Fatal server error:
[    48.906] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    48.906] (EE) 
[    48.906] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[    48.906] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    48.906] (EE) 
[    48.906] (II) AIGLX: Suspending AIGLX clients for VT switch
[    48.979] (EE) Server terminated with error (1). Closing log file.
Comment 15 Bruno Pagani 2016-01-20 13:37:39 UTC
To be more precise, the number of needed tries on my system seems random, from 0 to infinite.
Comment 16 nemezis007 2016-01-20 13:38:45 UTC
Same here, it appears that plasma waits for some process. It doesn't matter how many times you are trying to login (my typical is 5 and more attempts) but is seems after some undefined time it goes through
Comment 17 Raúl Arellano 2016-01-20 15:12:14 UTC
Note that this is not happening in ALL intel graphics (i have a netbook with an intel atom / gma950 i think)

@David Edmundson .. I think so, Now I realize that I always have that Xorg.0.log in /var/log even when it does not happens (i changed sddm theme a couple days ago and still have same error with todays date)

In the test, i login with no error but nothings happens. here's the output

raul ~ $ sddm-greeter --theme /usr/share/sddm/themes/breeze/ --test-mode
[12:06:05.242] (II) GREETER: Reading from "/usr/share/xsessions/plasma.desktop"
[12:06:05.243] (II) GREETER: Reading from "/usr/share/wayland-sessions/plasmawayland.desktop"
[12:06:05.243] (EE) GREETER: Socket error:  "QLocalSocket::connectToServer: Invalid name"
[12:06:06.134] (II) GREETER: Adding view for "VGA1" QRect(0,0 1920x1080)
[12:06:06.391] (II) GREETER: Overwriting existing old cached entry due to collision.
[12:06:08.459] (II) GREETER: Reading from "/usr/share/xsessions/plasma.desktop"
[12:06:08.459] (WW) GREETER: QIODevice::write (QLocalSocket): device not open
^C
raul ~ $ sudo sddm-greeter --theme /usr/share/sddm/themes/breeze/ --test-mode
Contraseña: 

Put my password (i don't have more users), hit enter, login button and password textbox sets to gray, and nothing happens
Comment 18 Marco Parillo 2016-01-20 22:38:27 UTC
Changing the theme to Maui seems to resolve it on Manjaro.
Comment 19 AJSlye 2016-01-20 22:46:10 UTC
The Maui theme comes from the SDDM project directly.
This issue only effects the breeze theme, and any other themes based on breeze.
Comment 20 AJSlye 2016-01-21 01:50:37 UTC
 I'll need to test some more, but today's update in Arch to plasma-framework 5.18.0-2 seems to have fixed this issue. I wonder what they patched or back ported?
Comment 21 Raúl Arellano 2016-01-21 02:15:21 UTC
(In reply to AJslye from comment #20)
>  I'll need to test some more, but today's update in Arch to plasma-framework
> 5.18.0-2 seems to have fixed this issue. I wonder what they patched or back
> ported?

Did they updated something? I've been up to 3 days without an issue
Comment 22 AJSlye 2016-01-21 02:26:52 UTC
Yes, Arch had a revision 5.18.0-2 update of Plasma-framworks today (2016-01-20)
https://www.archlinux.org/packages/?sort=&q=plasma-framework&maintainer=&flagged=
Comment 23 Jonathan Doman 2016-01-21 03:01:37 UTC
I upgraded to plasma-framework 5.18.0-2 and it did not change any behavior for me. I am *never* able to login through SDDM when breeze theme is used (tried up to ten times in a row).
Comment 24 AJSlye 2016-01-21 12:12:53 UTC
It looks like the update yesterday of plasma-framework 5.18.0-2 didn't fix the issue after all.
After a reboot this morning, the problem persists, it took 4 attempts before I was able to log in.
SDDM disappears showing the VT output underneath and reloads itself instead of starting Plasma.
Comment 25 Elvis Angelaccio 2016-01-21 12:25:17 UTC
(In reply to AJslye from comment #20)
>  I'll need to test some more, but today's update in Arch to plasma-framework
> 5.18.0-2 seems to have fixed this issue. I wonder what they patched or back
> ported?

You can see it here: https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/plasma-framework&id=1b876fdcb66e690f466b413276fa468acdd6cf8b

It's a patch for another unrelated bug.
Comment 26 AJSlye 2016-01-21 13:23:05 UTC
(In reply to Elvis Angelaccio from comment #25)
> (In reply to AJslye from comment #20)
> >  I'll need to test some more, but today's update in Arch to plasma-framework
> > 5.18.0-2 seems to have fixed this issue. I wonder what they patched or back
> > ported?
> 
> You can see it here:
> https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/
> plasma-framework&id=1b876fdcb66e690f466b413276fa468acdd6cf8b
> 
> It's a patch for another unrelated bug.

Yes, I see that now. The strange thing was I could log out and back in right after the update without issue, it wasn't until I rebooted the laptop in the morning that the issue reappeared.
Comment 27 Robbi3 2016-01-21 13:47:09 UTC
Same experience here, I thought it was fixed with latest update, after few reboots, log- in issue still exists..
Comment 28 Bassio 2016-01-22 07:26:32 UTC
This happened to me after setting up the kubuntu-ppa backports to upgrade to plasma 5.5.3.
I am on Kubuntu Wily.

Symptoms:
On the SDDM login, after I enter the username and password, and instead of showing the plasma desktop, a black screen comes over, with only the cursor visible.
After a while this black screen becomes responsive to CTRL+ALT+Backspace, which when pressed now shows up a new SDDM login screen. The SDDM screen can thus show up 2 or maybe 3 times.
Another symptom is that the kcm module for SDDM was hanging (only when accessed through the system settings and not directly through the application launcher)
I have an NVIDIA GTX 970 but I was using the open source Nouveau driver.

Different to what others were saying here, changing the Breeze theme (to Maui or Maldives) did not solve this problem.

What worked for me though was when I switched my driver to the Nvidia binary. This helped resolve the issue and now I can login, even using the Breeze SDDM theme.
Comment 29 jed-bugs.kde.org 2016-01-22 07:51:58 UTC
*** This bug has been confirmed by popular vote. ***
Comment 30 AJSlye 2016-01-22 11:55:55 UTC
(In reply to Bassio from comment #28)
> This happened to me after setting up the kubuntu-ppa backports to upgrade to
> plasma 5.5.3.
> I am on Kubuntu Wily.
> 
> Symptoms:
> On the SDDM login, after I enter the username and password, and instead of
> showing the plasma desktop, a black screen comes over, with only the cursor
> visible.
> After a while this black screen becomes responsive to CTRL+ALT+Backspace,
> which when pressed now shows up a new SDDM login screen. The SDDM screen can
> thus show up 2 or maybe 3 times.
> Another symptom is that the kcm module for SDDM was hanging (only when
> accessed through the system settings and not directly through the
> application launcher)
> I have an NVIDIA GTX 970 but I was using the open source Nouveau driver.
> 
> Different to what others were saying here, changing the Breeze theme (to
> Maui or Maldives) did not solve this problem.
> 
> What worked for me though was when I switched my driver to the Nvidia
> binary. This helped resolve the issue and now I can login, even using the
> Breeze SDDM theme.

I think your issue is a different one since your SDDM is not reseting back to itself on it's own.
I believe your issue has more to due with your Nvidia chip, the nouveau drivers, mesa and possibly the compositor.  The kcm hang issue is also another issue that been around for a while.
Comment 31 AJSlye 2016-01-22 14:27:13 UTC
I believe the issue is between plasma-workspace (breeze sddm theme) 5.5.3 and SDDM 0.13.0. These are the versions currently in Arch, Manjaro, KaOS, etc.
@ Bassio,
What version of SDDM is in Kubuntu ATM?
Comment 32 Bassio 2016-01-22 15:24:12 UTC
(In reply to AJslye from comment #31)
> I believe the issue is between plasma-workspace (breeze sddm theme) 5.5.3
> and SDDM 0.13.0. These are the versions currently in Arch, Manjaro, KaOS,
> etc.
> @ Bassio,
> What version of SDDM is in Kubuntu ATM?

0.13.0-1ubuntu5 .. but note that is the the Kubuntu backports version (backports plasma 5.5.3)
Comment 33 AJSlye 2016-01-22 15:31:10 UTC
Here are the versions in Manjaro unstable / Arch stable:
sddm - 0.13.0-2
plasma-workspace - 5.5.3-2
plasma-desktop - 5.5.3-2.1
plasma-framework - 5.18.0-2
qt5-base - 5.5.1-9
qt4 - 4.8.7-6

d_ed (David Edmundson)
If any other package versions are needed let me know here or on IRC.
Comment 34 David Edmundson 2016-01-23 21:58:09 UTC
Given it's X crashing I think the SDDM pattern is a red herring (a distraction from the real problem).

Nothing in application space should make X crash deep inside the Mesa driver.  I would guess from the logs it's kwin's first frameswap that's triggering the issue, and something related to the allocations the Breeze theme uses changes the state.

Can someone try with Plasma (safe mode) or Plasma (openbox) to prove who's causing the crash?

Also maybe run sddm-greeter --test-mode --theme /usr/share/sddm/themes/breeze
from within a started session to see if that does influence anything?

Also can someone get debug symbols for mesa so we have better traces of where in the driver we're at.
Comment 35 AJSlye 2016-01-24 22:14:28 UTC
Here is what I get in a running session launching from konsole:
sddm-greeter --test-mode --theme /usr/share/sddm/themes/breeze
[17:10:52.221] (II) GREETER: Reading from "/usr/share/xsessions/plasma.desktop"
[17:10:52.221] (EE) GREETER: Socket error:  "QLocalSocket::connectToServer: Invalid name"
[17:10:52.852] (II) GREETER: Adding view for "LVDS1" QRect(0,0 1600x900)
[17:10:59.309] (II) GREETER: Reading from "/usr/share/xsessions/plasma.desktop"
[17:10:59.310] (WW) GREETER: QIODevice::write (QLocalSocket): device not open
Comment 36 AJSlye 2016-01-25 00:24:55 UTC
I seemed to have fixed this on one of my system.However, I still need to test this on my other two tomorrow.
Here is what I did:
First, I added a plasma-safe.desktop file under /usr/share/xsessions with this in it:
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/bin/startkde --failsafe
TryExec=/usr/bin/startkde
DesktopNames=KDE
Name=Plasma (Failsafe)
Comment=Plasma by KDE (Failsafe)
X-KDE-PluginInfo-Version=5.5.3

Next, I logged out and into Plasma (Failsafe), no issue.
Then I logged out again and selected Plasma, no issue.

I have rebooted my system 4 times and logged in and out 10+ times, now it logs in the first time every time.

@ David,
Is there some file or settings somewhere that startkde --failsafe changes that could have corrected this issue with the normal startkde (Plasma) session?
Comment 37 AJSlye 2016-01-25 00:59:09 UTC
Never mind, after waiting 10 minutes or so I tried to log out and back in again and problem came back. I can however log into Plasma (failsafe) without the issue.
Here are my current logs:
.xsession-errors - http://pastebin.com/fGhKYy6m
Xorg.0.log - http://pastebin.com/v9qwzkWU
Comment 38 AJSlye 2016-01-26 14:25:51 UTC
A user just reported this error in dmesg when the crash occurs:
kactivitymanage[11080]: segfault at xxxxxxxxxx ip xxxxxxxxxx sp xxxxxxxxxx error 4 in libQt5Sql.so.5.5.1[xxxxxxxxxx]

https://forum.manjaro.org/index.php?topic=29857.msg252173#msg252173
Comment 39 AJSlye 2016-01-26 15:02:33 UTC
It looks like this might be a QT5 issue, downgrading qt5-base from 5.5.1.9 to 5.5.1.8 SOLVED the problem for that user.
https://forum.manjaro.org/index.php?topic=29857.msg252179#msg252179
Comment 40 David Edmundson 2016-01-26 16:21:10 UTC
If X crashes, it's an X/driver problem.
Anything else is just coincidence.
Comment 41 cyril.baletaud 2016-02-03 12:39:31 UTC
Same here with 2 PC with Intel graphics.

févr. 03 13:22:43 gentoogige sddm-greeter[398]: Message received from daemon: HostName
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Message received from daemon: Capabilities
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Adding view for "HDMI1" QRect(0,0 1680x1050)
févr. 03 13:22:43 gentoogige sddm-greeter[398]: file:///usr/share/sddm/themes/breeze/components/InfoPane.qml:52:22: Unable to assign [undefined] to int
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject::installEventFilter(): Cannot filter events for objects in a different thread.
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject: Cannot create children for a parent that is in a different thread.
                                                 (Parent is SDDM::GreeterApp(0x7ffef9367710), parent's thread is QThread(0x81b800), current thread is QThread(0x86d4d0)
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Icon theme "hicolor" not found.
févr. 03 13:22:43 gentoogige systemd[390]: Started D-Bus User Message Bus.
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject::installEventFilter(): Cannot filter events for objects in a different thread.
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject: Cannot create children for a parent that is in a different thread.
                                                 (Parent is SDDM::GreeterApp(0x7ffef9367710), parent's thread is QThread(0x81b800), current thread is QThread(0x86d4d0)
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject: Cannot create children for a parent that is in a different thread.
                                                 (Parent is SDDM::GreeterApp(0x7ffef9367710), parent's thread is QThread(0x81b800), current thread is QThread(0x86d4d0)
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject: Cannot create children for a parent that is in a different thread.
                                                 (Parent is SDDM::GreeterApp(0x7ffef9367710), parent's thread is QThread(0x81b800), current thread is QThread(0x86d4d0)
févr. 03 13:22:43 gentoogige sddm-greeter[398]: QObject: Cannot create children for a parent that is in a different thread.
                                                 (Parent is SDDM::GreeterApp(0x7ffef9367710), parent's thread is QThread(0x81b800), current thread is QThread(0x86d4d0)
févr. 03 13:22:43 gentoogige sddm[255]: Message received from greeter: Connect
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Connected to the daemon.
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Reading from "/usr/share/wayland-sessions/plasmawayland.desktop"
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Reading from "/usr/share/xsessions/Xsession.desktop"
févr. 03 13:22:43 gentoogige sddm-greeter[398]: Reading from "/usr/share/xsessions/plasma.desktop"
févr. 03 13:22:43 gentoogige sddm[255]: Greeter session started successfully
Comment 42 Nils 2016-02-03 23:16:39 UTC
I am also facing the issue with my system which is an updated archlinux distribution. 
I would like an explanation about the bug status which is:  RESOLVED UPSTREAM
I am not sure to understand this status, does it mean that a fix has been found? Or that the fix will not be found because the bug does not come from the KDE environment but from Qt because from what I understand, it seems to be a Qt issue.

But then, do we have any idea when will it be resolved? Is the only available solution is to downgrade qt5-base from 5.5.1.9 to 5.5.1.8?
Comment 43 David Edmundson 2016-02-03 23:22:27 UTC
>I would like an explanation about the bug status which is: RESOLVED UPSTREAM

If X crashes it's a problem in X or lower, and it needs to be reported and fixed in that component.
Comment 44 AJSlye 2016-02-04 01:15:56 UTC
This is a bug in Xorg or lower. It's not clear as to the actual cause of the crash since Arch doesn't have debug symbols for Mesa, etc. The only solution that seems to be a compleate workaround is to use DRI 3. Alternatively you can use one of the other SDDM themes that came with it as these render differently and do not crash the xserver.
Comment 45 Nils 2016-02-04 12:53:57 UTC
I am using Nvidia driver, and it says here: https://bbs.archlinux.org/viewtopic.php?id=198656 that "Nvidia uses their own implementation of OpenGL, thus DRI3 from Mesa libs has no influence." so I am a bit puzzled. 
Furthermore, I have no other theme suggested in SDDM graphical user interface than Breeze. 

Otherwise, has someone reported the issue in xorg? It would be nice to reference the xorg issue on this ticket.
Comment 46 Antonio Rojas 2016-02-04 13:53:36 UTC
The crash should be fixed by http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=7817949314a21293c8bc34dec214b42932b19aaf

(In reply to Nils from comment #45)
> I am using Nvidia driver

Then yours is a different issue
Comment 47 AJSlye 2016-02-04 15:01:46 UTC
Antonio Rojas,
That only fixes one of the issues in the Intel xorg driver, It doesn't fix the actual cause of the issue.
The fact of the mater is, there is no way of finding the culprit without proper debug symbols for the components involved in the crash, from the Plasma shell and qt down to xorg and the gpu drivers. By the looks of the plasma bug report that I could get, it's the way QT5 handles the framebuffer created by the breeze theme that is causing the crash. But then again, there are no debug symbols compiled into qt5 under Arch to further diagnose this further.

Nils,
When you installed SDDM it should have came with the upstream circles, elarun, maldives, and maui themes.
Comment 48 Martin Flöser 2016-02-10 08:41:28 UTC
From the comments and logs in this bug report it seems that only Intel on SNA is affected. This seems to be confirmed by comment #46.

Given that I would like to ask you to try, to switch from SNA to either EXA, UXA or glamor.
Comment 49 Cedjo 2016-02-10 08:48:00 UTC
I had it solved by the DRI=3 solution on my Lenovo S1 Yoga.
https://bbs.archlinux.org/viewtopic.php?pid=1603247#p1603247
Comment 50 Martin Flöser 2016-02-10 08:54:49 UTC
That would be confirmed by:
> [ 48.872] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
Comment 51 Elvis Angelaccio 2016-02-10 09:27:34 UTC
(In reply to Martin Gräßlin from comment #48)
> From the comments and logs in this bug report it seems that only Intel on
> SNA is affected. This seems to be confirmed by comment #46.
> 
> Given that I would like to ask you to try, to switch from SNA to either EXA,
> UXA or glamor.

I can confirm that switching to UXA workarounds the issue.
Enabling DRI3 seems to work too.
Comment 52 littlebifi 2016-02-10 09:48:34 UTC
For me with Manjaro 15.12 switching to DRI 3 fixes the bug. I've also tried UXA, but had performance issues. The solution also works for us on arch.

We've created the option of the intel driver (/etc/X11/xorg.conf.d/20-intel.conf) with:

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "sna"
        Option 		"DRI" "3"
EndSection

https://bbs.archlinux.org/viewtopic.php?pid=1603247#p1603247