Bug 355587

Summary: Manually control number of rows/columns in system tray
Product: [Plasma] plasmashell Reporter: Apoorv Parle <apparle>
Component: System TrayAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: wishlist CC: bob.mt.wya, chgonzalezg, materka, mklapetek, nate, notmart, samrog131, zmogas
Priority: NOR    
Version: master   
Target Milestone: 1.0   
Platform: Kubuntu   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=363562
https://bugs.kde.org/show_bug.cgi?id=360333
Latest Commit: Version Fixed In: 5.20.0
Attachments: Wide panel with 2 columns in tray
Thin panel with tray in 1 column

Description Apoorv Parle 2015-11-19 13:09:55 UTC
Hi,
I use the main panel in vertical orientation. I prefer to use the system tray arranged in two columns. Because the tray automatically switches from double column to single column, I'm not able to to shrink it to a desired size.
When the tray is in single column mode, and I reduce the panel width, and the icons scale automatically. I would prefer to shrink the icons while keeping them in 2 columns when I shrink the width of the panel.

Reproducible: Always

Steps to Reproduce:
1. Put main panel with system tray on left vertical screen edge. Widen it until there are 2 columns in the system tray
2. Reduce the width of the column. 
3. 

Actual Results:  
The tray will automatically switches to single column mode.

Expected Results:  
There should be a way/option to fix the number of columns to two, and still scale the icons according to the panel width.
Comment 1 Apoorv Parle 2015-11-19 13:11:18 UTC
Created attachment 95597 [details]
Wide panel with 2 columns in tray

As visible in the image, the icons used in the tray are pretty big right now.
Comment 2 Apoorv Parle 2015-11-19 13:13:10 UTC
Created attachment 95598 [details]
Thin panel with tray in 1 column

Here the width of the panel is reduced, and small icons are used for the tray.
Ideally there should be a way to use such small icons, but use 2 columns in the tray.
Comment 3 Martin Klapetek 2015-12-04 20:27:31 UTC
I think this https://git.reviewboard.kde.org/r/125773/ could/would fix it.

Are you able to test patches? Could you test this one?
Comment 4 Apoorv Parle 2015-12-05 03:49:10 UTC
Unfortunately, I cannot test patches, at least not any time in near future because I'm using this system for work.

But judging from comments, the patch seems to be fixing rendering of fonts on the pop-up. I'm not sure if it provides a manual control on the grid to be used for tray icons (but I might be wrong, since I didn't read the code).
Comment 5 Martin Klapetek 2015-12-05 05:06:39 UTC
Not manual control, but better sizing of the icons. Basically David in the review has the same problem as you with the systray icons.
Comment 6 Rog131 2016-05-22 09:14:15 UTC
Kubuntu forums has an example how to edit the Layout.js to get smaller icons to the vertical system tray: https://www.kubuntuforums.net/showthread.php?69658-Reduce-icon-size-in-vertical-panel&p=384036&viewfull=1#post384036
Comment 7 Bob Wya 2016-05-22 13:36:34 UTC
(In reply to Rog131 from comment #6)
> Kubuntu forums has an example how to edit the Layout.js to get smaller icons
> to the vertical system tray:
> https://www.kubuntuforums.net/showthread.php?69658-Reduce-icon-size-in-
> vertical-panel&p=384036&viewfull=1#post384036

Boom!! IMHO that should exposed in the (rather anaemic) system tray configuration gui...
Thanks :-)
Comment 8 Bob Wya 2016-05-22 13:50:39 UTC
(In reply to Martin Klapetek from comment #3)
> I think this https://git.reviewboard.kde.org/r/125773/ could/would fix it.
> 
> Are you able to test patches? Could you test this one?

I've tested the patch - along with setting my systemtray icons to a fixed size (16x16) - in the systemtray plasmoid.

I don't normally run with a Vertical Panel (since KDE4 / Plasma 5 have not supported this configuration very well). Now I've got to say it's become a totally viable option!! It's possible to match the look 'n' feel of a Windows vertical panel (which previously looked far better).

Should this bug have the VisualDesign + set? The vertical panel configuration thread - was a hot topic in the VDG subforum - when Plasma 5 was being worked on!!

Personally I really like my new look desktop. It's now possible to have much thinner panels - without the systemtray icons looking dumbly oversized.

Screenshots can be supplied - if anyone is interested...
Comment 9 Konrad Materka 2020-05-26 21:05:08 UTC
There is an idea to have configurable icon size:
https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/24

With this, it should be possible to configure smaller icons that should arrange automatically in rows/columns.
Comment 10 Konrad Materka 2020-05-29 14:36:26 UTC
Git commit 161309cdf5904bca3db5a64da3706bb808efe67c by Konrad Materka.
Committed on 29/05/2020 at 14:35.
Pushed by kmaterka into branch 'master'.

[applets/systemtray] Configurable maximum icon size

Add configuration UI for setting maximum icon size. This utilizes existing configuration parameter. It is a maximum allowed icon size, if panel is smaller, icon will fit to closest smaller size.
Related: bug 360333

FIXED-IN: 5.20.0

M  +5    -0    applets/systemtray/package/contents/config/config.qml
C  +16   -8    applets/systemtray/package/contents/ui/ConfigGeneral.qml [from: applets/systemtray/package/contents/config/config.qml - 070% similarity]
M  +1    -1    applets/systemtray/package/contents/ui/items/AbstractItem.qml
M  +2    -2    applets/systemtray/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/161309cdf5904bca3db5a64da3706bb808efe67c