Bug 355218

Summary: Kontact crashes after switch from kdepim4 to 5
Product: [Frameworks and Libraries] Akonadi Reporter: Thomas Baag <thomas>
Component: IMAP resourceAssignee: Christian Mollekopf <chrigi_1>
Status: RESOLVED NOT A BUG    
Severity: crash CC: kdepim-bugs, vkrause
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: output from kontact

Description Thomas Baag 2015-11-11 23:40:52 UTC
Application: akonadi_imap_resource (4.89.0)

Qt Version: 5.5.1
Operating System: Linux 4.2.5-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Launched kontact. Window came up but didn't render any content.

- Custom settings of the application:
I was switching from kde4 to kf15/plasma5.
I manually compiled arkonadi (with archlinux/abs) with debug symbols.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi-Ressource (akonadi_imap_resource), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2be7546840 (LWP 24900))]

Thread 2 (Thread 0x7f2bcedf5700 (LWP 24901)):
#0  0x00007f2be156d18d in poll () from /usr/lib/libc.so.6
#1  0x00007f2bdc22bae2 in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f2bdc22d757 in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#3  0x00007f2bd0b33e89 in ?? () from /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f2be1e8496e in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007f2bdc44b4a4 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f2be157613d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f2be7546840 (LWP 24900)):
[KCrash Handler]
#5  0x00007f2be14c05f8 in raise () from /usr/lib/libc.so.6
#6  0x00007f2be14c1a7a in abort () from /usr/lib/libc.so.6
#7  0x00007f2be1ad6b3d in __gnu_cxx::__verbose_terminate_handler () at /build/gcc-multilib/src/gcc-5.2.0/libstdc++-v3/libsupc++/vterminate.cc:95
#8  0x00007f2be1ad4996 in __cxxabiv1::__terminate (handler=<optimized out>) at /build/gcc-multilib/src/gcc-5.2.0/libstdc++-v3/libsupc++/eh_terminate.cc:47
#9  0x00007f2be1ad49e1 in std::terminate () at /build/gcc-multilib/src/gcc-5.2.0/libstdc++-v3/libsupc++/eh_terminate.cc:57
#10 0x00007f2be1ad4bf8 in __cxxabiv1::__cxa_throw (obj=0xfbfa30, tinfo=0x7f2be075c988 <typeinfo for Akonadi::ProtocolException>, dest=0x7f2be0509770 <Akonadi::ProtocolException::~ProtocolException()>) at /build/gcc-multilib/src/gcc-5.2.0/libstdc++-v3/libsupc++/eh_throw.cc:87
#11 0x00007f2be050a7f1 in Akonadi::Protocol::DataStream::waitForData(unsigned int) () from /usr/lib/libKF5AkonadiPrivate.so.5
#12 0x00007f2be0520e99 in Akonadi::Protocol::DataStream::operator>>(QByteArray&) () from /usr/lib/libKF5AkonadiPrivate.so.5
#13 0x00007f2be0532b48 in Akonadi::Protocol::ChangeNotificationPrivate::deserialize(Akonadi::Protocol::DataStream&) () from /usr/lib/libKF5AkonadiPrivate.so.5
#14 0x00007f2be05169ee in Akonadi::Protocol::deserialize(QIODevice*) () from /usr/lib/libKF5AkonadiPrivate.so.5
#15 0x00007f2be59613e3 in Akonadi::SessionPrivate::dataReceived() () from /usr/lib/libKF5AkonadiCore.so.5
#16 0x00007f2be209412a in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#17 0x00007f2be209412a in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#18 0x00007f2be3a8c9ee in ?? () from /usr/lib/libQt5Network.so.5
#19 0x00007f2be3a993e1 in ?? () from /usr/lib/libQt5Network.so.5
#20 0x00007f2be301c01c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#21 0x00007f2be30214f6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#22 0x00007f2be20659ab in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#23 0x00007f2be20bc81d in ?? () from /usr/lib/libQt5Core.so.5
#24 0x00007f2bdb200dc7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x00007f2bdb201020 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x00007f2bdb2010cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0x00007f2be20bc34f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#28 0x00007f2be206337a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#29 0x00007f2be206b33c in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#30 0x00007f2be5cd173a in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libKF5AkonadiAgentBase.so.5
#31 0x000000000043d083 in int Akonadi::ResourceBase::init<ImapResource>(int, char**) ()
#32 0x00007f2be14ad610 in __libc_start_main () from /usr/lib/libc.so.6
#33 0x000000000043cf49 in _start ()

Possible duplicates by query: bug 353304, bug 352408, bug 352280, bug 351515, bug 351097.

Reported using DrKonqi
Comment 1 Thomas Baag 2015-11-11 23:58:25 UTC
Created attachment 95450 [details]
output from kontact
Comment 2 Thomas Baag 2015-11-12 00:00:32 UTC
> Socket error occurred: "QLocalSocket: Zeit├╝berschreitung bei Socket-Operation"
It says: Timeout.
Comment 3 Thomas Baag 2015-11-12 00:18:04 UTC
(In reply to Thomas Baag from comment #1)
> Created attachment 95450 [details]
> output from kontact

terminate called after throwing an instance of 'Akonadi::ProtocolException'
  what():  Timeout while waiting for data
Comment 4 Thomas Baag 2015-11-12 00:32:44 UTC
akonadictl status
> Akonadi Control: running
> Akonadi Server: running
> search paths:  ("lib", "lib/qt5/plugins/", "lib/kf5/", "lib/kf5/plugins/", "/usr/lib/qt5/plugins/", "/usr/lib/qt/plugins", "/usr/bin")
> Akonadi Server Search Support: available (Remote Search)
> Available Agent Types: akonadi_akonotes_resource, akonadi_archivemail_agent, akonadi_baloo_indexer, akonadi_birthdays_resource, akonadi_contacts_resource, akonadi_davgroupware_resource, akonadi_followupreminder_agent, akonadi_googlecalendar_resource, akonadi_googlecontacts_resource, akonadi_ical_resource, akonadi_icaldir_resource, akonadi_imap_resource, akonadi_indexing_agent, akonadi_invitations_agent, akonadi_kalarm_dir_resource, akonadi_kalarm_resource, akonadi_knut_resource, akonadi_kolab_resource, akonadi_maildir_resource, akonadi_maildispatcher_agent, akonadi_mailfilter_agent, akonadi_mbox_resource, akonadi_migration_agent, akonadi_mixedmaildir_resource, akonadi_newmailnotifier_agent, akonadi_notes_agent, akonadi_notes_resource, akonadi_openxchange_resource, akonadi_pop3_resource, akonadi_sendlater_agent, akonadi_vcard_resource, akonadi_vcarddir_resource
Comment 5 Thomas Baag 2015-11-13 00:03:48 UTC
Problem vanished after an "akonadictl restart". It seemed like the internal chat of akonadi didn't go as expected. Maybe because of different versions of library and akonadi process running.
Comment 6 Thomas Baag 2015-11-13 00:04:34 UTC
Problem vanished after an "akonadictl restart". It seemed like the internal chat of akonadi didn't go as expected. Maybe because of different versions of library and akonadi process running.