Bug 354849

Summary: Link to "Open LastFM webpage for this artist" dead
Product: amarok Reporter: Olivier Churlaud <olivier>
Component: Context View/Similar ArtistsAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: normal CC: jclavel
Priority: NOR    
Version: 2.8.90 (2.9 beta)   
Target Milestone: 2.9   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 2.9

Description Olivier Churlaud 2015-11-04 19:13:50 UTC
The link is dead and should be changed.

It points to http://www.http.com//www.last.fm/music/>Artist_Name>

Reproducible: Always
Comment 1 Stefano Pettini 2018-02-24 22:37:46 UTC
Git commit ee13a2d2fbfe0720491c95be9be865b2e36bdd81 by Stefano Pettini.
Committed on 24/02/2018 at 22:34.
Pushed by spettini into branch 'master'.

Fixed "Open Last-fm webpage" of similar artist

It looks like the assumption that last.fm returns incomplete
urls is not valid. This at least since 2015.
FIXED-IN: 2.9

M  +2    -4    src/context/applets/similarartists/ArtistWidget.cpp

https://commits.kde.org/amarok/ee13a2d2fbfe0720491c95be9be865b2e36bdd81