Bug 352098

Summary: "System Configuration" app crash when opening "Screen and Monitor" option
Product: [I don't know] kde Reporter: Vitor Boufleur <v.boufleur>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vitor Boufleur 2015-09-01 13:47:08 UTC
Application: systemsettings5 (5.3.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-26-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
When opening the "Screen and Monitor" option the System Configuration app is crashing everytime. I didn't test if a reboot will solve this problem. If anyone wants more information I'm available.

The crash can be reproduced every time.

-- Backtrace:
Application: ConfiguraƧƵes do Sistema (systemsettings5), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f69803b3780 (LWP 26316))]

Thread 3 (Thread 0x7f696d863700 (LWP 26317)):
#0  0x00007f697cb158dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f697ae29b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f697ae2b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6970622099 in QXcbEventReader::run (this=0x1beb200) at qxcbconnection.cpp:1105
#4  0x00007f697d196b0e in QThreadPrivate::start (arg=0x1beb200) at thread/qthread_unix.cpp:337
#5  0x00007f6979d476aa in start_thread (arg=0x7f696d863700) at pthread_create.c:333
#6  0x00007f697cb20eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f695eba1700 (LWP 26319)):
#0  0x00007f697986d7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f69798286f9 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6979828e37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6979828fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f697d42dc6c in QEventDispatcherGlib::processEvents (this=0x7f69580008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f697d3d23e2 in QEventLoop::exec (this=this@entry=0x7f695eba0e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f697d191b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f697c15bf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f697d196b0e in QThreadPrivate::start (arg=0x1fe90b0) at thread/qthread_unix.cpp:337
#9  0x00007f6979d476aa in start_thread (arg=0x7f695eba1700) at pthread_create.c:333
#10 0x00007f697cb20eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f69803b3780 (LWP 26316)):
[KCrash Handler]
#6  0x00007f697ca4f267 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:55
#7  0x00007f697ca50eca in __GI_abort () at abort.c:89
#8  0x00007f697d183edf in qt_message_fatal (context=..., message=...) at global/qlogging.cpp:1415
#9  QMessageLogger::fatal (this=0x7ffc8afce190, msg=<optimized out>) at global/qlogging.cpp:636
#10 0x00007f697bc03791 in QSGRenderLoop::handleContextCreationFailure(QQuickWindow*, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f697bc0d06f in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f697bc0d30a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f697dc0c7b5 in QWindow::event (this=0x2004e90, ev=<optimized out>) at kernel/qwindow.cpp:2051
#14 0x00007f697bc3edd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f697e1c0b2c in QApplicationPrivate::notify_helper (this=0x1bbe4a0, receiver=0x2004e90, e=0x7ffc8afce610) at kernel/qapplication.cpp:3720
#16 0x00007f697e1c6000 in QApplication::notify (this=0x7ffc8afcea10, receiver=0x2004e90, e=0x7ffc8afce610) at kernel/qapplication.cpp:3503
#17 0x00007f697d3d4c2b in QCoreApplication::notifyInternal (this=0x7ffc8afcea10, receiver=receiver@entry=0x2004e90, event=event@entry=0x7ffc8afce610) at kernel/qcoreapplication.cpp:935
#18 0x00007f697dc04e86 in sendSpontaneousEvent (event=0x7ffc8afce610, receiver=0x2004e90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QGuiApplicationPrivate::processExposeEvent (e=0x217cdc0) at kernel/qguiapplication.cpp:2613
#20 0x00007f697dc05bbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x217cdc0) at kernel/qguiapplication.cpp:1638
#21 0x00007f697dbea34f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#22 0x00007f697064c590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#23 0x00007f6979828c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f6979828f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f6979828fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f697d42dc57 in QEventDispatcherGlib::processEvents (this=0x1c348d0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#27 0x00007f697d3d23e2 in QEventLoop::exec (this=this@entry=0x7ffc8afce8f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#28 0x00007f697d3da02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#29 0x00007f697dbfb31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#30 0x00007f697e1bc7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#31 0x000000000040ef6b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-03 09:22:18 UTC

*** This bug has been marked as a duplicate of bug 346519 ***