Bug 351691

Summary: KDED crash during indexing
Product: [Frameworks and Libraries] frameworks-knotifications Reporter: Philip C <cliabhach>
Component: generalAssignee: Martin Klapetek <mklapetek>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kdelibs-bugs
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Philip C 2015-08-24 12:20:41 UTC
Application: kded5 ()

Qt Version: 5.4.1
Operating System: Linux 3.19.0-26-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Yesterday, I modified the baloo file indexing settings to cover fewer folders. I left the system on overnight, with 2 GUI applications open: Chrome and Libreoffice Calc. In the morning, upon waking the computer from sleep, I saw this crash report waiting for me.

-- Backtrace:
Application: kded5 (kded5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f92ebca6780 (LWP 2760))]

Thread 11 (Thread 0x7f92dfa00700 (LWP 2761)):
#0  0x00007f92eb6868dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f92e61d5b72 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f92e61d764f in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f92ebc16099 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#4  0x00007f92e998db0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f92e93c46aa in start_thread (arg=0x7f92dfa00700) at pthread_create.c:333
#6  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 10 (Thread 0x7f92d1525700 (LWP 2762)):
#0  0x00007f92e8eea7a4 in g_mutex_unlock (mutex=0x1638510) at /build/buildd/glib2.0-2.44.1/./glib/gthread-posix.c:1348
#1  0x00007f92e8ea56f9 in g_main_context_query (context=context@entry=0x1638510, max_priority=2147483647, timeout=timeout@entry=0x7f92d1524e44, fds=fds@entry=0x7f92cc0010c0, n_fds=n_fds@entry=3) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3557
#2  0x00007f92e8ea5e37 in g_main_context_iterate (context=0x1638510, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3790
#3  0x00007f92e8ea6242 in g_main_loop_run (loop=0x16384a0) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:4002
#4  0x00007f92dd480af6 in gdbus_shared_thread_func (user_data=0x16384e0) at /build/buildd/glib2.0-2.44.1/./gio/gdbusprivate.c:274
#5  0x00007f92e8ecc955 in g_thread_proxy (data=0x15f8050) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#6  0x00007f92e93c46aa in start_thread (arg=0x7f92d1525700) at pthread_create.c:333
#7  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 9 (Thread 0x7f92d0d24700 (LWP 2764)):
#0  0x00007f92eb6868dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f92e8ea5ebc in g_main_context_iterate (priority=2147483647, n_fds=2, fds=0x7f92c40008c0, timeout=-1, context=0x16408f0) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:4103
#2  0x00007f92e8ea5ebc in g_main_context_iterate (context=context@entry=0x16408f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3803
#3  0x00007f92e8ea5fcc in g_main_context_iteration (context=0x16408f0, may_block=may_block@entry=1) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3869
#4  0x00007f92e8ea6009 in glib_worker_main (data=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:5618
#5  0x00007f92e8ecc955 in g_thread_proxy (data=0x15f80f0) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#6  0x00007f92e93c46aa in start_thread (arg=0x7f92d0d24700) at pthread_create.c:333
#7  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 8 (Thread 0x7f92ad200700 (LWP 2803)):
#0  0x00007f92eb6868dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f92e8ea5ebc in g_main_context_iterate (priority=2147483647, n_fds=1, fds=0x7f928c004cc0, timeout=-1, context=0x7f928c000990) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:4103
#2  0x00007f92e8ea5ebc in g_main_context_iterate (context=context@entry=0x7f928c000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3803
#3  0x00007f92e8ea5fcc in g_main_context_iteration (context=0x7f928c000990, may_block=1) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3869
#4  0x00007f92e9c24c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f92e9bc93e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f92e9988b44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f92b7507cf7 in KCupsConnection::run() () at /usr/lib/x86_64-linux-gnu/libkcupslib.so
#8  0x00007f92e998db0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f92e93c46aa in start_thread (arg=0x7f92ad200700) at pthread_create.c:333
#10 0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 7 (Thread 0x7f92ac9ff700 (LWP 2804)):
#0  0x00007f92eb6a03a6 in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:134
#1  0x00007f92e9a43cb6 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f92e9c22639 in QTimerInfoList::updateCurrentTime() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f92e9c22ba5 in QTimerInfoList::timerWait(timespec&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f92e9c2403e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f92e8ea53fd in g_main_context_prepare (context=context@entry=0x7f9288000990, priority=priority@entry=0x7f92ac9fed00) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3410
#6  0x00007f92e8ea5de8 in g_main_context_iterate (context=context@entry=0x7f9288000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3788
#7  0x00007f92e8ea5fcc in g_main_context_iteration (context=0x7f9288000990, may_block=1) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3869
#8  0x00007f92e9c24c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f92e9bc93e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f92e9988b44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f92e998db0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f92e93c46aa in start_thread (arg=0x7f92ac9ff700) at pthread_create.c:333
#13 0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f92b0444700 (LWP 21401)):
#0  0x00007f92eb68c5a9 in syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007f92e8eea8ef in g_cond_wait (cond=0x7f925c03d650, mutex=0x7f925c03d608) at /build/buildd/glib2.0-2.44.1/./glib/gthread-posix.c:1395
#2  0x00007f92a4eaed0d in  () at /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0
#3  0x00007f92e8ecd2e8 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gthreadpool.c:307
#4  0x00007f92e8ecc955 in g_thread_proxy (data=0x7f92b8003190) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#5  0x00007f92e93c46aa in start_thread (arg=0x7f92b0444700) at pthread_create.c:333
#6  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f9282857700 (LWP 21402)):
#0  0x00007f92eb68c5a9 in syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007f92e8eea8ef in g_cond_wait (cond=0x7f92901389b0, mutex=0x7f9290138968) at /build/buildd/glib2.0-2.44.1/./glib/gthread-posix.c:1395
#2  0x00007f92a4eaed0d in  () at /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0
#3  0x00007f92e8ecd2e8 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gthreadpool.c:307
#4  0x00007f92e8ecc955 in g_thread_proxy (data=0x325e0f0) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#5  0x00007f92e93c46aa in start_thread (arg=0x7f9282857700) at pthread_create.c:333
#6  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f9282056700 (LWP 21403)):
#0  0x00007f92eb68c5a9 in syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007f92e8eea8ef in g_cond_wait (cond=0x7f9298008678, mutex=0x7f9298008668) at /build/buildd/glib2.0-2.44.1/./glib/gthread-posix.c:1395
#2  0x00007f92a4579032 in  () at /usr/lib/x86_64-linux-gnu/libgstbase-1.0.so.0
#3  0x00007f92a457a340 in gst_data_queue_pop () at /usr/lib/x86_64-linux-gnu/libgstbase-1.0.so.0
#4  0x00007f927e83a201 in  () at /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstcoreelements.so
#5  0x00007f92a4eaeb71 in  () at /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0
#6  0x00007f92e8ecd2e8 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gthreadpool.c:307
#7  0x00007f92e8ecc955 in g_thread_proxy (data=0x326a370) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#8  0x00007f92e93c46aa in start_thread (arg=0x7f9282056700) at pthread_create.c:333
#9  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f9281855700 (LWP 21404)):
#0  0x00007f92eb68c5a9 in syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007f92e8eea8ef in g_cond_wait (cond=0x7f925c03d2f0, mutex=0x7f925c03d2a8) at /build/buildd/glib2.0-2.44.1/./glib/gthread-posix.c:1395
#2  0x00007f92a4eaed0d in  () at /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0
#3  0x00007f92e8ecd2e8 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gthreadpool.c:307
#4  0x00007f92e8ecc955 in g_thread_proxy (data=0x325e1e0) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#5  0x00007f92e93c46aa in start_thread (arg=0x7f9281855700) at pthread_create.c:333
#6  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f9280853700 (LWP 21654)):
#0  0x00007f92eb68c5a9 in syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007f92e8eea8ef in g_cond_wait (cond=0x7f9290138650, mutex=0x7f9290138608) at /build/buildd/glib2.0-2.44.1/./glib/gthread-posix.c:1395
#2  0x00007f92a4eaed0d in  () at /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so.0
#3  0x00007f92e8ecd2e8 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gthreadpool.c:307
#4  0x00007f92e8ecc955 in g_thread_proxy (data=0x326a770) at /build/buildd/glib2.0-2.44.1/./glib/gthread.c:764
#5  0x00007f92e93c46aa in start_thread (arg=0x7f9280853700) at pthread_create.c:333
#6  0x00007f92eb691eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f92ebca6780 (LWP 2760)):
[KCrash Handler]
#6  0x00007f92c9bf7030 in KNotification::flags() const () at /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#7  0x00007f92c9c15d49 in  () at /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#8  0x00007f92c9c1c225 in  () at /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#9  0x00007f92e9bfc9c9 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f92c94953ad in  () at /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#11 0x00007f92e9bfd73a in QObject::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f92eb03fb2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#13 0x00007f92eb045000 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#14 0x00007f92e9bcbc2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f92e9bcdc9b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f92e9c24843 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f92e8ea5c3d in g_main_context_dispatch (context=0x7f92d80016f0) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3122
#18 0x00007f92e8ea5c3d in g_main_context_dispatch (context=context@entry=0x7f92d80016f0) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3737
#19 0x00007f92e8ea5f20 in g_main_context_iterate (context=context@entry=0x7f92d80016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3808
#20 0x00007f92e8ea5fcc in g_main_context_iteration (context=0x7f92d80016f0, may_block=1) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3869
#21 0x00007f92e9c24c57 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f92e9bc93e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f92e9bd102c in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f92eb962321 in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_kded5.so
#25 0x00007f92eb5aba40 in __libc_start_main (main=0x400720 <main>, argc=1, argv=0x7fffc8f08e28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc8f08e18) at libc-start.c:289
#26 0x0000000000400759 in _start ()

Reported using DrKonqi
Comment 1 Martin Klapetek 2015-09-03 14:44:52 UTC
Thanks for the report

This is already fixed in KDE Frameworks 5.13, please update.

*** This bug has been marked as a duplicate of bug 348414 ***