Bug 351044

Summary: KWin crashes when dragging Window to another Workspace at screen edge (only with compositing enabled)
Product: [Plasma] kwin Reporter: MartinV <fizbaum>
Component: compositingAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 5.3.0   
Target Milestone: ---   
Platform: Debian stable   
OS: Linux   
Latest Commit: Version Fixed In:

Description MartinV 2015-08-06 20:46:02 UTC
When moving a Window to another Workspace (that means: drag&drop, changing the workspace when the mouse pointer reaches the screen edge), KWin crashes and shows the "Problem report"-window.
This only happens with compositing enabled.



Reproducible: Always

Steps to Reproduce:
1. Terminal: kwin_x11 --replace
2. Grab Terminal-Window and move to egde of screen to switch workspace


Actual Results:  
1. kwin crashes
2. crash report assistent appears
3. kwin restarts automatically
4. window is on new workspace

Expected Results:  
window appears on new workspace without a crash :)

System: Tanglu (Debian 8-based) 
Desktop: XFCE 4.10 with KWin instead of xfwm4. 
Kernel: 4.0.0-2-686-pae. 
lspci -nnk:  00:02.0 VGA compatible controller [0300]: 
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
	Subsystem: Hewlett-Packard Company Device [103c:30dd]
	Kernel driver in use: i915

kwin-dbg and qtbase5-dbg are installed, but the crash report assistent is still missing them.

Terminal-Output of kwin--replace until crash: http://pastebin.com/W9sY0FWM
Backtrace: http://pastebin.com/TWmfV9DK
Comment 1 Thomas L├╝bking 2015-08-06 20:58:50 UTC
In general, please never use pastebin for important information on bugs.
Backtraces belongs into the posts, everything else to the attachments.

----

Application: KWin (kwin_x11), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/i686/cmov/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1987840 (LWP 25818))]

Thread 3 (Thread 0xae50cb40 (LWP 25826)):
#0  0xb7718be0 in __kernel_vsyscall ()
#1  0xb7639c52 in clock_gettime () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#2  0xb60e9c98 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#3  0xb62cc231 in QTimerInfoList::updateCurrentTime() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#4  0xb62cc744 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb62cbda8 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb6270a03 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb6270e6a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb604451d in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb4cdb06f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#10 0xb604991b in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb726defb in start_thread () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#12 0xb762c62e in clone () from /lib/i386-linux-gnu/i686/cmov/libc.so.6

Thread 2 (Thread 0xab800b40 (LWP 25828)):
#0  0xb7718be0 in __kernel_vsyscall ()
#1  0xb7271c4b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#2  0xb76391bc in pthread_cond_wait () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#3  0xb574f4e4 in ?? () from /usr/lib/i386-linux-gnu/libQt5Script.so.5
#4  0xb574f52c in ?? () from /usr/lib/i386-linux-gnu/libQt5Script.so.5
#5  0xb726defb in start_thread () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#6  0xb762c62e in clone () from /lib/i386-linux-gnu/i686/cmov/libc.so.6

Thread 1 (Thread 0xb1987840 (LWP 25818)):
[KCrash Handler]
#7  0xb7718be0 in __kernel_vsyscall ()
#8  0xb7571307 in raise () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#9  0xb75729c3 in abort () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#10 0xb6035e41 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb5e7598e in KWin::WindowQuad::makeSubQuad(double, double, double, double) const () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#12 0xb7388db0 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#13 0xb73893b2 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#14 0xb738f5c4 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#15 0xb738f7b8 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#16 0xb73a91e5 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#17 0xb5e71b1e in KWin::Effect::drawWindow(KWin::EffectWindow*, int, QRegion, KWin::WindowPaintData&) () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#18 0xb73a9188 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#19 0xb5e71b1e in KWin::Effect::drawWindow(KWin::EffectWindow*, int, QRegion, KWin::WindowPaintData&) () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#20 0xb73a9188 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#21 0xb5e71b1e in KWin::Effect::drawWindow(KWin::EffectWindow*, int, QRegion, KWin::WindowPaintData&) () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#22 0xb73a9188 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#23 0xb736c71e in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#24 0xb73a9045 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#25 0xb5d812bd in ?? () from /usr/lib/i386-linux-gnu/libkwin4_effect_builtins.so.1
#26 0xb73a8ff8 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#27 0xb5e811e1 in KWin::AnimationEffect::paintWindow(KWin::EffectWindow*, int, QRegion, KWin::WindowPaintData&) () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#28 0xb73a8ff8 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#29 0xb5dcd2d2 in ?? () from /usr/lib/i386-linux-gnu/libkwin4_effect_builtins.so.1
#30 0xb73a8ff8 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#31 0xb7371899 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#32 0xb736e91a in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#33 0xb7384919 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#34 0xb736c11e in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#35 0xb73a8dbf in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#36 0xb5d80ef7 in ?? () from /usr/lib/i386-linux-gnu/libkwin4_effect_builtins.so.1
#37 0xb5d84a7c in ?? () from /usr/lib/i386-linux-gnu/libkwin4_effect_builtins.so.1
#38 0xb73a8d7a in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#39 0xb5e7188f in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#40 0xb73a8d7a in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#41 0xb5e7188f in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib/i386-linux-gnu/libkwineffects.so.6
#42 0xb73a8d7a in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#43 0xb736bd3e in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#44 0xb738a8e6 in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#45 0xb73634ac in ?? () from /usr/lib/i386-linux-gnu/libkwin.so.5
#46 0xb62a6efe in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#47 0xb6b7028a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#48 0xb6b75b31 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#49 0xb730476a in KWin::Application::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libkwin.so.5
#50 0xb62737fa in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#51 0xb62cd718 in QTimerInfoList::activateTimers() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#52 0xb62cb431 in QEventDispatcherUNIX::activateTimers() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#53 0xb62cbdd4 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#54 0xb17aacef in ?? () from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/libqxcb.so
#55 0xb6270a03 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#56 0xb6270e6a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#57 0xb6278f85 in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#58 0xb65acb31 in QGuiApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5
#59 0xb6b6bd84 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#60 0xb76f1492 in kdemain () from /usr/lib/i386-linux-gnu/libkdeinit5_kwin_x11.so
#61 0x08048607 in main ()

*** This bug has been marked as a duplicate of bug 338972 ***