Bug 348313

Summary: system settings crashes when opening Application Style -> Window Decorations
Product: kde Reporter: cro22
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: olivier
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description cro22 2015-05-27 14:21:20 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

Installed a couple of window decorations styles and now when I open system settings -> application style -> window decorations it crashes after a second or two.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa9c2ab2780 (LWP 11709))]

Thread 5 (Thread 0x7fa9b2101700 (LWP 11710)):
#0  0x00007fa9bf21d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa9bd537b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fa9bd53964f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fa9b464c099 in QXcbEventReader::run (this=0x23d7b90) at qxcbconnection.cpp:1105
#4  0x00007fa9bf89eb0e in QThreadPrivate::start (arg=0x23d7b90) at thread/qthread_unix.cpp:337
#5  0x00007fa9bc4516aa in start_thread (arg=0x7fa9b2101700) at pthread_create.c:333
#6  0x00007fa9bf228eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fa9a2dd7700 (LWP 11711)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fa9a5e144fb in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007fa9a5e13c87 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007fa9bc4516aa in start_thread (arg=0x7fa9a2dd7700) at pthread_create.c:333
#4  0x00007fa9bf228eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fa99f4b3700 (LWP 11713)):
#0  0x00007fa9bf21d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa9bbf32ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa9bbf32fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa9bfb35c6c in QEventDispatcherGlib::processEvents (this=0x7fa99814afb0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fa9bfada3e2 in QEventLoop::exec (this=this@entry=0x7fa99f4b2e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fa9bf899b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fa9be864f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fa9bf89eb0e in QThreadPrivate::start (arg=0x2a476a0) at thread/qthread_unix.cpp:337
#8  0x00007fa9bc4516aa in start_thread (arg=0x7fa99f4b3700) at pthread_create.c:333
#9  0x00007fa9bf228eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fa9970e7700 (LWP 11714)):
#0  0x00007fa9bf21949d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa9bbf762f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa9bbf3296c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa9bbf32e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa9bbf32fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa9bfb35c6c in QEventDispatcherGlib::processEvents (this=0x7fa9900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007fa9bfada3e2 in QEventLoop::exec (this=this@entry=0x7fa9970e6e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007fa9bf899b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007fa9be864f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007fa9bf89eb0e in QThreadPrivate::start (arg=0x2e18a10) at thread/qthread_unix.cpp:337
#10 0x00007fa9bc4516aa in start_thread (arg=0x7fa9970e7700) at pthread_create.c:333
#11 0x00007fa9bf228eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fa9c2ab2780 (LWP 11709)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007fa9be2e9628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fa9be2e8d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fa99db9ac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4760e60, oldNode=0x4864030) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fa9be33c4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fa9be33d4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fa9be33dd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fa9be30cf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fa9be30d979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fa9c08c8b2c in QApplicationPrivate::notify_helper (this=0x23bcb10, receiver=0x2737e40, e=0x7ffed966e660) at kernel/qapplication.cpp:3720
#16 0x00007fa9c08ce000 in QApplication::notify (this=0x7ffed966e9d0, receiver=0x2737e40, e=0x7ffed966e660) at kernel/qapplication.cpp:3503
#17 0x00007fa9bfadcc2b in QCoreApplication::notifyInternal (this=0x7ffed966e9d0, receiver=0x2737e40, event=event@entry=0x7ffed966e660) at kernel/qcoreapplication.cpp:935
#18 0x00007fa9bfb34ae5 in sendEvent (event=0x7ffed966e660, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x24052f0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fa9bfb34f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fa9bbf32c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fa9bbf32f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fa9bbf32fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fa9bfb35c57 in QEventDispatcherGlib::processEvents (this=0x2419800, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fa9bfada3e2 in QEventLoop::exec (this=this@entry=0x7ffed966e8b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fa9bfae202c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fa9c030331c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fa9c08c47a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-31 13:52:51 UTC

*** This bug has been marked as a duplicate of bug 345675 ***
Comment 2 Olivier Churlaud 2016-06-20 22:17:51 UTC
Git commit 8c15258b28870b6d9990b24f87ce913e2049bac8 by Olivier CHURLAUD.
Committed on 20/06/2016 at 22:17.
Pushed by ochurlaud into branch 'master'.

Disable non SSL connections in wikipedia applet.

REVIEW: 128248

M  +2    -1    ChangeLog
M  +1    -6    src/context/applets/wikipedia/WikipediaApplet.cpp
M  +0    -1    src/context/applets/wikipedia/WikipediaApplet_p.h
M  +0    -7    src/context/applets/wikipedia/wikipediaGeneralSettings.ui
M  +3    -15   src/context/engines/wikipedia/WikipediaEngine.cpp

http://commits.kde.org/amarok/8c15258b28870b6d9990b24f87ce913e2049bac8
Comment 3 Christoph Feck 2017-04-27 01:02:49 UTC

*** This bug has been marked as a duplicate of bug 345675 ***