Bug 347679

Summary: Kdeinit is crashing when trying to connect with kde telepathy
Product: [I don't know] kde Reporter: Sadako Sasaki <sadako>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Sadako Sasaki 2015-05-13 18:14:05 UTC
Application: kdeinit5 ()

Qt Version: 5.4.1
Operating System: Linux 3.19.0-17-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
using the plasmoid to connect to my telepathy kde messenger		
- Unusual behavior I noticed:
kdeinit is crashing always and the messenger cant connect.

The crash can be reproduced every time.

-- Backtrace:
Application: kdeinit5 (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f126d689780 (LWP 1544))]

Thread 6 (Thread 0x7f1257c72700 (LWP 1547)):
#0  0x00007f126bd8f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f126a1cab72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f126a1cc64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f125aa39099 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#4  0x00007f126c101b0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f126991e6aa in start_thread (arg=0x7f1257c72700) at pthread_create.c:333
#6  0x00007f126bd9aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f124f547700 (LWP 1553)):
#0  __lll_lock_wait () at ../sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:135
#1  0x00007f1269920d82 in __GI___pthread_mutex_lock (mutex=0x7f126b5e6a50) at ../nptl/pthread_mutex_lock.c:115
#2  0x00007f126b35c310 in ?? () from /usr/lib/nvidia-346/libGL.so.1
#3  0x00007f126b35fc31 in ?? () from /usr/lib/nvidia-346/libGL.so.1
#4  0x00007f126b36002b in ?? () from /usr/lib/nvidia-346/libGL.so.1
#5  0x00007f1268394fc0 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#6  0x00007f1268f052f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f1268ec196c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f1268ec1e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f1268ec2242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f1254121ae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#11 0x00007f1268ee8955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f126991e6aa in start_thread (arg=0x7f124f547700) at pthread_create.c:333
#13 0x00007f126bd9aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f123ffff700 (LWP 1606)):
#0  0x00007f126bd8f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1268ec1ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1268ec1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f126c398c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f126c33d3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f126c0fcb44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f124c1d8cf7 in KCupsConnection::run() () from /usr/lib/x86_64-linux-gnu/libkcupslib.so
#7  0x00007f126c101b0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f126991e6aa in start_thread (arg=0x7f123ffff700) at pthread_create.c:333
#9  0x00007f126bd9aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f123f7fe700 (LWP 1607)):
#0  0x00007f126bd8b49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1268394f45 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#2  0x00007f1268f052f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1268ec196c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1268ec1e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1268ec1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f126c398c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f126c33d3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f126c0fcb44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f126c101b0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f126991e6aa in start_thread (arg=0x7f123f7fe700) at pthread_create.c:333
#11 0x00007f126bd9aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f1217fff700 (LWP 2823)):
#0  0x00007f1268f06789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1268ec1fb8 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f126c398c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f126c33d3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f126c0fcb44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f126c101b0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f126991e6aa in start_thread (arg=0x7f1217fff700) at pthread_create.c:333
#7  0x00007f126bd9aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f126d689780 (LWP 1544)):
[KCrash Handler]
#6  ref (this=<optimized out>) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QList (this=0x7f11fbffd818 <QPrinterInfoPrivate::shared_null+24>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:121
#8  QPrinterInfoPrivate (name=..., this=0x7f11fbffd800 <QPrinterInfoPrivate::shared_null>) at painting/qprinterinfo_p.h:71
#9  __static_initialization_and_destruction_0 (__initialize_p=1, __priority=65535) at painting/qprinterinfo.cpp:35
#10 _GLOBAL__sub_I_qprinterinfo.cpp(void) () at painting/qprinterinfo.cpp:163
#11 0x00007f126d4c35ba in call_init (l=<optimized out>, argc=argc@entry=5, argv=argv@entry=0x7ffcec9934f8, env=env@entry=0x21faac0) at dl-init.c:72
#12 0x00007f126d4c36cb in call_init (env=<optimized out>, argv=<optimized out>, argc=<optimized out>, l=<optimized out>) at dl-init.c:30
#13 _dl_init (main_map=main_map@entry=0x5428ec0, argc=5, argv=0x7ffcec9934f8, env=0x21faac0) at dl-init.c:120
#14 0x00007f126d4c8587 in dl_open_worker (a=a@entry=0x7ffcec991438) at dl-open.c:579
#15 0x00007f126d4c3464 in _dl_catch_error (objname=objname@entry=0x7ffcec991428, errstring=errstring@entry=0x7ffcec991430, mallocedp=mallocedp@entry=0x7ffcec991427, operate=operate@entry=0x7f126d4c80a0 <dl_open_worker>, args=args@entry=0x7ffcec991438) at dl-error.c:187
#16 0x00007f126d4c79a3 in _dl_open (file=0x541c5f0 "/usr/lib/vlc/plugins/gui/libqt4_plugin.so", mode=-2147483647, caller_dlopen=0x7f1234438c0f, nsid=-2, argc=<optimized out>, argv=<optimized out>, env=0x21faac0) at dl-open.c:663
#17 0x00007f1269b35fc9 in dlopen_doit (a=a@entry=0x7ffcec991650) at dlopen.c:66
#18 0x00007f126d4c3464 in _dl_catch_error (objname=0x2131e20, errstring=0x2131e28, mallocedp=0x2131e18, operate=0x7f1269b35f70 <dlopen_doit>, args=0x7ffcec991650) at dl-error.c:187
#19 0x00007f1269b3662d in _dlerror_run (operate=operate@entry=0x7f1269b35f70 <dlopen_doit>, args=args@entry=0x7ffcec991650) at dlerror.c:163
#20 0x00007f1269b36061 in __dlopen (file=<optimized out>, mode=<optimized out>) at dlopen.c:87
#21 0x00007f1234438c0f in ?? () from /usr/lib/libvlccore.so.8
#22 0x00007f123441d8bb in ?? () from /usr/lib/libvlccore.so.8
#23 0x00007f123441dbe8 in ?? () from /usr/lib/libvlccore.so.8
#24 0x00007f123441db44 in ?? () from /usr/lib/libvlccore.so.8
#25 0x00007f123441e0c4 in ?? () from /usr/lib/libvlccore.so.8
#26 0x00007f123441e691 in ?? () from /usr/lib/libvlccore.so.8
#27 0x00007f12343a444d in libvlc_InternalInit () from /usr/lib/libvlccore.so.8
#28 0x00007f121437a35b in libvlc_new () from /usr/lib/libvlc.so.5
#29 0x00007f12346cc1cb in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/phonon4qt5_backend/phonon_vlc.so
#30 0x00007f12346a9878 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/phonon4qt5_backend/phonon_vlc.so
#31 0x00007f12346cffd8 in qt_plugin_instance () from /usr/lib/x86_64-linux-gnu/qt5/plugins/phonon4qt5_backend/phonon_vlc.so
#32 0x00007f126c328d9f in QPluginLoader::instance() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x00007f125f60b0e8 in ?? () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#34 0x00007f125f60cd0e in ?? () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#35 0x00007f125f60d641 in ?? () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#36 0x00007f125f60debd in Phonon::Factory::backend(bool) () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#37 0x00007f125f60e4d3 in ?? () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#38 0x00007f125f603a54 in ?? () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#39 0x00007f125f60109e in ?? () from /usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4
#40 0x00007f126107eeaa in ?? () from /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#41 0x00007f1261062b6f in ?? () from /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#42 0x00007f12610612d8 in KNotification::sendEvent() () from /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#43 0x00007f123e6f7b55 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kded_ktp_integration_module.so
#44 0x00007f123e6f8ce6 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kded_ktp_integration_module.so
#45 0x00007f126c3709c9 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#46 0x00007f126c37e6ab in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#47 0x00007f126c3716f3 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#48 0x00007f126a741b2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#49 0x00007f126a747000 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#50 0x00007f126c33fc2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#51 0x00007f126c397ae5 in QTimerInfoList::activateTimers() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#52 0x00007f126c397f61 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#53 0x00007f1268ec1c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#54 0x00007f1268ec1f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#55 0x00007f1268ec1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#56 0x00007f126c398c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#57 0x00007f126c33d3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#58 0x00007f126c34502c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#59 0x00007f125aad5321 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kded5.so
#60 0x0000000000408716 in ?? ()
#61 0x00000000004058e9 in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-16 17:16:32 UTC

*** This bug has been marked as a duplicate of bug 335111 ***