Bug 346279

Summary: Crashes everytime I try to open OpenGl screen
Product: [Applications] kinfocenter Reporter: kamiox
Component: OpenGLAssignee: David Hubner <hubn3rd>
Status: RESOLVED DUPLICATE    
Severity: crash CC: notmart
Priority: NOR    
Version: 5.2.95   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description kamiox 2015-04-16 21:46:08 UTC
App crashes everytime I try to open OpenGl screen from the tree menu

Reproducible: Always

Steps to Reproduce:
1. Run kinfocenter
2. Try to open OpenGL category



Starting program: /usr/bin/kinfocenter 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
kf5.kservice.sycoca: Trying to open ksycoca from "/home/kx/.cache/ksycoca5"
QObject::connect: No such signal QAction::triggered(Qt::MouseButtons,Qt::KeyboardModifiers) in /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/infocenter.cpp:71
QObject::connect:  (sender name:   'search')
kwayland-client: Failed connecting to Wayland display
[New Thread 0x7fffe62a0700 (LWP 8405)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff273b150 in __lll_unlock_elision () from /usr/lib/libpthread.so.0
(gdb) bt
#0  0x00007ffff273b150 in __lll_unlock_elision () from /usr/lib/libpthread.so.0
#1  0x00007ffff19b1875 in _XError () from /usr/lib/libX11.so.6
#2  0x00007ffff1046d57 in glXMakeCurrentReadSGI () from /usr/lib/libGL.so.1
#3  0x00007fffd97e205c in get_gl_info_glx (dpy=dpy@entry=0x10b5ba0, allowDirect=allowDirect@entry=0, l1=l1@entry=0xd366f0, after=after@entry=0x157a0d0, scrnum=0)
    at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/Modules/opengl/opengl.cpp:708
#4  0x00007fffd97e38f0 in GetInfo_OpenGL (treeWidget=0x807780) at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/Modules/opengl/opengl.cpp:937
#5  0x00007fffd97e4291 in KCMOpenGL::KCMOpenGL (this=this@entry=0xdcf690, parent=parent@entry=0x872230) at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/Modules/opengl/opengl.cpp:80
#6  0x00007fffd97e540b in KPluginFactory::createInstance<KCMOpenGL, QWidget> (parentWidget=<optimized out>, parent=0x872230, args=...) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:477
#7  0x00007ffff6adf707 in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib/libKF5CoreAddons.so.5
#8  0x00007ffff7ba7228 in KCModuleLoader::loadModule(KCModuleInfo const&, KCModuleLoader::ErrorReporting, QWidget*, QStringList const&) () from /usr/lib/libKF5KCMUtils.so.5
#9  0x00007ffff7bb007f in ?? () from /usr/lib/libKF5KCMUtils.so.5
#10 0x00007ffff7bb0c75 in KCModuleProxy::realModule() const () from /usr/lib/libKF5KCMUtils.so.5
#11 0x00007ffff7bb0e04 in KCModuleProxy::quickHelp() const () from /usr/lib/libKF5KCMUtils.so.5
#12 0x0000000000416ad3 in KcmContainer::setKcm (this=0x7b0ee0, info=...) at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/kcmcontainer.cpp:86
#13 0x0000000000414a3e in KInfoCenter::setKcm (this=0x6c5490, kcmItem=<optimized out>) at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/infocenter.cpp:205
#14 0x0000000000414b00 in KInfoCenter::itemClickedSlot (this=<optimized out>, item=<optimized out>) at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/infocenter.cpp:199
#15 0x000000000041a4c0 in KInfoCenter::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>)
    at /home/kx/abs/kinfocenter/src/build/moc_infocenter.cpp:85
#16 0x00007ffff59483c9 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#17 0x000000000041a17f in SidePanel::clicked (this=<optimized out>, _t1=0x7c3240, _t1@entry=0x7fffffffd208) at /home/kx/abs/kinfocenter/src/build/moc_sidepanel.cpp:152
#18 0x0000000000415f51 in SidePanel::clickedSlot (this=<optimized out>, index=...) at /home/kx/abs/kinfocenter/src/kinfocenter-5.2.95/sidepanel.cpp:67
#19 0x000000000041a299 in SidePanel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /home/kx/abs/kinfocenter/src/build/moc_sidepanel.cpp:93
#20 0x00007ffff59483c9 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#21 0x00007ffff645a9a5 in QAbstractItemView::clicked(QModelIndex const&) () from /usr/lib/libQt5Widgets.so.5
#22 0x00007ffff6463533 in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5Widgets.so.5
#23 0x00007ffff64aad4b in QTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5Widgets.so.5
#24 0x00007ffff6240e08 in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#25 0x00007ffff633e85e in QFrame::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#26 0x00007ffff6469a3b in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQt5Widgets.so.5
Comment 1 Marco Martin 2015-04-17 07:53:43 UTC
graphics card/graphics drivers?
Comment 2 kamiox 2015-04-17 08:24:05 UTC
Hi @Marco, below is my setup:

uname -a
Linux kx-new 3.19.3-3-ARCH #1 SMP PREEMPT Wed Apr 8 14:10:00 CEST 2015 x86_64 GNU/Linux

lspci -vnn | grep VGA -A 12

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device [17aa:221e]
        Flags: bus master, fast devsel, latency 0, IRQ 27
        Memory at f1000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
        Subsystem: Lenovo Device [17aa:2210]
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208M [GeForce GT 730M] [10de:1290] (rev a1) (prog-if 00 [VGA controller])
        Flags: fast devsel, IRQ 11
        Memory at f0000000 (32-bit, non-prefetchable) [disabled] [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [disabled] [size=256M]
        Memory at d0000000 (64-bit, prefetchable) [disabled] [size=32M]
        I/O ports at 4000 [disabled] [size=128]
        Expansion ROM at <ignored> [disabled]
        Capabilities: <access denied>
        Kernel modules: nouveau, nvidia

glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.3
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.5.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 3 Christoph Feck 2015-05-02 22:05:19 UTC

*** This bug has been marked as a duplicate of bug 344971 ***