Bug 346180

Summary: Plasma Application Style Window Decoration segfaults on certain themes
Product: [Plasma] kwin Reporter: Xen <bugs>
Component: decorationsAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.2.2   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Xen 2015-04-14 17:02:43 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-10-generic x86_64
Distribution: Ubuntu Vivid Vervet (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I had selected a specific theme in the Window Decoration thing. Can you please stop this window from interfering with my typing? I don't want it to show how good I am doing, okay?

Fine, it's gone now. Bug reporting is an anomoly in this system. It drives me crazy.

I had selected a regular theme for the Window Decoration in the application settings thing.

- Custom settings of the application:

The theme I had installed was a  transparent Oxygen theme.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0380fad780 (LWP 29226))]

Thread 4 (Thread 0x7f0371e16700 (LWP 29227)):
#0  0x00007f037d71f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f037c464b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f037c46664f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f0374361099 in QXcbEventReader::run (this=0x1972f60) at qxcbconnection.cpp:1105
#4  0x00007f037dda0b0e in QThreadPrivate::start (arg=0x1972f60) at thread/qthread_unix.cpp:337
#5  0x00007f037b37e6aa in start_thread (arg=0x7f0371e16700) at pthread_create.c:333
#6  0x00007f037d72aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f0360483700 (LWP 29228)):
#0  0x00007f037d71f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f037ae5febc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f037ae5ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f037e037c6c in QEventDispatcherGlib::processEvents (this=0x7f03580008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f037dfdc3e2 in QEventLoop::exec (this=this@entry=0x7f0360482e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f037dd9bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f0360fcff45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f037dda0b0e in QThreadPrivate::start (arg=0x1eab3b0) at thread/qthread_unix.cpp:337
#8  0x00007f037b37e6aa in start_thread (arg=0x7f0360483700) at pthread_create.c:333
#9  0x00007f037d72aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f035ca33700 (LWP 29229)):
#0  0x00007f037aea4798 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f037ae5edf0 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f037ae5fd75 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f037ae5ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f037e037c6c in QEventDispatcherGlib::processEvents (this=0x7f03500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f037dfdc3e2 in QEventLoop::exec (this=this@entry=0x7f035ca32e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f037dd9bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f0360fcff45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f037dda0b0e in QThreadPrivate::start (arg=0x3b2f180) at thread/qthread_unix.cpp:337
#9  0x00007f037b37e6aa in start_thread (arg=0x7f035ca33700) at pthread_create.c:333
#10 0x00007f037d72aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f0380fad780 (LWP 29226)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f036171c628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f036171bd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f035ee7f142 in Plasma::FrameSvgItem::updatePaintNode (this=0x51d53c0, oldNode=0x52eae40) at ../../../../src/declarativeimports/core/framesvgitem.cpp:473
#10 0x00007f036176f4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f03617704cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f0361770d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f036173ff05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f0361740979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f037edc9b2c in QApplicationPrivate::notify_helper (this=0x195b680, receiver=0x1eb5590, e=0x7ffed90064b0) at kernel/qapplication.cpp:3720
#16 0x00007f037edcf000 in QApplication::notify (this=0x7ffed9006820, receiver=0x1eb5590, e=0x7ffed90064b0) at kernel/qapplication.cpp:3503
#17 0x00007f037dfdec2b in QCoreApplication::notifyInternal (this=0x7ffed9006820, receiver=0x1eb5590, event=event@entry=0x7ffed90064b0) at kernel/qcoreapplication.cpp:935
#18 0x00007f037e036ae5 in sendEvent (event=0x7ffed90064b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1999bb0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f037e036f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f037ae5fc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f037ae5ff20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f037ae5ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f037e037c57 in QEventDispatcherGlib::processEvents (this=0x19a4f10, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f037dfdc3e2 in QEventLoop::exec (this=this@entry=0x7ffed9006700, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f037dfe402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f037e80431c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f037edc57a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2015-04-16 19:57:56 UTC

*** This bug has been marked as a duplicate of bug 345675 ***