Bug 341031

Summary: LibLqr detected during build but shown as not supported in components information
Product: digikam Reporter: Philip Johnsson <philip.johnsson>
Component: Portability-CompilationAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: caulier.gilles
Priority: NOR    
Version: 4.5.0   
Target Milestone: ---   
Platform: Kubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 4.6.0

Description Philip Johnsson 2014-11-16 18:45:30 UTC
LibLqr 0.4.2 is detected during build on Ubuntu 14.10 and the tool Transform > Liquid Rescale is working in Digikam but "components information" in Digikam show "LibLqr support: no". Not sure if it's just the components information display window that show it wrong or if some part of digikam besides Liquid Rescale that is missing?

Reproducible: Always


Actual Results:  
digiKam version 4.5.0
CPU cores: 8
Demosaic GPL2 pack support: Unknown
Demosaic GPL3 pack support: Unknown
Exiv2 can write to Jp2: Yes
Exiv2 can write to Jpeg: Yes
Exiv2 can write to Pgf: Yes
Exiv2 can write to Png: Yes
Exiv2 can write to Tiff: Yes
Exiv2 supports XMP metadata: Yes
LibCImg: 130
LibEigen: 3.2.1
LibExiv2: 0.24
LibJPEG: 80
LibJasper: 1.900.1
LibKDE: 4.14.2
LibKExiv2: 2.4.0
LibKGeoMap: 3.0.0
LibKdcraw: 2.4.2
LibLCMS: 2060
LibLensFun: 0.2.8-0
LibLqr support: no
LibPGF: 6.12.24
LibPNG: 1.2.51
LibQt: 4.8.6
LibRaw: 0.16.0
LibTIFF: LIBTIFF, Version 4.0.3 Copyright (c) 1988-1996 Sam Leffler Copyright (c) 1991-1996 Silicon Graphics, Inc.
Marble Widget: 0.19.0 (stable release)
Parallelized demosaicing: Unknown
RawSpeed codec support: Unknown
Baloo support: Yes
Database backend: QSQLITE
Kdepimlibs support: Yes
Kipi-Plugins: 4.5.0
LibGphoto2: 2.5.4
LibKface: 3.5.0
LibKipi: 2.2.0
LibOpenCV: 2.4.9
Sqlite2 support: Yes


Expected Results:  
LibLqr support: Yes

Have liblqr 0.4.2 installed and detected during build.

--  digiKam 4.5.0 dependencies results   <http://www.digikam.org>
-- 
--  Qt4 SQL module found..................... YES
--  MySQL Server found....................... YES
--  MySQL install_db tool found.............. YES
--  libqt found.............................. YES
--  libkde found............................. YES
--  libjpeg found............................ YES
--  libtiff found............................ YES
--  libpng found............................. YES
--  liblcms found............................ YES
--  libboostgraph found...................... YES
--  libkexiv2 found.......................... YES
--  libkdcraw found.......................... YES
--  libpgf found............................. YES
--  libopencv found.......................... YES
--  libkipi found............................ YES (optional)
--  libkface found........................... YES (optional)
--  libkgeomap found......................... YES (optional)
--  libkdepimlibs found...................... YES (optional)
--  libjasper found.......................... YES (optional)
--  liblensfun found......................... YES (optional)
--  liblqr-1 found........................... YES (optional)
--  libeigen3 found.......................... YES (optional)
--  libgphoto2 found......................... YES (optional)
--  libbaloo found........................... YES (optional)
--  libsqlite2 found......................... YES (optional)
--  doxygen found............................ YES (optional)
--  digiKam can be compiled.................. YES
Comment 1 caulier.gilles 2014-11-17 11:05:20 UTC
Git commit 1121a7266a43589a89e007a137c11a6fd41fa189 by Gilles Caulier.
Committed on 17/11/2014 at 11:04.
Pushed by cgilles into branch 'master'.

inverted report about lqr-1 support into lib info dialog

M  +1    -1    libs/dialogs/libsinfodlg.cpp

http://commits.kde.org/digikam/1121a7266a43589a89e007a137c11a6fd41fa189